通达信《安全信息》提示商业版副图指标源码

通达信安全信息提示商业版有两个版本,分别为完整版和快捷版本,以下是安全信息快捷版源码,完全版本请下载附件中的.TN6文件导入通达信软件获取。

通达信《安全信息》提示副图指标源码:

DRAWGBK(C>0,RGB(9,40,120),RGB(0,40,120),0,0,1);
{—————————————————————————————————————};
VRA1参:=(VOL*CLOSE);
VRA2参:=EMA(VRA1参,13)/EMA(VOL,13);
VRA3参:=EMA(VRA1参,60)/EMA(VOL,60);
VRA4参:=EMA((VRA2参+VRA3参)/2,3);{ WWW.ZHIBIAO123.CN}
分界线:=MA(((EMA(C,30)*2+MA(C,60))/3+VRA4参)/2,1);
行情类型:=IF(CLOSE>分界线,’ ★行情类型: 突破;’,’ ★行情类型:反弹;’);
{—————————————————————————————————————};
流通盘:=STRCAT(STRCAT(‘ 流通盘: ‘,CON2STR(CAPITAL/1000000,2)),’亿’);
市值:=STRCAT(STRCAT(‘ 市值: ‘,CON2STR((CAPITAL/1000000)*C,2)),’亿’);
全流通:=STRCAT(STRCAT(‘ 全流通: ‘,CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2)),’%’);
净利润增长率:=STRCAT(STRCAT(‘ 同比增长 ‘,CON2STR(FINANCE(43),2)),’%’);
主营利润率:=STRCAT(‘ 主营利润率: ‘,CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当日换手:=STRCAT(STRCAT(‘ 当日换手: ‘,CON2STR(VOL/CAPITAL*100,2)),’%’);
五日换手:=STRCAT(STRCAT(‘ 五日换手: ‘,CON2STR(SUM(VOL/CAPITAL*100,5),2)),’%’);
市盈率:=STRCAT(‘ 市盈率: ‘,CON2STR(C/FINANCE(33),2));
换手:=STRCAT(当日换手,五日换手);{ WWW.ZHIBIAO123.CN}
开盘金额:=STRCAT(STRCAT(‘ 竞价: ‘,CON2STR(DYNAINFO(15)/10000,0)),’万’);
{ WWW.ZHIBIAO123.CN}
{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;{ WWW.ZHIBIAO123.CN}
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;{ WWW.ZHIBIAO123.CN}
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,’重警’,IF(Z值>=1.2 AND Z值<2.6,’轻警’,’无警’));
财务预警:=STRCAT(STRCAT(预警,’-Z值: ‘),CON2STR(Z值,3));
{ WWW.ZHIBIAO123.CN}
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
转送:=每股未分配>=2 AND 每股公积金>=2;
高送转:=IF(转送,’ 转送’,’ 不转送’);
{ WWW.ZHIBIAO123.CN}
基本面:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(流通盘,市值),全流通),净利润增长率),主营利润率),市盈率);
财基面:=STRCAT(财务预警,基本面);

概念板块:=STRCAT(‘热点题材: ‘,GNBLOCK);
地域板块:=STRCAT(‘ 地域权重: ‘,DYBLOCK);
板块:=STRCAT(概念板块,地域板块);
{ WWW.ZHIBIAO123.CN}
技术面:=STRCAT(STRCAT(STRCAT(高送转,换手),开盘金额),行情类型);
安全信息:=STRCAT(财基面,技术面);
{—————————————————————————————————————};
DRAWTEXT_FIX(ISLASTBAR,0.00,0,0,安全信息),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.24,0,板块),COLORWHITE;

通达信《安全信息》提示副图案例截图:

安全信息

安全信息

资源下载
下载价格8 金币
VIP免费
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/4149.html,转载请注明出处。
通达信【战狼竞价排序V8】系统直达竞价核心抓涨停指标公式源码
通达信【战狼竞价排序V8】系统直达竞价核心抓涨停指标公式源码
9分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录