通达信《黄龙5更》副图+选股指标公式源码

通达信黄龙5更副图指标公式源码:

MA5:=MA(C,5);
MA10:=MA(C,10);MA20:=MA(C,20);
MA30:=MA(C,30);MA40:=MA(C,40);
MA60:=MA(C,60);
MA120:=MA(C,120);
LC:=REF(C,1);{ WWW.ZHIBIAO123.CN}
ZT:=C>REF(C,1)*1.095 AND C=H;
一字停:=C/REF(C,1)<=1.09 AND O=C AND C=L;
十字星:=H<>L AND C=OPEN AND H>C;
K上三分:=(MAX(C,O)*2+MIN(O,C))/3;
K下三分:=(MIN(C,O)*2+MAX(C,O))/3;
ZDF20:=(HHV(MAX(C,O),20)-LLV(MIN(C,O),20))/LLV(MIN(C,O),20)*100;
ZDF9:=(HHV(MAX(C,O),9)-LLV(MIN(C,O),9))/LLV(MIN(C,O),9)*100;
均线大:=MAX(MA30,MAX(MA60,MA120));{ WWW.ZHIBIAO123.CN}
均线小:=MIN(MA30,MIN(MA60,MA120));
均线中:=IF(MA30<>均线大 AND MA30<>均线小,MA30,IF(MA60<>均线大 AND MA60<>均线小,MA60,MA120));
均线差:=(均线大-均线小)/均线小*100;{ WWW.ZHIBIAO123.CN}
大中均差:=(均线大-均线中)/均线中*100;
中小均差:=(均线中-均线小)/均线小*100;
三均倍差:=MAX(大中均差,中小均差)/MIN(大中均差,中小均差);
最高均线:=MAX(均线大,MAX(MAX(MA5,MA10),MAX(MA20,MA40)));
小无压:=C*1.01>HHV(MAX(C,O),4);
{—————————————————————————————————————};
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR10:=REF(VAR6 OR VAR7 OR VAR8,1) AND VAR1;
VAR11:=VAR10 AND CLOSE>OPEN;{ WWW.ZHIBIAO123.CN}
VAR12:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF (C,2);
VAR13:=REF(VAR1 OR VAR3 OR VAR4 OR VAR5,1) AND VAR6 AND VAR12=0 AND NOT(REF(C,3)=LLV(C,4));
VAR14:=(REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5,1)) AND VAR6 AND VAR13=0;
VAR15:=C/OPEN>1.04 AND C<SMA(HIGH,19,3) AND C>REF(C,1);
VAR16:=IF(C>MA(C,4),1,0)+IF(C<MA(C,4),-1,0)+IF(MA(C,5)>REF(MA(C,5),1),1,0)+IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR17:=VAR16=-2 AND C>O;{ WWW.ZHIBIAO123.CN}
VAR18:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VAR19:=(CROSS(VAR18,EMA(VAR18,2)) AND VAR18<=0.05 AND (C/REF(C,1)>0.035));
VAR20:=IF(C>MA(C,4),1,0);
VAR21:=IF(C<MA(C,4),-1,0);
VAR22:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
VAR23:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR24:=VAR20+VAR21+VAR22+VAR23;
VAR25:=VAR24=2 AND C<O;{ WWW.ZHIBIAO123.CN}
VAR26:=(VAR7 OR VAR8 OR VAR9) AND C>OPEN AND VAR17=0 AND VAR12=0;
VAR27:=CLOSE>OPEN AND VAR11=0 AND VAR15=0 AND VAR17=0 AND VAR19=0 AND VAR26=0 AND VAR12=0;
VAR28:=(VAR6 OR VAR7 OR VAR8 OR VAR9) AND VAR12=0 AND VAR17=0 AND VAR19=0 AND VAR13=0;
VAR29:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;
VAR30:=(H-MAX(C,O))/MAX(C,O)*100;
VAR31:=(MIN(C,O)-L)/L*100;{ WWW.ZHIBIAO123.CN}
VAR32:=(REF(MIN(C,O),1)-MAX(C,O))/MAX(C,O)*100;
VAR33:=(HHV(MAX(C,O),2)-LLV(MAX(C,O),2))/LLV(MAX(C,O),2)*100;
VAR34:=(HHV(MIN(C,O),2)-LLV(MIN(C,O),2))/LLV(MIN(C,O),2)*100;
VAR35:=(HHV(MAX(C,O),3)-LLV(MAX(C,O),3))/LLV(MAX(C,O),3)*100;
VAR36:=(HHV(MIN(C,O),3)-LLV(MIN(C,O),3))/LLV(MIN(C,O),3)*100;
VAR37:=(HHV(MAX(C,O),4)-LLV(MAX(C,O),4))/LLV(MAX(C,O),4)*100;
VAR38:=(HHV(MIN(C,O),4)-LLV(MIN(C,O),4))/LLV(MIN(C,O),4)*100;
VAR39:=MA(REF(LLV(C,30),1),2);{ WWW.ZHIBIAO123.CN}
VAR40:=MA(REF(HHV(C,30),1),2);
VAR41:=BARSLASTCOUNT(VAR40=REF(VAR40,1));
VAR42:=BARSLASTCOUNT(VAR39=REF(VAR39,1));
VAR43:=BARSLASTCOUNT(VAR40>REF(VAR40,1));
VAR44:=BARSLASTCOUNT(VAR39<REF(VAR39,1));
VAR45:=BARSLASTCOUNT(VAR39>REF(VAR39,1));
VAR46:=REF(VAR39,1)>REF(VAR39,2) AND VAR39<REF(VAR39,1);
VAR47:=REF(VAR39,3)<REF(VAR39,2) AND REF(VAR39,1)=REF(VAR39,2) AND VAR39<REF(VAR39,1);
VAR48:=ATAN((VAR39/REF(VAR39,1)-1)*100)*180/3.1416;
VAR49:=(MIN(C,O)-VAR39)/VAR39*100;
VAR50:=(最高均线-C)/C*100;{ WWW.ZHIBIAO123.CN}
VAR51:=MA120>MA60 AND MA60>MA30;
VAR52:=MA30>MA60 AND MA60>MA120;
VAR53:=MA30>REF(MA30,1) AND MA60>REF(MA60,1) AND MA120>=REF(MA120,1);
VAR54:=MA30<REF(MA30,1) AND MA60<REF(MA60,1) AND MA120<=REF(MA120,1);
VAR55:=BARSLASTCOUNT(VAR52 AND VAR53)>=7;
VAR56:=BARSLASTCOUNT(VAR51 AND VAR54)>=7;
VAR57:=BARSLASTCOUNT(MIN(C,O)>=REF(MIN(C,O),1) AND MAX(C,O)>REF(MAX(C,O),1))>=2;
VAR58:=BARSLASTCOUNT(MIN(C,O)<=REF(MIN(C,O),1) AND MAX(C,O)<REF(MAX(C,O),1))>=2;
VAR59:=VAR58 AND BARSLASTCOUNT(VAR29>1.5 AND VAR29<7 AND C<O)>=3 AND COUNT(VAR29>3.2,3)>=2;
VAR60:=BARSLASTCOUNT(MIN(C,O)>=REF(MIN(C,O),1) AND MAX(C,O)>REF(MAX(C,O),1))>=3;
VAR61:=BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1) AND MIN(C,O)<=REF(MIN(C,O),1))>=3;
VAR62:=VAR58 AND REF(VAR13,2);
VAR63:=VAR58 AND REF(VAR14,2);{ WWW.ZHIBIAO123.CN}
VAR64:=VAR61 AND REF(VAR13 AND VAR29<8.4,3) AND BARSLASTCOUNT(VAR29>0.2)>=4;
VAR65:=VAR61 AND REF(VAR14,3);{ WWW.ZHIBIAO123.CN}
VAR66:=BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1) AND MIN(C,O)<REF(MIN(C,O),1) AND VAR29<REF(VAR29,1))>=2;
VAR67:=C>OPEN AND ((C<MA120 AND CROSS(C,MA120*0.995)) OR (C>MA120 AND CROSS(C,MA120))) AND C<MA120*1.0051 AND REF(C<MA120,1);
VAR68:=C>OPEN AND CROSS(C,MA60*0.995) AND C<MA60*1.005 AND REF(C<MA60,1);
VAR69:=C>OPEN AND CROSS(C,MA40*0.995) AND C<MA40*1.007 AND REF(C<MA40,1);{ WWW.ZHIBIAO123.CN}
VAR70:=(C>OPEN OR VAR19 OR (VAR29<0.5 AND VAR25)) AND CROSS(MAX(C,O),MA30*0.995) AND MAX(C,O)<MA30*1.005 AND REF(MAX(C,O)<MA30,1);
VAR71:=(C>OPEN OR VAR19) AND CROSS(MAX(C,O),MA20*0.995) AND MAX(C,O)<MA20*1.005 AND REF(MAX(C,O)<MA20,1);
VAR72:=C>OPEN AND CROSS(C,MA10*0.995) AND C<MA10*1.005 AND REF(C<MA10,1);{ WWW.ZHIBIAO123.CN}
VAR73:=C>OPEN AND CROSS(C,最高均线*0.995) AND C<最高均线*1.005 AND REF(C<最高均线,1);
VAR74:=CROSS(C,VAR40*0.993) AND C<VAR40*1.005 AND REF(BARSLASTCOUNT(C<VAR40)>6,1) AND VAR41>=4;
VAR75:=C>OPEN AND H*1.005>MA120 AND H<MA120*1.005;{ WWW.ZHIBIAO123.CN}
VAR76:=C>OPEN AND H*1.007>MA60 AND H<MA60*1.007;{ WWW.ZHIBIAO123.CN}
VAR77:=C>OPEN AND H*1.005>MA10 AND H<MA10*1.005;
VAR78:=COUNT(BARSLASTCOUNT(MAX(C,O)>MA30)>21,4)>=1 AND BARSLASTCOUNT(MAX(C,O)<MA30)>=2;
VAR79:=COUNT(BARSLASTCOUNT(MIN(C,O)>MA60)>40,4)>=1 AND BARSLASTCOUNT(MAX(C,O)<MA60)>=2;{ WWW.ZHIBIAO123.CN}
VAR80:=BARSLASTCOUNT((MIN(C,O)>均线大 AND 均线大*1.01>MIN(C,O)) OR (MIN(C,O)<均线大 AND MAX(C,O)>均线大))>=3 AND BARSLASTCOUNT(MAX(C,O)>均线大)>=3;
VAR81:=(VAR29>0.74 AND VAR31>6.5 AND VAR31>VAR29*3) OR (VAR29>1.74 AND VAR29<3.5 AND VAR31>8.1) OR (VAR29<5 AND VAR31>9 AND VAR31>VAR30*3);
VAR82:=VAR29>0.3 AND VAR29<0.74 AND VAR31>VAR29*7 AND VAR31>VAR30*4;{ WWW.ZHIBIAO123.CN}
VAR83:=REF(VAR11 AND VAR29>3,1) AND VAR27 AND C/REF(O,1)>1.08 AND C=HHV(C,40);
VAR84:=BARSLASTCOUNT(VAR29<3)>=3 AND VAR36<1.4 AND VAR35<2.1 AND COUNT(VAR83,7)=1 AND HHV(MAX(C,O),3)*1.012>REF(C,BARSLAST(VAR83)) AND LLV(MIN(C,O),3)*1.012>REF(O,BARSLAST(VAR83));
VAR85:=(VAR11 OR VAR27) AND VAR29>5.4 AND VAR29<8.1;{ WWW.ZHIBIAO123.CN}
VAR86:=BARSLASTCOUNT(VAR29<3)>=3 AND VAR36<1.4 AND VAR35<2.1 AND COUNT(VAR85,7)=1 AND HHV(MAX(C,O),3)*1.012>REF(C,BARSLAST(VAR85)) AND LLV(MIN(C,O),3)*1.012>REF(K上三分,BARSLAST(VAR85));
VAR87:=(VAR11 OR VAR27) AND VAR29>8.1;{ WWW.ZHIBIAO123.CN}
VAR88:=BARSLASTCOUNT(VAR29<3.6)>=3 AND VAR36<3.6 AND VAR35<3.6 AND COUNT(VAR87,7)=1 AND HHV(MAX(C,O),3)*1.012>REF(C,BARSLAST(VAR87)) AND LLV(MIN(C,O),3)*1.012>REF(K上三分,BARSLAST(VAR87));
VAR89:=VAR84 OR VAR86 OR VAR88;{ WWW.ZHIBIAO123.CN}
VAR90:=VAR58 AND BARSLASTCOUNT(VAR29>0.7 AND VAR29<2.4)>=3 AND COUNT(VAR29>6.4 AND C>O,7)=1 AND HHV(MAX(C,O),3)<REF(C,BARSLAST(VAR29>6.4 AND C>O))*1.04 AND MIN(C,O)*1.02>REF(O,BARSLAST(VAR29>6.4 AND C>O));
VAR91:=REF(VAR29<2.1 AND VAR30>4.7 AND VAR30>VAR29*3,1) AND VAR29<2.1 AND VAR31>3.6 AND VAR31>VAR29*3 AND MAX(C,O)<REF(MAX(C,O),1);
VAR92:=BARSLASTCOUNT(VAR29>0.4 AND VAR29<1.2)>=2 AND REF(VAR30>VAR29*5 AND VAR30>VAR31*5,1) AND VAR31>VAR29*5 AND VAR31>VAR30*4;
VAR93:=VAR91 OR VAR92;{ WWW.ZHIBIAO123.CN}
VAR94:=ABS(VAR29-REF(VAR29,1))<0.7 AND REF(VAR29*1.7<VAR31 AND VAR31>VAR30*3,1) AND VAR29*1.7<VAR30 AND VAR30>VAR31*3 AND MIN(C,O)*1.005>REF(MAX(C,O),1) AND COUNT(BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1))>=2,4)>=1;
VAR95:=OPEN*0.99<均线小 AND C>均线大;{ WWW.ZHIBIAO123.CN}
VAR96:=REF(VAR29>3 AND VAR13,1) AND ((VAR29>4 AND C>OPEN AND C>REF(MAX(C,O),1)) OR VAR15) AND VAR17=0;
VAR97:=OPEN>LC AND H>=REF(OPEN,1) AND REF(VAR13 AND VAR29>3.6 AND MAX(C,O)=HHV(MAX(C,O),4),1);
VAR98:=VAR11 AND OPEN*0.98<VAR39 AND C>VAR39 AND VAR39<=REF(VAR39,1) AND VAR15=0 AND VAR17=0 AND VAR19=0;
VAR99:=BARSLASTCOUNT(VAR29<1.2 AND VAR25)>=2 AND (VAR34<0.5 OR VAR33<0.5);
VAR100:=BARSLASTCOUNT(VAR29<1.8)>=2 AND COUNT(VAR29>0.74,2)>=1 AND VAR34<0.5;
VAR101:=BARSLASTCOUNT(VAR29<0.74)>=2 AND VAR33<0.5 AND VAR34<0.5;{ WWW.ZHIBIAO123.CN}
VAR102:=十字星 AND REF((VAR11 OR VAR27) AND VAR29<1.4,1) AND VAR33<0.5;
VAR103:=VAR29>3.6 AND C>O AND REF(VAR17 AND VAR29<3,1) AND REF(VAR29<1,2) AND LC>=REF(MAX(C,O),2) AND REF(OPEN,1)<REF(MIN(C,O),2) AND OPEN*0.98<LC AND OPEN*1.02>LC;
VAR104:=VAR29=REF(VAR29,1) AND VAR33=0 AND VAR34=0;{ WWW.ZHIBIAO123.CN}
VAR105:=REF(MAX(C,O)*0.995<VAR39,1) AND C>OPEN AND OPEN*0.995<VAR39 AND C>VAR39 AND VAR44 AND VAR30<VAR29/1.84 AND VAR31<VAR29/2.1;
VAR106:=VAR29<9 AND OPEN<VAR39*1.007 AND C>VAR39 AND VAR30<VAR29/2.1 AND VAR31<VAR29/2.1 AND VAR42>=2;
VAR107:=VAR48>-35 AND VAR48<0 AND OPEN<VAR39*1.007 AND C>VAR39 AND VAR30<VAR29/1.84 AND VAR31<VAR29/2.1;
VAR108:=VAR15 AND VAR29>3.6 AND VAR48<-35 AND REF(MIN(C,O)<VAR39 AND MAX(C,O)>VAR39,1) AND VAR30<VAR29/1.84 AND VAR31<VAR29/2.1;
{—————————————————————————————————————};
VAR109:=VAR76 AND VAR11 AND VAR29<1 AND REF(VAR102,1) AND VAR41>=9 AND VAR42>=9;
VAR110:=VAR76 AND VAR11 AND VAR29<1 AND REF(十字星,1) AND REF(VAR25 AND VAR29>1.2,2) AND 均线大<VAR40*1.05 AND COUNT(均线大>VAR40,4) AND VAR41>=9 AND VAR42>=14;
VAR111:=VAR76 AND VAR11 AND VAR29<3.6 AND REF(VAR13 AND VAR29>1.2,1) AND REF(VAR25 AND VAR29>0.7,2) AND 均线大<VAR40 AND C<均线小 AND VAR41>=14 AND VAR42>=4;
VAR112:=VAR71 AND VAR15 AND 均线大<VAR40 AND REF(VAR17,1) AND C=HHV(MAX(C,O),4) AND COUNT(VAR62,4) AND VAR41>=21 AND VAR45>=1;
VAR113:=VAR72 AND VAR107 AND VAR11 AND VAR15 AND VAR56 AND 均线大<VAR40*1.05 AND VAR41>=2 AND BARSLASTCOUNT(MAX(C,O)>=REF(MAX(C,O),1) AND MIN(C,O)<REF(MIN(C,O),1))>=3;
VAR114:=VAR105 AND VAR15 AND BARSLASTCOUNT(VAR17)=2 AND VAR68 AND MA60=均线小 AND 均线大<VAR40*1.05 AND VAR41>=4 AND COUNT(VAR42>=28,14)>=1;
VAR115:=VAR71 AND COUNT(VAR15,4)>=1 AND VAR41>=24 AND VAR42>=9 AND 均线大>VAR40 AND VAR56;
VAR116:=VAR69 AND VAR15 AND VAR19=0 AND C>REF(MAX(C,O),1) AND 均线大<VAR40 AND VAR51 AND REF(((VAR29>3 AND VAR32>3) OR VAR32>9) AND VAR30>3,1) AND REF(VAR41>=9,1) AND VAR42>=14;
VAR117:=VAR70 AND VAR11 AND BARSLASTCOUNT(VAR29>0 AND VAR29<1)>=4 AND VAR38<1 AND REF(VAR41>=9,1) AND VAR42>=4 AND 均线大<VAR40 AND REF(VAR14 AND VAR29<0.2,1);
VAR118:=VAR67 AND VAR15 AND VAR95 AND (COUNT(VAR64,4)>=1 OR (VAR96 AND C>REF(MAX(C,O),1)));{ WWW.ZHIBIAO123.CN}
VAR119:=BARSLASTCOUNT(VAR67)=2 AND MA120*1.005>最高均线 AND VAR60 AND OPEN>均线小 AND (COUNT(VAR65,4)>=1 OR REF(VAR74 AND CROSS(C,MA60),3));
VAR120:=VAR74 AND REF(COUNT(C<VAR40 AND C*1.005>VAR40,4)>=1,1) AND CROSS(C,MA60) AND VAR57 AND 三均倍差<1.2;
VAR121:=OPEN<VAR39 AND C*1.005>VAR39 AND VAR17 AND VAR29<1.2 AND VAR58 AND REF(VAR14 AND VAR29>4,1) AND VAR45>=3 AND VAR41>=21 AND VAR39/REF(VAR39,14)>1.2;
VAR122:=VAR109 OR VAR110 OR VAR111 OR VAR112 OR VAR113 OR VAR114 OR VAR115 OR VAR116 OR VAR117 OR VAR118 OR VAR119 OR VAR120 OR VAR121;
VAR123:=VAR105 AND VAR15 AND VAR17 AND C>REF(VAR39,1) AND VAR41>=2 AND REF(VAR42>=21,1) AND REF(VAR17 AND VAR29<1 AND H<VAR39,1);
VAR124:=VAR11 AND VAR15 AND VAR29>4 AND VAR107 AND VAR41>=14 AND 均线大<VAR40 AND 均线差<10 AND MA30=均线中 AND 均线小<K下三分;
VAR125:=VAR107 AND VAR15 AND REF(VAR58 AND C<VAR39 AND VAR42>=14 AND VAR29>3,1) AND OPEN<LC AND C>REF(O,1) AND COUNT(VAR41>=28,7)>=1;
VAR126:=VAR106 AND VAR11 AND VAR15 AND REF(VAR61,1) AND C<VAR40 AND VAR51 AND VAR41>=21 AND VAR42>=18 AND 三均倍差<1.5;
VAR127:=VAR15 AND VAR106 AND VAR77 AND 均线大/VAR40>1.1 AND REF(BARSLASTCOUNT(C<O)>=2,1) AND C<REF(O,1) AND COUNT(BARSLASTCOUNT(VAR41)>=4,4) AND VAR42>=2;
VAR128:=VAR19 AND VAR29>3.6 AND REF(VAR15 AND VAR108,3) AND REF(VAR25 AND VAR29>2.7,2) AND VAR37<1.7 AND VAR49<5 AND VAR41>=4 AND VAR42>=3;
VAR129:=VAR19 AND VAR75 AND 小无压 AND MA120<VAR40 AND C*1.01<MA120 AND MA120=最高均线 AND OPEN<均线小 AND COUNT(VAR41>=28,14) AND VAR42>=21 AND 三均倍差<2 AND COUNT(VAR58 AND VAR17,4)>=1;
VAR130:=VAR19 AND VAR29>1.7 AND VAR29<6 AND VAR71 AND REF(VAR98 AND REF(十字星,1),2) AND C<均线小 AND H=C AND BARSLASTCOUNT(均线差<4)>=9;
VAR131:=VAR123 OR VAR124 OR VAR125 OR VAR126 OR VAR127 OR VAR128 OR VAR129 OR VAR130;{ WWW.ZHIBIAO123.CN}
VAR132:=VAR100 AND VAR11 AND REF(VAR26,1) AND REF(VAR17,2) AND 均线大<VAR40*1.05 AND COUNT(VAR41>=21,4) AND VAR42<4 AND VAR39=LLV(VAR39,100);
VAR133:=BARSLASTCOUNT(VAR29<1.5 AND VAR29>0.5)=3 AND VAR38<0.5 AND REF(VAR62,1) AND VAR41>=9 AND VAR42>=4 AND 均线大<VAR40 AND 三均倍差<1.5;
VAR134:=VAR101 AND REF(VAR62 AND VAR17,1) AND VAR34<0.2 AND VAR36<1 AND VAR41>=14 AND VAR44 AND 均线大>VAR40 AND COUNT(VAR45>=2,7)=0;
VAR135:=VAR25 AND VAR29<1.2 AND BARSLASTCOUNT(VAR52 AND VAR53)>=4 AND REF(VAR101,2) AND VAR40/LLV(MAX(C,O),4)<1.05 AND VAR40/OPEN<2 AND C=HHV(C,4) AND VAR41>=9 AND VAR42>=21 AND 大中均差>中小均差;
VAR136:=VAR104 AND REF(C<O AND VAR14=0,1) AND VAR29>0.7 AND COUNT(VAR41>=28,7)>=1 AND VAR40<REF(VAR40,1) AND VAR42>=9 AND VAR73;
VAR137:=BARSLASTCOUNT(VAR104)=2 AND BARSLASTCOUNT(VAR28 AND VAR29<2)>=2 AND VAR41>=9 AND VAR42>=3 AND VAR56;
VAR138:=VAR132 OR VAR133 OR VAR134 OR VAR135 OR VAR136 OR VAR137;{ WWW.ZHIBIAO123.CN}
VAR139:=VAR17 AND VAR15 AND REF(一字停 AND VAR30>4,1) AND C>LC AND COUNT(VAR64,4)>=1 AND VAR41>=14 AND COUNT(VAR42>=18,4)>=1;
VAR140:=VAR15 AND VAR57 AND OPEN<均线中 AND C>最高均线 AND REF(VAR17 AND VAR29<1,2) AND COUNT(VAR41>=27,14)>=1 AND VAR41>=4 AND VAR42>=14;
VAR141:=VAR11 AND VAR15 AND REF(VAR66 AND VAR59 AND VAR61 AND BARSLASTCOUNT(C<O)>=4,1) AND VAR55 AND VAR41>=9 AND VAR42>=2;
VAR142:=VAR11 AND VAR15 AND C=H AND C=HHV(C,4) AND REF(VAR64 AND BARSLASTCOUNT(C<O)>=4 AND COUNT(VAR29>2.7,3)>=2,1) AND VAR52 AND VAR41>=14;
VAR143:=VAR17 AND VAR55 AND O>均线大 AND 均线差<36 AND REF(VAR64 AND BARSLASTCOUNT(C<O)>=4 AND COUNT(VAR29>2.7,3)>=2 AND REF(VAR29>7,3),1);
VAR144:=VAR64 AND VAR29<1 AND REF(VAR66,1) AND BARSLASTCOUNT(C<O)>=4 AND C=LC AND VAR55 AND C>均线大;
VAR145:=VAR11 AND VAR29<1.5 AND REF(VAR17 AND VAR65,1) AND VAR55 AND VAR41>=18 AND VAR45>=4 AND CROSS(MA10,MA5);
VAR146:=VAR139 OR VAR140 OR VAR141 OR VAR142 OR VAR143 OR VAR144 OR VAR145;{ WWW.ZHIBIAO123.CN}
VAR147:=VAR78 AND VAR17 AND COUNT(BARSLASTCOUNT(MAX(C,O)<均线小)>=2,4)=0 AND REF(VAR59,1) AND MIN(O,C)=LLV(MIN(C,O),21) AND VAR32>5.4 AND VAR41>=14 AND VAR45>=4;
VAR148:=VAR79 AND REF(VAR17,1) AND VAR41>=21 AND BARSLASTCOUNT(VAR29<REF(VAR29,1))>=2 AND BARSLASTCOUNT(VAR44)>=4 AND VAR34<0.2;
VAR149:=VAR46 AND REF(VAR42>=2,2) AND HHV(VAR39,4)=HHV(VAR39,100) AND REF(VAR59,1) AND C>均线中 AND VAR41>=4;
VAR150:=VAR47 AND VAR15 AND VAR41>=14 AND COUNT(VAR42>=28,7)>=1 AND REF(VAR58,1) AND 均线大<VAR40 AND 均线差<10 AND 均线小<K下三分;
VAR151:=VAR81 AND COUNT(C<O AND VAR29<3.6 AND VAR43=3 AND REF(VAR41>=18 AND C>O,3) AND C=LLV(MIN(C,O),4) AND VAR32>0 AND VAR32<3.6,4);
VAR152:=VAR15 AND VAR11 AND COUNT(VAR82 AND VAR31>7,4) AND VAR52 AND VAR41>=14 AND VAR42>=18 AND 大中均差*2<中小均差;
VAR153:=VAR82 AND VAR17 AND VAR45=2 AND VAR41>=3 AND REF(VAR42>=28,2) AND REF(VAR59 AND BARSLASTCOUNT(VAR29>REF(VAR29,1))>=2,1);
VAR154:=VAR147 OR VAR148 OR VAR149 OR VAR150 OR VAR151 OR VAR152 OR VAR153;{ WWW.ZHIBIAO123.CN}
VAR155:=VAR89 AND REF(VAR29<0.5 AND VAR30>4.5,2) AND BARSLASTCOUNT(MAX(C,O)>=REF(MAX(C,O),1))>=2 AND VAR55 AND ZDF9<10 AND VAR41>=1;
VAR156:=VAR89 AND VAR35<1 AND HHV(C,4)=HHV(C,60) AND BARSLASTCOUNT(C>O)>=3 AND C=REF(C,2) AND VAR55 AND 均线差<10 AND COUNT(VAR29>3,3)>=2;
VAR157:=VAR89 AND VAR66 AND VAR14 AND COUNT(VAR42>=28,4)>=1;{ WWW.ZHIBIAO123.CN}
VAR158:=VAR90 AND VAR62 AND VAR55 AND VAR41>=1 AND VAR42>=14;
VAR159:=VAR93 AND REF(C>O AND VAR14,1) AND 小无压 AND C>最高均线 AND VAR41>=18 AND VAR42>=14 AND 均线差<4;
VAR160:=VAR94 AND VAR11 AND VAR29<2 AND VAR41>=18 AND VAR42>=14 AND C>最高均线 AND COUNT(VAR58 AND BARSLASTCOUNT(VAR29<REF(VAR29,1))>=3,4);
VAR161:=VAR61 AND BARSLASTCOUNT(VAR29<0.5)>=3 AND BARSLASTCOUNT(VAR32>0)>=2 AND 均线差<1 AND MIN(C,O)>均线大 AND VAR41>=2 AND VAR42>=2 AND COUNT(VAR45>=2,4)>=1;
VAR162:=VAR97 AND COUNT(VAR15 AND VAR107,9) AND C>均线小 AND C<均线中 AND 均线大<VAR40 AND 均线差<10;
VAR163:=VAR96 AND VAR29>REF(VAR29,1) AND VAR15 AND 均线大<VAR40 AND VAR41>=7 AND VAR42>=14 AND VAR95 AND VAR51 AND (BARSLASTCOUNT(均线差<2)>=7 OR VAR67);
VAR164:=VAR155 OR VAR156 OR VAR157 OR VAR158 OR VAR159 OR VAR160 OR VAR161 OR VAR162 OR VAR163;{ WWW.ZHIBIAO123.CN}
VAR165:=VAR103 AND VAR15 AND 均线大<VAR40 AND C>均线小 AND C<均线中 AND VAR50<10 AND COUNT(VAR41>=28,7)>=1;
VAR166:=VAR15 AND VAR73 AND REF(BARSLASTCOUNT(VAR29>0.7 AND VAR29<1.4)>=4 AND VAR38<1.4,1);{ WWW.ZHIBIAO123.CN}
VAR167:=VAR58 AND REF(C>O AND VAR29>3 AND C=HHV(C,40),2) AND REF(COUNT(VAR58 AND REF(C>O AND VAR29>3 AND C=HHV(C,40),2),4)=1,1) AND ZDF20<30 AND VAR42>=24 AND C>REF(C,4);
VAR168:=VAR80 AND VAR41>=9 AND VAR45>=4 AND VAR55 AND C>最高均线 AND 小无压 AND REF(VAR17 AND VAR29<2.5,1) AND REF(VAR32>2.4,2);
VAR169:=VAR15 AND REF(VAR17 AND VAR29<2,1) AND VAR57 AND REF(VAR63 AND BARSLASTCOUNT(VAR32>4.5)>=2,2) AND COUNT(BARSLASTCOUNT(ZT)>=2,9) AND VAR41>=3 AND VAR42>=9;
VAR170:=VAR11 AND VAR49<3 AND OPEN=REF(O,REF(BARSLAST(VAR11 AND VAR49<3),1)+1) AND REF(VAR63 AND 十字星,1) AND VAR41>=9 AND VAR42>=14 AND 均线大>VAR40;
VAR171:=VAR165 OR VAR166 OR VAR167 OR VAR168 OR VAR169 OR VAR170;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
XG:VAR122 OR VAR131 OR VAR138 OR VAR146 OR VAR154 OR VAR164 OR VAR171;

通达信黄龙5更选股指标公式源码:

MA5:=MA(C,5);
MA10:=MA(C,10);MA20:=MA(C,20);
MA30:=MA(C,30);MA40:=MA(C,40);
MA60:=MA(C,60);
MA120:=MA(C,120);
LC:=REF(C,1);{ WWW.ZHIBIAO123.CN}
ZT:=C>REF(C,1)*1.095 AND C=H;
一字停:=C/REF(C,1)<=1.09 AND O=C AND C=L;
十字星:=H<>L AND C=OPEN AND H>C;
K上三分:=(MAX(C,O)*2+MIN(O,C))/3;
K下三分:=(MIN(C,O)*2+MAX(C,O))/3;
ZDF20:=(HHV(MAX(C,O),20)-LLV(MIN(C,O),20))/LLV(MIN(C,O),20)*100;
ZDF9:=(HHV(MAX(C,O),9)-LLV(MIN(C,O),9))/LLV(MIN(C,O),9)*100;
均线大:=MAX(MA30,MAX(MA60,MA120));{ WWW.ZHIBIAO123.CN}
均线小:=MIN(MA30,MIN(MA60,MA120));
均线中:=IF(MA30<>均线大 AND MA30<>均线小,MA30,IF(MA60<>均线大 AND MA60<>均线小,MA60,MA120));
均线差:=(均线大-均线小)/均线小*100;
大中均差:=(均线大-均线中)/均线中*100;
中小均差:=(均线中-均线小)/均线小*100;
三均倍差:=MAX(大中均差,中小均差)/MIN(大中均差,中小均差);
最高均线:=MAX(均线大,MAX(MAX(MA5,MA10),MAX(MA20,MA40)));
小无压:=C*1.01>HHV(MAX(C,O),4);
{—————————————————————————————————————};
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR10:=REF(VAR6 OR VAR7 OR VAR8,1) AND VAR1;
VAR11:=VAR10 AND CLOSE>OPEN;{ WWW.ZHIBIAO123.CN}
VAR12:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF (C,2);
VAR13:=REF(VAR1 OR VAR3 OR VAR4 OR VAR5,1) AND VAR6 AND VAR12=0 AND NOT(REF(C,3)=LLV(C,4));
VAR14:=(REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5,1)) AND VAR6 AND VAR13=0;
VAR15:=C/OPEN>1.04 AND C<SMA(HIGH,19,3) AND C>REF(C,1);
VAR16:=IF(C>MA(C,4),1,0)+IF(C<MA(C,4),-1,0)+IF(MA(C,5)>REF(MA(C,5),1),1,0)+IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR17:=VAR16=-2 AND C>O;{ WWW.ZHIBIAO123.CN}
VAR18:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VAR19:=(CROSS(VAR18,EMA(VAR18,2)) AND VAR18<=0.05 AND (C/REF(C,1)>0.035));
VAR20:=IF(C>MA(C,4),1,0);
VAR21:=IF(C<MA(C,4),-1,0);
VAR22:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
VAR23:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR24:=VAR20+VAR21+VAR22+VAR23;
VAR25:=VAR24=2 AND C<O;{ WWW.ZHIBIAO123.CN}
VAR26:=(VAR7 OR VAR8 OR VAR9) AND C>OPEN AND VAR17=0 AND VAR12=0;
VAR27:=CLOSE>OPEN AND VAR11=0 AND VAR15=0 AND VAR17=0 AND VAR19=0 AND VAR26=0 AND VAR12=0;
VAR28:=(VAR6 OR VAR7 OR VAR8 OR VAR9) AND VAR12=0 AND VAR17=0 AND VAR19=0 AND VAR13=0;
VAR29:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;
VAR30:=(H-MAX(C,O))/MAX(C,O)*100;
VAR31:=(MIN(C,O)-L)/L*100;{ WWW.ZHIBIAO123.CN}
VAR32:=(REF(MIN(C,O),1)-MAX(C,O))/MAX(C,O)*100;
VAR33:=(HHV(MAX(C,O),2)-LLV(MAX(C,O),2))/LLV(MAX(C,O),2)*100;
VAR34:=(HHV(MIN(C,O),2)-LLV(MIN(C,O),2))/LLV(MIN(C,O),2)*100;
VAR35:=(HHV(MAX(C,O),3)-LLV(MAX(C,O),3))/LLV(MAX(C,O),3)*100;
VAR36:=(HHV(MIN(C,O),3)-LLV(MIN(C,O),3))/LLV(MIN(C,O),3)*100;
VAR37:=(HHV(MAX(C,O),4)-LLV(MAX(C,O),4))/LLV(MAX(C,O),4)*100;
VAR38:=(HHV(MIN(C,O),4)-LLV(MIN(C,O),4))/LLV(MIN(C,O),4)*100;
VAR39:=MA(REF(LLV(C,30),1),2);
VAR40:=MA(REF(HHV(C,30),1),2);
VAR41:=BARSLASTCOUNT(VAR40=REF(VAR40,1));
VAR42:=BARSLASTCOUNT(VAR39=REF(VAR39,1));
VAR43:=BARSLASTCOUNT(VAR40>REF(VAR40,1));
VAR44:=BARSLASTCOUNT(VAR39<REF(VAR39,1));
VAR45:=BARSLASTCOUNT(VAR39>REF(VAR39,1));
VAR46:=REF(VAR39,1)>REF(VAR39,2) AND VAR39<REF(VAR39,1);
VAR47:=REF(VAR39,3)<REF(VAR39,2) AND REF(VAR39,1)=REF(VAR39,2) AND VAR39<REF(VAR39,1);
VAR48:=ATAN((VAR39/REF(VAR39,1)-1)*100)*180/3.1416;
VAR49:=(MIN(C,O)-VAR39)/VAR39*100;
VAR50:=(最高均线-C)/C*100;{ WWW.ZHIBIAO123.CN}
VAR51:=MA120>MA60 AND MA60>MA30;
VAR52:=MA30>MA60 AND MA60>MA120;
VAR53:=MA30>REF(MA30,1) AND MA60>REF(MA60,1) AND MA120>=REF(MA120,1);
VAR54:=MA30<REF(MA30,1) AND MA60<REF(MA60,1) AND MA120<=REF(MA120,1);
VAR55:=BARSLASTCOUNT(VAR52 AND VAR53)>=7;{ WWW.ZHIBIAO123.CN}
VAR56:=BARSLASTCOUNT(VAR51 AND VAR54)>=7;
VAR57:=BARSLASTCOUNT(MIN(C,O)>=REF(MIN(C,O),1) AND MAX(C,O)>REF(MAX(C,O),1))>=2;
VAR58:=BARSLASTCOUNT(MIN(C,O)<=REF(MIN(C,O),1) AND MAX(C,O)<REF(MAX(C,O),1))>=2;
VAR59:=VAR58 AND BARSLASTCOUNT(VAR29>1.5 AND VAR29<7 AND C<O)>=3 AND COUNT(VAR29>3.2,3)>=2;
VAR60:=BARSLASTCOUNT(MIN(C,O)>=REF(MIN(C,O),1) AND MAX(C,O)>REF(MAX(C,O),1))>=3;
VAR61:=BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1) AND MIN(C,O)<=REF(MIN(C,O),1))>=3;
VAR62:=VAR58 AND REF(VAR13,2);
VAR63:=VAR58 AND REF(VAR14,2);{ WWW.ZHIBIAO123.CN}
VAR64:=VAR61 AND REF(VAR13 AND VAR29<8.4,3) AND BARSLASTCOUNT(VAR29>0.2)>=4;
VAR65:=VAR61 AND REF(VAR14,3);{ WWW.ZHIBIAO123.CN}
VAR66:=BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1) AND MIN(C,O)<REF(MIN(C,O),1) AND VAR29<REF(VAR29,1))>=2;
VAR67:=C>OPEN AND ((C<MA120 AND CROSS(C,MA120*0.995)) OR (C>MA120 AND CROSS(C,MA120))) AND C<MA120*1.0051 AND REF(C<MA120,1);
VAR68:=C>OPEN AND CROSS(C,MA60*0.995) AND C<MA60*1.005 AND REF(C<MA60,1);
VAR69:=C>OPEN AND CROSS(C,MA40*0.995) AND C<MA40*1.007 AND REF(C<MA40,1);
VAR70:=(C>OPEN OR VAR19 OR (VAR29<0.5 AND VAR25)) AND CROSS(MAX(C,O),MA30*0.995) AND MAX(C,O)<MA30*1.005 AND REF(MAX(C,O)<MA30,1);
VAR71:=(C>OPEN OR VAR19) AND CROSS(MAX(C,O),MA20*0.995) AND MAX(C,O)<MA20*1.005 AND REF(MAX(C,O)<MA20,1);
VAR72:=C>OPEN AND CROSS(C,MA10*0.995) AND C<MA10*1.005 AND REF(C<MA10,1);
VAR73:=C>OPEN AND CROSS(C,最高均线*0.995) AND C<最高均线*1.005 AND REF(C<最高均线,1);
VAR74:=CROSS(C,VAR40*0.993) AND C<VAR40*1.005 AND REF(BARSLASTCOUNT(C<VAR40)>6,1) AND VAR41>=4;
VAR75:=C>OPEN AND H*1.005>MA120 AND H<MA120*1.005;{ WWW.ZHIBIAO123.CN}
VAR76:=C>OPEN AND H*1.007>MA60 AND H<MA60*1.007;
VAR77:=C>OPEN AND H*1.005>MA10 AND H<MA10*1.005;
VAR78:=COUNT(BARSLASTCOUNT(MAX(C,O)>MA30)>21,4)>=1 AND BARSLASTCOUNT(MAX(C,O)<MA30)>=2;
VAR79:=COUNT(BARSLASTCOUNT(MIN(C,O)>MA60)>40,4)>=1 AND BARSLASTCOUNT(MAX(C,O)<MA60)>=2;
VAR80:=BARSLASTCOUNT((MIN(C,O)>均线大 AND 均线大*1.01>MIN(C,O)) OR (MIN(C,O)<均线大 AND MAX(C,O)>均线大))>=3 AND BARSLASTCOUNT(MAX(C,O)>均线大)>=3;
VAR81:=(VAR29>0.74 AND VAR31>6.5 AND VAR31>VAR29*3) OR (VAR29>1.74 AND VAR29<3.5 AND VAR31>8.1) OR (VAR29<5 AND VAR31>9 AND VAR31>VAR30*3);
VAR82:=VAR29>0.3 AND VAR29<0.74 AND VAR31>VAR29*7 AND VAR31>VAR30*4;{ WWW.ZHIBIAO123.CN}
VAR83:=REF(VAR11 AND VAR29>3,1) AND VAR27 AND C/REF(O,1)>1.08 AND C=HHV(C,40);
VAR84:=BARSLASTCOUNT(VAR29<3)>=3 AND VAR36<1.4 AND VAR35<2.1 AND COUNT(VAR83,7)=1 AND HHV(MAX(C,O),3)*1.012>REF(C,BARSLAST(VAR83)) AND LLV(MIN(C,O),3)*1.012>REF(O,BARSLAST(VAR83));
VAR85:=(VAR11 OR VAR27) AND VAR29>5.4 AND VAR29<8.1;{ WWW.ZHIBIAO123.CN}
VAR86:=BARSLASTCOUNT(VAR29<3)>=3 AND VAR36<1.4 AND VAR35<2.1 AND COUNT(VAR85,7)=1 AND HHV(MAX(C,O),3)*1.012>REF(C,BARSLAST(VAR85)) AND LLV(MIN(C,O),3)*1.012>REF(K上三分,BARSLAST(VAR85));
VAR87:=(VAR11 OR VAR27) AND VAR29>8.1;{ WWW.ZHIBIAO123.CN}
VAR88:=BARSLASTCOUNT(VAR29<3.6)>=3 AND VAR36<3.6 AND VAR35<3.6 AND COUNT(VAR87,7)=1 AND HHV(MAX(C,O),3)*1.012>REF(C,BARSLAST(VAR87)) AND LLV(MIN(C,O),3)*1.012>REF(K上三分,BARSLAST(VAR87));
VAR89:=VAR84 OR VAR86 OR VAR88;
VAR90:=VAR58 AND BARSLASTCOUNT(VAR29>0.7 AND VAR29<2.4)>=3 AND COUNT(VAR29>6.4 AND C>O,7)=1 AND HHV(MAX(C,O),3)<REF(C,BARSLAST(VAR29>6.4 AND C>O))*1.04 AND MIN(C,O)*1.02>REF(O,BARSLAST(VAR29>6.4 AND C>O));
VAR91:=REF(VAR29<2.1 AND VAR30>4.7 AND VAR30>VAR29*3,1) AND VAR29<2.1 AND VAR31>3.6 AND VAR31>VAR29*3 AND MAX(C,O)<REF(MAX(C,O),1);
VAR92:=BARSLASTCOUNT(VAR29>0.4 AND VAR29<1.2)>=2 AND REF(VAR30>VAR29*5 AND VAR30>VAR31*5,1) AND VAR31>VAR29*5 AND VAR31>VAR30*4;
VAR93:=VAR91 OR VAR92;{ WWW.ZHIBIAO123.CN}
VAR94:=ABS(VAR29-REF(VAR29,1))<0.7 AND REF(VAR29*1.7<VAR31 AND VAR31>VAR30*3,1) AND VAR29*1.7<VAR30 AND VAR30>VAR31*3 AND MIN(C,O)*1.005>REF(MAX(C,O),1) AND COUNT(BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1))>=2,4)>=1;
VAR95:=OPEN*0.99<均线小 AND C>均线大;{ WWW.ZHIBIAO123.CN}
VAR96:=REF(VAR29>3 AND VAR13,1) AND ((VAR29>4 AND C>OPEN AND C>REF(MAX(C,O),1)) OR VAR15) AND VAR17=0;
VAR97:=OPEN>LC AND H>=REF(OPEN,1) AND REF(VAR13 AND VAR29>3.6 AND MAX(C,O)=HHV(MAX(C,O),4),1);
VAR98:=VAR11 AND OPEN*0.98<VAR39 AND C>VAR39 AND VAR39<=REF(VAR39,1) AND VAR15=0 AND VAR17=0 AND VAR19=0;
VAR99:=BARSLASTCOUNT(VAR29<1.2 AND VAR25)>=2 AND (VAR34<0.5 OR VAR33<0.5);
VAR100:=BARSLASTCOUNT(VAR29<1.8)>=2 AND COUNT(VAR29>0.74,2)>=1 AND VAR34<0.5;
VAR101:=BARSLASTCOUNT(VAR29<0.74)>=2 AND VAR33<0.5 AND VAR34<0.5;{ WWW.ZHIBIAO123.CN}
VAR102:=十字星 AND REF((VAR11 OR VAR27) AND VAR29<1.4,1) AND VAR33<0.5;
VAR103:=VAR29>3.6 AND C>O AND REF(VAR17 AND VAR29<3,1) AND REF(VAR29<1,2) AND LC>=REF(MAX(C,O),2) AND REF(OPEN,1)<REF(MIN(C,O),2) AND OPEN*0.98<LC AND OPEN*1.02>LC;
VAR104:=VAR29=REF(VAR29,1) AND VAR33=0 AND VAR34=0;{ WWW.ZHIBIAO123.CN}
VAR105:=REF(MAX(C,O)*0.995<VAR39,1) AND C>OPEN AND OPEN*0.995<VAR39 AND C>VAR39 AND VAR44 AND VAR30<VAR29/1.84 AND VAR31<VAR29/2.1;
VAR106:=VAR29<9 AND OPEN<VAR39*1.007 AND C>VAR39 AND VAR30<VAR29/2.1 AND VAR31<VAR29/2.1 AND VAR42>=2;
VAR107:=VAR48>-35 AND VAR48<0 AND OPEN<VAR39*1.007 AND C>VAR39 AND VAR30<VAR29/1.84 AND VAR31<VAR29/2.1;
VAR108:=VAR15 AND VAR29>3.6 AND VAR48<-35 AND REF(MIN(C,O)<VAR39 AND MAX(C,O)>VAR39,1) AND VAR30<VAR29/1.84 AND VAR31<VAR29/2.1;
{—————————————————————————————————————};
VAR109:=VAR76 AND VAR11 AND VAR29<1 AND REF(VAR102,1) AND VAR41>=9 AND VAR42>=9;
VAR110:=VAR76 AND VAR11 AND VAR29<1 AND REF(十字星,1) AND REF(VAR25 AND VAR29>1.2,2) AND 均线大<VAR40*1.05 AND COUNT(均线大>VAR40,4) AND VAR41>=9 AND VAR42>=14;
VAR111:=VAR76 AND VAR11 AND VAR29<3.6 AND REF(VAR13 AND VAR29>1.2,1) AND REF(VAR25 AND VAR29>0.7,2) AND 均线大<VAR40 AND C<均线小 AND VAR41>=14 AND VAR42>=4;
VAR112:=VAR71 AND VAR15 AND 均线大<VAR40 AND REF(VAR17,1) AND C=HHV(MAX(C,O),4) AND COUNT(VAR62,4) AND VAR41>=21 AND VAR45>=1;
VAR113:=VAR72 AND VAR107 AND VAR11 AND VAR15 AND VAR56 AND 均线大<VAR40*1.05 AND VAR41>=2 AND BARSLASTCOUNT(MAX(C,O)>=REF(MAX(C,O),1) AND MIN(C,O)<REF(MIN(C,O),1))>=3;
VAR114:=VAR105 AND VAR15 AND BARSLASTCOUNT(VAR17)=2 AND VAR68 AND MA60=均线小 AND 均线大<VAR40*1.05 AND VAR41>=4 AND COUNT(VAR42>=28,14)>=1;
VAR115:=VAR71 AND COUNT(VAR15,4)>=1 AND VAR41>=24 AND VAR42>=9 AND 均线大>VAR40 AND VAR56;
VAR116:=VAR69 AND VAR15 AND VAR19=0 AND C>REF(MAX(C,O),1) AND 均线大<VAR40 AND VAR51 AND REF(((VAR29>3 AND VAR32>3) OR VAR32>9) AND VAR30>3,1) AND REF(VAR41>=9,1) AND VAR42>=14;
VAR117:=VAR70 AND VAR11 AND BARSLASTCOUNT(VAR29>0 AND VAR29<1)>=4 AND VAR38<1 AND REF(VAR41>=9,1) AND VAR42>=4 AND 均线大<VAR40 AND REF(VAR14 AND VAR29<0.2,1);
VAR118:=VAR67 AND VAR15 AND VAR95 AND (COUNT(VAR64,4)>=1 OR (VAR96 AND C>REF(MAX(C,O),1)));{ WWW.ZHIBIAO123.CN}
VAR119:=BARSLASTCOUNT(VAR67)=2 AND MA120*1.005>最高均线 AND VAR60 AND OPEN>均线小 AND (COUNT(VAR65,4)>=1 OR REF(VAR74 AND CROSS(C,MA60),3));
VAR120:=VAR74 AND REF(COUNT(C<VAR40 AND C*1.005>VAR40,4)>=1,1) AND CROSS(C,MA60) AND VAR57 AND 三均倍差<1.2;
VAR121:=OPEN<VAR39 AND C*1.005>VAR39 AND VAR17 AND VAR29<1.2 AND VAR58 AND REF(VAR14 AND VAR29>4,1) AND VAR45>=3 AND VAR41>=21 AND VAR39/REF(VAR39,14)>1.2;
VAR122:=VAR109 OR VAR110 OR VAR111 OR VAR112 OR VAR113 OR VAR114 OR VAR115 OR VAR116 OR VAR117 OR VAR118 OR VAR119 OR VAR120 OR VAR121;
VAR123:=VAR105 AND VAR15 AND VAR17 AND C>REF(VAR39,1) AND VAR41>=2 AND REF(VAR42>=21,1) AND REF(VAR17 AND VAR29<1 AND H<VAR39,1);
VAR124:=VAR11 AND VAR15 AND VAR29>4 AND VAR107 AND VAR41>=14 AND 均线大<VAR40 AND 均线差<10 AND MA30=均线中 AND 均线小<K下三分;
VAR125:=VAR107 AND VAR15 AND REF(VAR58 AND C<VAR39 AND VAR42>=14 AND VAR29>3,1) AND OPEN<LC AND C>REF(O,1) AND COUNT(VAR41>=28,7)>=1;
VAR126:=VAR106 AND VAR11 AND VAR15 AND REF(VAR61,1) AND C<VAR40 AND VAR51 AND VAR41>=21 AND VAR42>=18 AND 三均倍差<1.5;
VAR127:=VAR15 AND VAR106 AND VAR77 AND 均线大/VAR40>1.1 AND REF(BARSLASTCOUNT(C<O)>=2,1) AND C<REF(O,1) AND COUNT(BARSLASTCOUNT(VAR41)>=4,4) AND VAR42>=2;
VAR128:=VAR19 AND VAR29>3.6 AND REF(VAR15 AND VAR108,3) AND REF(VAR25 AND VAR29>2.7,2) AND VAR37<1.7 AND VAR49<5 AND VAR41>=4 AND VAR42>=3;
VAR129:=VAR19 AND VAR75 AND 小无压 AND MA120<VAR40 AND C*1.01<MA120 AND MA120=最高均线 AND OPEN<均线小 AND COUNT(VAR41>=28,14) AND VAR42>=21 AND 三均倍差<2 AND COUNT(VAR58 AND VAR17,4)>=1;
VAR130:=VAR19 AND VAR29>1.7 AND VAR29<6 AND VAR71 AND REF(VAR98 AND REF(十字星,1),2) AND C<均线小 AND H=C AND BARSLASTCOUNT(均线差<4)>=9;
VAR131:=VAR123 OR VAR124 OR VAR125 OR VAR126 OR VAR127 OR VAR128 OR VAR129 OR VAR130;{ WWW.ZHIBIAO123.CN}
VAR132:=VAR100 AND VAR11 AND REF(VAR26,1) AND REF(VAR17,2) AND 均线大<VAR40*1.05 AND COUNT(VAR41>=21,4) AND VAR42<4 AND VAR39=LLV(VAR39,100);
VAR133:=BARSLASTCOUNT(VAR29<1.5 AND VAR29>0.5)=3 AND VAR38<0.5 AND REF(VAR62,1) AND VAR41>=9 AND VAR42>=4 AND 均线大<VAR40 AND 三均倍差<1.5;
VAR134:=VAR101 AND REF(VAR62 AND VAR17,1) AND VAR34<0.2 AND VAR36<1 AND VAR41>=14 AND VAR44 AND 均线大>VAR40 AND COUNT(VAR45>=2,7)=0;
VAR135:=VAR25 AND VAR29<1.2 AND BARSLASTCOUNT(VAR52 AND VAR53)>=4 AND REF(VAR101,2) AND VAR40/LLV(MAX(C,O),4)<1.05 AND VAR40/OPEN<2 AND C=HHV(C,4) AND VAR41>=9 AND VAR42>=21 AND 大中均差>中小均差;
VAR136:=VAR104 AND REF(C<O AND VAR14=0,1) AND VAR29>0.7 AND COUNT(VAR41>=28,7)>=1 AND VAR40<REF(VAR40,1) AND VAR42>=9 AND VAR73;
VAR137:=BARSLASTCOUNT(VAR104)=2 AND BARSLASTCOUNT(VAR28 AND VAR29<2)>=2 AND VAR41>=9 AND VAR42>=3 AND VAR56;
VAR138:=VAR132 OR VAR133 OR VAR134 OR VAR135 OR VAR136 OR VAR137;{ WWW.ZHIBIAO123.CN}
VAR139:=VAR17 AND VAR15 AND REF(一字停 AND VAR30>4,1) AND C>LC AND COUNT(VAR64,4)>=1 AND VAR41>=14 AND COUNT(VAR42>=18,4)>=1;
VAR140:=VAR15 AND VAR57 AND OPEN<均线中 AND C>最高均线 AND REF(VAR17 AND VAR29<1,2) AND COUNT(VAR41>=27,14)>=1 AND VAR41>=4 AND VAR42>=14;
VAR141:=VAR11 AND VAR15 AND REF(VAR66 AND VAR59 AND VAR61 AND BARSLASTCOUNT(C<O)>=4,1) AND VAR55 AND VAR41>=9 AND VAR42>=2;
VAR142:=VAR11 AND VAR15 AND C=H AND C=HHV(C,4) AND REF(VAR64 AND BARSLASTCOUNT(C<O)>=4 AND COUNT(VAR29>2.7,3)>=2,1) AND VAR52 AND VAR41>=14;
VAR143:=VAR17 AND VAR55 AND O>均线大 AND 均线差<36 AND REF(VAR64 AND BARSLASTCOUNT(C<O)>=4 AND COUNT(VAR29>2.7,3)>=2 AND REF(VAR29>7,3),1);
VAR144:=VAR64 AND VAR29<1 AND REF(VAR66,1) AND BARSLASTCOUNT(C<O)>=4 AND C=LC AND VAR55 AND C>均线大;
VAR145:=VAR11 AND VAR29<1.5 AND REF(VAR17 AND VAR65,1) AND VAR55 AND VAR41>=18 AND VAR45>=4 AND CROSS(MA10,MA5);
VAR146:=VAR139 OR VAR140 OR VAR141 OR VAR142 OR VAR143 OR VAR144 OR VAR145;{ WWW.ZHIBIAO123.CN}
VAR147:=VAR78 AND VAR17 AND COUNT(BARSLASTCOUNT(MAX(C,O)<均线小)>=2,4)=0 AND REF(VAR59,1) AND MIN(O,C)=LLV(MIN(C,O),21) AND VAR32>5.4 AND VAR41>=14 AND VAR45>=4;
VAR148:=VAR79 AND REF(VAR17,1) AND VAR41>=21 AND BARSLASTCOUNT(VAR29<REF(VAR29,1))>=2 AND BARSLASTCOUNT(VAR44)>=4 AND VAR34<0.2;
VAR149:=VAR46 AND REF(VAR42>=2,2) AND HHV(VAR39,4)=HHV(VAR39,100) AND REF(VAR59,1) AND C>均线中 AND VAR41>=4;
VAR150:=VAR47 AND VAR15 AND VAR41>=14 AND COUNT(VAR42>=28,7)>=1 AND REF(VAR58,1) AND 均线大<VAR40 AND 均线差<10 AND 均线小<K下三分;
VAR151:=VAR81 AND COUNT(C<O AND VAR29<3.6 AND VAR43=3 AND REF(VAR41>=18 AND C>O,3) AND C=LLV(MIN(C,O),4) AND VAR32>0 AND VAR32<3.6,4);
VAR152:=VAR15 AND VAR11 AND COUNT(VAR82 AND VAR31>7,4) AND VAR52 AND VAR41>=14 AND VAR42>=18 AND 大中均差*2<中小均差;
VAR153:=VAR82 AND VAR17 AND VAR45=2 AND VAR41>=3 AND REF(VAR42>=28,2) AND REF(VAR59 AND BARSLASTCOUNT(VAR29>REF(VAR29,1))>=2,1);
VAR154:=VAR147 OR VAR148 OR VAR149 OR VAR150 OR VAR151 OR VAR152 OR VAR153;{ WWW.ZHIBIAO123.CN}
VAR155:=VAR89 AND REF(VAR29<0.5 AND VAR30>4.5,2) AND BARSLASTCOUNT(MAX(C,O)>=REF(MAX(C,O),1))>=2 AND VAR55 AND ZDF9<10 AND VAR41>=1;
VAR156:=VAR89 AND VAR35<1 AND HHV(C,4)=HHV(C,60) AND BARSLASTCOUNT(C>O)>=3 AND C=REF(C,2) AND VAR55 AND 均线差<10 AND COUNT(VAR29>3,3)>=2;
VAR157:=VAR89 AND VAR66 AND VAR14 AND COUNT(VAR42>=28,4)>=1;{ WWW.ZHIBIAO123.CN}
VAR158:=VAR90 AND VAR62 AND VAR55 AND VAR41>=1 AND VAR42>=14;
VAR159:=VAR93 AND REF(C>O AND VAR14,1) AND 小无压 AND C>最高均线 AND VAR41>=18 AND VAR42>=14 AND 均线差<4;
VAR160:=VAR94 AND VAR11 AND VAR29<2 AND VAR41>=18 AND VAR42>=14 AND C>最高均线 AND COUNT(VAR58 AND BARSLASTCOUNT(VAR29<REF(VAR29,1))>=3,4);
VAR161:=VAR61 AND BARSLASTCOUNT(VAR29<0.5)>=3 AND BARSLASTCOUNT(VAR32>0)>=2 AND 均线差<1 AND MIN(C,O)>均线大 AND VAR41>=2 AND VAR42>=2 AND COUNT(VAR45>=2,4)>=1;
VAR162:=VAR97 AND COUNT(VAR15 AND VAR107,9) AND C>均线小 AND C<均线中 AND 均线大<VAR40 AND 均线差<10;
VAR163:=VAR96 AND VAR29>REF(VAR29,1) AND VAR15 AND 均线大<VAR40 AND VAR41>=7 AND VAR42>=14 AND VAR95 AND VAR51 AND (BARSLASTCOUNT(均线差<2)>=7 OR VAR67);
VAR164:=VAR155 OR VAR156 OR VAR157 OR VAR158 OR VAR159 OR VAR160 OR VAR161 OR VAR162 OR VAR163;
VAR165:=VAR103 AND VAR15 AND 均线大<VAR40 AND C>均线小 AND C<均线中 AND VAR50<10 AND COUNT(VAR41>=28,7)>=1;
VAR166:=VAR15 AND VAR73 AND REF(BARSLASTCOUNT(VAR29>0.7 AND VAR29<1.4)>=4 AND VAR38<1.4,1);{ WWW.ZHIBIAO123.CN}
VAR167:=VAR58 AND REF(C>O AND VAR29>3 AND C=HHV(C,40),2) AND REF(COUNT(VAR58 AND REF(C>O AND VAR29>3 AND C=HHV(C,40),2),4)=1,1) AND ZDF20<30 AND VAR42>=24 AND C>REF(C,4);
VAR168:=VAR80 AND VAR41>=9 AND VAR45>=4 AND VAR55 AND C>最高均线 AND 小无压 AND REF(VAR17 AND VAR29<2.5,1) AND REF(VAR32>2.4,2);
VAR169:=VAR15 AND REF(VAR17 AND VAR29<2,1) AND VAR57 AND REF(VAR63 AND BARSLASTCOUNT(VAR32>4.5)>=2,2) AND COUNT(BARSLASTCOUNT(ZT)>=2,9) AND VAR41>=3 AND VAR42>=9;
VAR170:=VAR11 AND VAR49<3 AND OPEN=REF(O,REF(BARSLAST(VAR11 AND VAR49<3),1)+1) AND REF(VAR63 AND 十字星,1) AND VAR41>=9 AND VAR42>=14 AND 均线大>VAR40;
VAR171:=VAR165 OR VAR166 OR VAR167 OR VAR168 OR VAR169 OR VAR170;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
XG:VAR122 OR VAR131 OR VAR138 OR VAR146 OR VAR154 OR VAR164 OR VAR171;

资源下载
下载价格VIP专享
仅限VIP下载升级VIP
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/3879.html,转载请注明出处。
通达信《卧龙起爆》战法全套7个指标:股市征战的无上利器
通达信《卧龙起爆》战法全套7个指标:股市征战的无上利器
1分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录