通达信《夜龙分时主图》指标公式源码

通达信夜龙分时主图指标公式源码:

DD1:=1;
成交额:=V*C/100,NODRAW;{万元}
A20:=SUM((IF(((成交额/8>18) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A30:=SUM((IF(((成交额/8>18) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A60:=(A20+A30);
AAA30:=STRCAT(STRCAT(‘机构净’,CON2STR((100*(A20-A30))/A60,0)),’%’);
DRAWTEXT_FIX(DD1=1,0,0.05,0,AAA30),COLORLIRED;

{ WWW.ZHIBIAO123.CN}

现价:C,COLORWHITE,LINETHICK1;
量价:=(VOL/CLOSE)/3;
A2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
A3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
A6:=A2+A3;比:=A2/A3;{ WWW.ZHIBIAO123.CN}
AAA3:=STRCAT(STRCAT(‘差= ‘,CON2STR((100*(A2-A3))/A6,0)),’%’);
DRAWTEXT_FIX(DD1=1,0,0.01,0,AAA3),COLORYELLOW;
DRAWTEXT_FIX(比>2,0,0.40,0,’预’),COLORLIRED;
DRAWTEXT_FIX(比>2,0,0.48,0,’涨’),COLORMAGENTA;
DRAWTEXT_FIX(比>2,0,0.56,0,’停’),COLORRED;
中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
IF((比>1.1 AND 中期线<5),C,DRAWNULL),COLORRED,LINETHICK3;
IF((比<1.1 AND 中期线>98.0),C,DRAWNULL),COLORGREEN,LINETHICK3;
均价1:=SUM(C*V,240)/SUM(V,240),COLORYELLOW;
TT:=BARSCOUNT(C);均:=MA(C,TT);{ WWW.ZHIBIAO123.CN}
上均线:=均+2*STD(C,3);下均线:=均-2*STD(C,3);
TT1:=SUM(V*C,0)/SUM(V,0);
TT2:=TT1>C AND C<REF(C,1) AND REF(C,1)<REF(C,2) AND REF(V,1)>REF(HHV(V,25),2) AND REF(COUNT(V=HHV(V,10),3)>=1,1);
TT3:=TT1<C AND C<REF(C,1) AND REF(C,1)>REF(C,2) AND REF(V,1)>REF(HHV(V,99),2) AND V/REF(V,1)>=0.5;
{ WWW.ZHIBIAO123.CN}

V1:=MA(V,1);
C1:=MA(C,1);
H1:=C1>REF(C1,1) AND V1<REF(V1,1) AND C/均价1>(1+0.001);
H2:=C1>REF(C1,1) AND V1<REF(V1,1) AND C/均价1>(1+0.02);
H3:=C1>REF(C1,1) AND V1<REF(V1,1) AND C/均价1>(1+0.034);
L1:=C1<REF(C1,1) AND V1>REF(V1,1) AND C/均价1<(1-0.001);
L2:=C1<REF(C1,1) AND V1>REF(V1,1) AND C/均价1<(1-0.02);
L3:=C1<REF(C1,1) AND V1>REF(V1,1) AND C/均价1>(1+0.034);
IF(FILTER(H,240),C,DRAWNULL),COLORLIRED,LINETHICK3;
IF(FILTER(L,240),C,DRAWNULL),COLORGREEN,LINETHICK3;
IF(FILTER(H1,240),C,DRAWNULL),COLORLIRED,LINETHICK3;
IF(FILTER(L1,240),C,DRAWNULL),COLORCYAN,LINETHICK3;
IF(TT2,C,DRAWNULL),COLORRED,LINETHICK3;
IF(TT3,C,DRAWNULL),COLORGREEN,LINETHICK3;
VV:=CROSS(SUM(C<=REF(C,1),BARSLAST(H1))=1,0.5);
VVB:=CROSS(SUM(C>=REF(C,1),BARSLAST(L1))=1,0.5);
VV1:=CROSS(SUM(C<=REF(C,1),BARSLAST(H2))=1,0.5);
VVB1:=CROSS(SUM(C>=REF(C,1),BARSLAST(L2))=1,0.5);


VAR22:CONST(SUM(IF(VVB22,REF(C,1),DRAWNULL),0)),COLORLIRED,LINETHICK1;
VAS22:CONST(SUM(IF(VV22,REF(C,1),DRAWNULL),0)),COLORCYAN,LINETHICK1;
VVB3:=IF(CROSS(SUM(CROSS(VVB AND C/VAR2<0.95,0.5),0),0.5) AND SUM(VVB,0)>1,1,0);
VV3:=IF(CROSS(SUM(CROSS(VV AND C/VAS2>1.05,0.5),0),0.5) AND SUM(VV,0)>1,1,0);
VAR3:CONST(SUM(IF(VVB3,REF(C,1),DRAWNULL),0)),COLORLIRED;
VAS3:CONST(SUM(IF(VV3,REF(C,1),DRAWNULL),0)),COLORCYAN;
VVB31:=IF(CROSS(SUM(CROSS(VVB1 AND C/VAR21<0.95,0.5),0),0.5) AND SUM(VVB1,0)>1,1,0);
VV31:=IF(CROSS(SUM(CROSS(VV1 AND C/VAS21>1.05,0.5),0),0.5) AND SUM(VV1,0)>1,1,0);
VAR31:CONST(SUM(IF(VVB31,REF(C,1),DRAWNULL),0)),COLORLIRED;
VAS31:CONST(SUM(IF(VV31,REF(C,1),DRAWNULL),0)),COLORCYAN;
VVB32:=IF(CROSS(SUM(CROSS(VVB2 AND C/VAR22<0.95,0.5),0),0.5) AND SUM(VVB23,0)>1,1,0);
VV32:=IF(CROSS(SUM(CROSS(VV2 AND C/VAS22>1.05,0.5),0),0.5) AND SUM(VV23,0)>1,1,0);
VAR32:CONST(SUM(IF(VVB32,REF(C,1),DRAWNULL),0)),COLORLIRED;{ WWW.ZHIBIAO123.CN}
VAS32:CONST(SUM(IF(VV32,REF(C,1),DRAWNULL),0)),COLORCYAN;
DRAWTEXT(VVB31 AND REF(COUNT(V=HHV(V,6),5)>=1,1),REF(C,1)*0.999,’B’),COLORLIRED;
DRAWTEXT(VVB3 AND REF(COUNT(V=HHV(V,6),5)>=1,1),REF(C,1)*0.999,’B’),COLORLIRED;
DRAWTEXT(VVB21 AND REF(COUNT(V=HHV(V,6),5)>=1,1),REF(C,1)*0.999,’B’),COLORLIRED;
{ WWW.ZHIBIAO123.CN}
DRAWTEXT(VV31 ,REF(C,1)*1.003,’S’),COLORCYAN;
DRAWTEXT(VV3 ,REF(C,1)*1.003,’S’),COLORCYAN;
DRAWTEXT(VV21 ,REF(C,1)*1.003,’S’),COLORCYAN;
DRAWTEXT(VV22 ,REF(C,1)*1.003,’S’),COLORCYAN;
{ WWW.ZHIBIAO123.CN}

H11:=MAX(DYNAINFO(3),DYNAINFO(5));
L1K:=MIN(DYNAINFO(3),DYNAINFO(6));
P1K:=H11-L1;
阻力:L1K+P1K*7.7/8,NODRAW;
支撑:L1K+P1K*0.3/8,NODRAW;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),NODRAW;

通达信夜龙分时主图指标案例截图:

通达信夜龙分时主图指标案例截图1

通达信夜龙分时主图指标案例截图2

资源下载
下载价格免费
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/3029.html,转载请注明出处。
通达信《刻舟求剑》主图+副图+选股预警指标公式源码
通达信《刻舟求剑》主图+副图+选股预警指标公式源码
8分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录