通达信《多空黑马》副图指标公式源码

在充满变数的股市中,想要精准把握多空趋势,捕捉潜在的黑马,通达信《多空黑马》副图指标或许是您的得力助手。

该指标并非只是一组冰冷的数据和线条,而是一个融合了先进算法和丰富经验的智慧结晶。它通过对成交量、价格走势等关键因素的深度分析,以直观清晰的方式展现多空双方的力量对比。

无论是初涉股市的新手,还是经验丰富的投资者,《多空黑马》都能为您提供有价值的参考。它能够帮助您在关键时刻做出明智决策,降低投资风险,提高获利的概率,为您的股市之旅保驾护航。

多空黑马指标源码:

N:=20;
VAR01:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),15,1);
VAR02:=HIGH-REF(HIGH,5);
VAR03:=REF(LOW,5)-LOW;
JJ:=(HIGH+LOW+CLOSE)/3;
VAR04:=SMA(IF(VAR02>0 AND VAR02>VAR03,VAR02,0),15,1);
VAR05:=SMA(IF(VAR03>0 AND VAR03>VAR02,VAR03,0),15,1);
VAR06:=LLV(LOW,27);
VAR07:=HHV(HIGH,34);
VAR08:=EMA((CLOSE-VAR06)/(VAR07-VAR06)*4,4)*25;
VAR09:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,
5,1)-3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
做空:VAR05*100/VAR01,COLORLIBLUE;
提示买入:IF(VAR09<=8,8,0),STICK,COLORWHITE,LINETHICK2;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
VAR10:=MA(C,2)>REF(MA(C,2),1);
VAR11:=MA(C,10)>MA(C,20);
VAR12:=(CLOSE*2+HIGH+LOW)/4;
VAR13:=EMA(VAR12,12)-EMA(VAR12,50);
VAR14:=EMA(VAR13,2);{WWW.ZHIBIAO123.CN}
VAR15:=(CROSS(VAR13,VAR14) AND VAR13<-0.04 AND (C-REF(C,1))/REF(C,
1)>=0.03) OR (CROSS(VAR13,VAR14) AND VAR13<=-0.14 ) OR (CROSS(VAR13,
VAR14) AND VAR13<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) AND VAR10 AND VAR11;
STICKLINE(VAR15>0,60,110,2,0),COLORRED;
DRAWTEXT(VAR15,90,'←黑马'),COLORYELLOW;
DDX:20*((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,100000000,1000000),COLOR00AAAA,LINETHICK;
DX:=(MA(DDX,5)*N)*2;
涨跌:=IF(BETWEEN(C,REF(C,1),H),VOL,0);
动因:=IF(BETWEEN(C,REF(C,1),L),VOL,0);
VAR16:=REF(LOW,1);
VAR17:=(SMA(ABS(LOW-VAR16),13,1))/(SMA(MAX(LOW-VAR16,0),13,1))*100;
VAR18:=MA(VAR17,13);
VAR19:=LLV(LOW,34);
CC2:=IF(涨跌 AND 动因,0,VOL/3);
涨跌动因:3*(涨跌-(动因+CC2))/IF(CAPITAL<1,SUM(INDEXV,71),CAPITAL),LINETHICK0;
VAR20:=EMA(IF(LOW<=VAR19,VAR18,0),3);
VAR21:=SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1),5,1);
VAR22:=SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54))*100,7,1)*16.18-VAR21*10.9;
VAR23:=FILTER(IF(VAR22<=VAR21 AND VAR20>REF(VAR20,1),VAR20*8,0),20);
STICKLINE(涨跌动因>0,20,20+涨跌动因*18.5,2.5,0 ),COLORYELLOW;
STICKLINE(涨跌动因<0,20,20+涨跌动因*18.5,2.5,0 ),COLORBLUE;
DRAWTEXT(VAR23,35,'←洗盘'),COLORGREEN;
STICKLINE(VAR23=1,35,110,2,0),COLORGREEN;
VAR24:=3;
VAR25:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),
5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
买点:IF((VAR25<=3),15,0),COLORYELLOW,LINETHICK2;
补仓:IF((VAR25<5),10,0),COLORRED,LINETHICK2;
VAR26:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR27:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,
20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR28:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,
1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR29:=VAR27<REF(VAR28,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR30:=(HIGH+LOW+CLOSE)/3;
MA1:MA(涨跌动因,N)*2;
AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);
BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);
CC:=(AA - BB);
VAR31:=(VAR30-MA(VAR30,14))/(0.015*AVEDEV(VAR30,14));
VAR32:=(VAR30-MA(VAR30,70))/(0.015*AVEDEV(VAR30,70));
VAR33:=IF(VAR31>=150 AND VAR31<200 AND VAR32>=150 AND VAR32<200,10,0);
VAR34:=IF(VAR31<=-150 AND VAR31>-200 AND VAR32<=-150 AND VAR32>-200,-10,VAR33);
VAR35:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR36:=100-ABS(VAR35);
VAR37:=IF(VAR36<90,VAR36,100);
VAR38:=IF(VAR26>0,VAR26,0);
VAR39:=IF(VAR32>=200 AND VAR31>=150,15,IF(VAR32<=-200 AND VAR31<=-150,-15,VAR34))+60;
VAR40:=VAR38>60 AND VAR39>70 AND VAR37<100;
VAR41:=((CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100+(CLOSE-MA(CLOSE,
90))/MA(CLOSE,90)*100+(CLOSE-MA(CLOSE,72))/MA(CLOSE,72)*100)/3;
DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100);
EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN > LOW));
DRAWTEXT(VAR29 AND COUNT(VAR29,30)=1,70,'←筹码进入'),COLORMAGENTA;
STICKLINE(VAR29 AND COUNT(VAR29,30)=1,60,110,2,0),COLORMAGENTA;
DRAWTEXT(VAR40 AND COUNT(VAR40,30)=1,35,'←出逃'),COLORCYAN;
STICKLINE(VAR40 AND COUNT(VAR40,30)=1,50,110,2,0),COLORCYAN;
A1:=DYNAINFO(6);{www.zhibiao123.cn}
A22:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A3:=(VOL / WINNER(LOW));
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
DRAWTEXT(FILTER(VAR41<-9 AND VAR41>REF(VAR41,1),78),55,'←买票'),COLORWHITE;
STICKLINE(FILTER(VAR41<-9 AND VAR41>REF(VAR41,1),78),55,110,2,0),COLORWHITE;
ZHIBIAO123:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
A6:=((100 * (CLOSE - A5)) / (A4 - A5));
A7:=((A22 > 0) OR (A22 = 1));
A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80));
A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4));
A10:=(A8 AND A9);
快:=COUNT(CLOSE>REF(CLOSE,2),4)/4*100;
慢:=COUNT(CLOSE>REF(CLOSE,2),6)/6*100;
关注:IF(快=0 AND 慢=0,10,0),COLORCYAN,LINETHICK2;
风险:IF(快=100 AND 慢>=80,100,110),COLORLIGREEN;

多空黑马指标截图:

 

资源下载
下载价格VIP专享
仅限VIP下载升级VIP
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/154925.html,转载请注明出处。
通达信短中长《量能力道》副图指标公式源码
通达信短中长《量能力道》副图指标公式源码
8分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录