通达信《黄龙帝国3更4更》副图+选股指标公式源码

通达信《黄龙帝国3更》副图指标公式源码:

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA40:=MA(C,40);
MA60:=MA(C,60);
MA120:=MA(C,120);
LC:=REF(C,1);{ WWW.ZHIBIAO123.CN}
DT:=REF(C,1)/C>1.1;
ZT:=C>REF(C,1)*1.095 AND C=H;
ZF:=(C-LC)/LC*100;{ WWW.ZHIBIAO123.CN}
连板:=BARSLASTCOUNT(ZT)>=2;
连停:=BARSLASTCOUNT(DT)>=2;
一字板:=C>REF(C,1)*1.095 AND C=H AND L=H;
一字跌板:=C/REF(C,1)<=1.09 AND O=C AND H=L;
一字连跌:=BARSLASTCOUNT(一字跌板)>=2;
十字:=OPEN=C AND H<>L;{ WWW.ZHIBIAO123.CN}
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR2 OR VAR3,1) AND VAR1;
VAR6:=VAR5 AND CLOSE>OPEN;{ WWW.ZHIBIAO123.CN}
VAR7:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF (C,2);
VAR8:=REF(VAR1,1) AND VAR2 AND NOT(REF(C,3)=LLV(C,4));
VAR9:=C/OPEN>1.04 AND C<SMA(HIGH,19,3) AND C>REF(C,1);
VAR10:=IF(C>MA(C,4),1,0)+IF(C<MA(C,4),-1,0)+IF(MA(C,5)>REF(MA(C,5),1),1,0)+IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR11:=VAR10=-2 AND C>O;{ WWW.ZHIBIAO123.CN}
VAR12:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VAR13:=(CROSS(VAR12,EMA(VAR12,2)) AND VAR12<=0.05 AND (C/REF(C,1)>0.035));
VAR14:=IF(C>MA(C,4),1,0);{ WWW.ZHIBIAO123.CN}
VAR15:=IF(C<MA(C,4),-1,0);
VAR16:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
VAR17:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR18:=VAR14+VAR15+VAR16+VAR17;
VAR19:=VAR18=2 AND C<O;{ WWW.ZHIBIAO123.CN}
VAR20:=VAR3 AND C>OPEN AND VAR11=0 AND VAR7=0;
VAR21:=CLOSE>OPEN AND VAR6=0 AND VAR9=0 AND VAR11=0 AND VAR13=0 AND VAR20=0 AND VAR7=0;
VAR22:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR23:=(VAR2 OR VAR3 OR VAR4 OR VAR22) AND VAR7=0 AND VAR11=0 AND VAR13=0 AND VAR8=0;
VAR24:=C<REF(C,1) AND C<OPEN AND C>REF(OPEN,1) AND VAR23=0 AND VAR19=0 AND VAR7=0;
VAR25:=MA(REF(LLV(C,30),1),2);{ WWW.ZHIBIAO123.CN}
VAR26:=MA(REF(HHV(C,30),1),2);
VAR27:=MA30>=REF(MA30,1);VAR28:=MA60>=REF(MA60,1);VAR29:=MA120>=REF(MA120,1);
VAR30:=MA30<REF(MA30,1);VAR31:=MA60<REF(MA60,1);VAR32:=MA120<REF(MA120,1);
VAR33:=BARSLASTCOUNT(C>0)>30 AND BARSLASTCOUNT(C>0)<51;
VAR34:=BARSLASTCOUNT(C>0)>30 AND BARSLASTCOUNT(C>0)<61;
VAR35:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;
VAR36:=(H-MAX(C,O))/MAX(C,O)*100;
VAR37:=(MIN(C,O)-L)/L*100;{ WWW.ZHIBIAO123.CN}
VAR38:=(MIN(C,O)-REF(MAX(C,O),1))/REF(MAX(C,O),1)*100;
VAR39:=(REF(MIN(C,O),1)-MAX(C,O))/MAX(C,O)*100;
VAR40:=(MAX(REF(MAX(C,O),1),MAX(C,O))-MIN(REF(MAX(C,O),1),MAX(C,O)))/MIN(REF(MAX(C,O),1),MAX(C,O))*100;
VAR41:=(HHV(H,9)-LLV(C,9))/LLV(C,9)*100;
VAR42:=(HHV(H,9)-LLV(L,9))/LLV(L,9)*100;
VAR43:=(HHV(H,4)-LLV(L,4))/LLV(L,4)*100;
VAR44:=BARSLASTCOUNT(C>LC AND OPEN>REF(OPEN,1))>=2 AND BARSLASTCOUNT(C>OPEN AND VAR35<2.94)>=3;
VAR45:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
VAR46:=ATAN((MA60/REF(MA60,1)-1)*100)*180/3.1416;
VAR47:=MAX(MA30,MAX(MA60,MA120));{ WWW.ZHIBIAO123.CN}
VAR48:=MIN(MA30,MIN(MA60,MA120));
VAR49:=IF(MA30<>VAR47 AND MA30<>VAR48,MA30,IF(MA60<>VAR47 AND MA60<>VAR48,MA60,MA120));
VAR50:=(VAR47-VAR48)/VAR48*100;
VAR51:=(VAR47-VAR49)/VAR49*100;
VAR52:=(VAR49-VAR48)/VAR48*100;
VAR53:=VAR49>=REF(VAR49,1);{ WWW.ZHIBIAO123.CN}
VAR54:=MAX(MAX(MA5,MA10),MAX(MA20,MA40));
VAR55:=(VAR26-MAX(C,O))/MAX(C,O)*100;
VAR56:=(MIN(C,O)-VAR25)/VAR25*100;
VAR57:=(VAR47-C)/C*100;{ WWW.ZHIBIAO123.CN}
VAR58:=MA120>MA60 AND MA60>MA30;
VAR59:=MA30>MA60 AND MA60>MA120;
VAR60:=MA30>REF(MA30,1) AND MA60>REF(MA60,1) AND MA120>=REF(MA120,1);
VAR61:=MA30<REF(MA30,1) AND MA60<REF(MA60,1) AND MA120<=REF(MA120,1);
VAR62:=BARSLASTCOUNT(VAR26=REF(VAR26,1));
VAR63:=VAR62>=4;{ WWW.ZHIBIAO123.CN}
VAR64:=VAR62>=9;
VAR65:=VAR62>=18;
VAR66:=VAR62>=27;
VAR67:=BARSLASTCOUNT(VAR25=REF(VAR25,1));
VAR68:=VAR67>=4;{ WWW.ZHIBIAO123.CN}
VAR69:=VAR67>=9;
VAR70:=VAR67>=14;
VAR71:=VAR67>=18;
VAR72:=VAR67>=27;
VAR73:=BARSLAST(VAR68);
VAR74:=REF(VAR25,VAR73);
VAR75:=REF(VAR74,VAR73-1);
VAR76:=IF(VAR68>0,VAR25,0);
VAR77:=IF(VAR68>0,VAR25,VAR75);
VAR78:=(VAR77-MAX(C,O))/MAX(C,O)*100;
VAR79:=(MIN(C,O)-VAR77)/VAR77*100;
VAR80:=VAR25<REF(VAR25,1);{ WWW.ZHIBIAO123.CN}
VAR81:=ATAN((VAR25/REF(VAR25,1)-1)*100)*180/3.1416;
VAR82:=(REF(VAR25,1)-VAR25)/VAR25*100;
VAR83:=REF(VAR25,1)>REF(VAR25,2) AND VAR25<REF(VAR25,1);
VAR84:=REF(VAR67>=4,1) AND VAR80 AND VAR81>-45 AND REF(VAR35<3,1);
VAR85:=BARSLAST(VAR69);{ WWW.ZHIBIAO123.CN}
VAR86:=REF(VAR25,VAR85);
VAR87:=REF(VAR86,VAR85-1);
VAR88:=VAR25 AND VAR69;
VAR89:=IF(VAR88>0,VAR25,0);
VAR90:=IF(VAR89>0,(VAR89-OPEN)/OPEN*100,(REF(VAR25,14)-OPEN)/OPEN*100);
VAR91:=(VAR87-VAR89)/VAR89*100;
VAR92:=(VAR89-VAR87)/VAR87*100;
VAR93:=VAR87>VAR89 AND VAR91>=9;
VAR94:=VAR91<9 AND VAR91>-9;{ WWW.ZHIBIAO123.CN}
VAR95:=VAR87<VAR89 AND VAR91<=-9;
VAR96:=C<OPEN AND VAR35>5.4 AND VAR39>4.5;
VAR97:=VAR8 AND VAR35>5.4 AND VAR39>3.5;
VAR98:=VAR8 AND VAR35>7.9 AND VAR39>0.9;
VAR99:=C<OPEN AND VAR35>8.4 AND VAR39>1.5;
VAR100:=VAR96 OR VAR97 OR VAR98 OR VAR99;
VAR101:=VAR19 AND VAR35>7;
VAR102:=C<OPEN AND VAR35>8;{ WWW.ZHIBIAO123.CN}
VAR103:=(C<OPEN AND VAR35>5.4) OR (VAR8 AND VAR35>4) OR (REF(C<OPEN AND VAR35>4.5,1) AND VAR39>1.4) OR (C<OPEN AND VAR35>4 AND VAR39>3);
VAR104:=BARSLASTCOUNT(C<OPEN AND VAR35>1.9)=3 AND BARSLASTCOUNT(C<LC AND OPEN<REF(OPEN,1))>=2 AND COUNT(VAR8 AND VAR35>6,3)>=1 AND COUNT(VAR35>4.9,3)>=2;
VAR105:=BARSLASTCOUNT(C<OPEN AND VAR35>2.1)=3 AND BARSLASTCOUNT(C<LC AND OPEN<REF(OPEN,1))>=2 AND COUNT(VAR8 AND VAR35>4,3)>=1 AND COUNT(VAR35>4,3)>=2;
VAR106:=BARSLASTCOUNT(C<OPEN AND VAR35>2.7)=3 AND BARSLASTCOUNT(C<LC AND OPEN<REF(OPEN,1))>=2 AND COUNT(VAR8 AND VAR35>3.6,3)>=1;
VAR107:=VAR104 OR VAR105 OR VAR106;{ WWW.ZHIBIAO123.CN}
VAR108:=BARSLASTCOUNT(VAR35>1.29 AND OPEN>C)>=4 AND BARSLASTCOUNT(C<LC AND OPEN<REF(OPEN,1))>=3 AND COUNT(VAR8 AND VAR35>4.6,4)>=1;
VAR109:=C>OPEN OR (C>LC AND C=OPEN);
VAR110:=VAR103 AND REF(VAR109,1) AND OPEN<REF(H,1) AND REF(VAR109,2) AND OPEN<REF(H,2) AND COUNT(VAR6,3)>=1;
VAR111:=IF(VAR103 AND VAR110=0,1,0);{ WWW.ZHIBIAO123.CN}
VAR112:=COUNT(VAR102,9)>=1 AND VAR41>21;
VAR113:=IF(COUNT(VAR102,9)>=1 AND VAR41<14,1,0);
VAR114:=BARSLASTCOUNT(C<OPEN AND VAR35>3.5)=3 AND BARSLASTCOUNT(C<LC AND OPEN<REF(OPEN,1))=2 AND COUNT(VAR111,3)>=2;
VAR115:=BARSLASTCOUNT(C<OPEN AND VAR35>1)>=5 AND BARSLASTCOUNT(OPEN<LC)>=4 AND COUNT(VAR39>2.5,5)>=2;
VAR116:=BARSLASTCOUNT(C<OPEN AND VAR35>0.3)>=5 AND BARSLASTCOUNT(C<LC AND OPEN<REF(OPEN,1))>=4 AND COUNT(VAR102,5)>=1;
VAR117:=VAR115 OR VAR116;{ WWW.ZHIBIAO123.CN}
VAR118:=OPEN<VAR48 AND C>VAR47;
VAR119:=REF(VAR35>7 AND C<OPEN,1) AND VAR35>7 AND C>OPEN AND C>LC;
VAR120:=BARSLASTCOUNT(VAR35<0.7 AND VAR11)>=2 AND OPEN>=REF(OPEN,1) AND C>=LC AND VAR40<1;
VAR121:=BARSLASTCOUNT(VAR35<0.7 AND VAR19)>=2 AND OPEN<=REF(OPEN,1) AND C<=LC AND VAR40<1;
VAR122:=(VAR36>7 AND VAR37<1.4) OR (VAR36>VAR35*5.4 AND VAR36>VAR37*3) OR (VAR36>VAR35*2.7 AND VAR37=0);
VAR123:=REF(VAR122,1) AND REF(VAR35+VAR36,1)>VAR35*0.7 AND C>LC;
VAR124:=COUNT(VAR35>9 OR ZT OR DT,108)>=1;{ WWW.ZHIBIAO123.CN}
VAR125:=COUNT(REF(C>OPEN,1) AND C>OPEN AND L>REF(OPEN,1) AND (H-REF(L,1))/REF(L,1)*100>12,157)>=1 OR COUNT(C>OPEN AND VAR35>9,157)>=2;
VAR126:=VAR25<MA5 AND OPEN<VAR25 AND MA5<MA10 AND C>MA10*0.997;
VAR127:=(VAR35>0.74 AND VAR37>6.5 AND VAR37>VAR35*3) OR (VAR35>1.74 AND VAR35<3.5 AND VAR37>8.1) OR (VAR35<5 AND VAR37>9 AND VAR37>VAR36*3);
VAR128:=VAR35<1 AND VAR37>VAR35*4;{ WWW.ZHIBIAO123.CN}
VAR129:=(VAR127 OR VAR128) AND VAR37>VAR36*5 AND VOL<HHV(V,7) AND BARSLASTCOUNT(MAX(C,O)<=REF(MAX(C,O),1))>=2;
VAR130:=VAR127 AND VAR37>VAR36*5 AND BARSLASTCOUNT(MAX(C,O)*0.997<=REF(MAX(C,O),1))>=2;
VAR131:=(VAR35<1 AND VAR37>8 AND VAR37>VAR35*5) AND VAR37>VAR36*5 AND MAX(C,O)<=REF(MIN(C,O),1);
VAR132:=REF(COUNT(C>OPEN,3)>=1,1);
VAR133:=C*1.01>HHV(MAX(O,C),4);{ WWW.ZHIBIAO123.CN}
VAR134:=ATAN((VAR26/REF(VAR26,1)-1)*100)*180/3.1416;
VAR135:=VAR58 AND VAR32 AND VAR47>VAR26*1.04 AND ((VAR134>-27 AND VAR51>VAR52*2) OR (VAR134<-27 AND VAR51<VAR52*2)) AND C<VAR48;
VAR136:=COUNT(一字连跌 OR VAR101,15)=0 AND COUNT(连停 OR VAR39>4.9 OR VAR117 OR VAR100,9)=0 AND VAR113=0 AND COUNT(VAR107 OR VAR114,7)=0 AND COUNT(VAR39>2.4 OR VAR111 OR (VAR13 AND OPEN>C),4)=0;
VAR137:=VAR35>3.6 AND (VAR35<4.5 OR (C=H AND VAR35<7.9)) AND OPEN*1.01>=REF(MAX(C,OPEN),1) AND OPEN>VAR25 AND REF(VAR11 AND VAR35<0.4,1)=0;
VAR138:=VAR137 AND VAR80 AND VAR136 AND REF(C>OPEN AND VAR35>3.9,1)=0 AND VAR36<VAR35/2.1 AND REF(VAR25,1)<=REF(VAR25,2);
VAR139:=VAR9 AND VAR124 AND VAR133 AND VAR132;{ WWW.ZHIBIAO123.CN}
VAR140:=COUNT(CROSS(VAR26,MA60),5)=0 AND COUNT(CROSS(VAR26,MA(C,110)),5)=0 AND (COUNT(CROSS(MA(C,70),VAR26),5)=0 OR REF(VAR129,1)) AND COUNT(CROSS(MA120,VAR26),10)=0;
VAR141:=INBLOCK(‘吉林板块’)=0 AND NAMELIKE(‘ST’)=0 AND (COUNT(VAR130,20)>=2 AND LLV(L,4)=LLV(L,81))=0;
VAR142:=REF(VAR11 AND OPEN<VAR25 AND C>VAR25,1) OR REF(VAR11 AND C<VAR25 AND VAR35<0.5,2) OR REF(C>OPEN AND OPEN<VAR25 AND C>MA5 AND MA5>VAR25,1) OR REF(VAR130,1);
VAR143:=VAR6 AND VAR138 AND VAR135 AND VAR139 AND COUNT(VAR68,11) AND VAR140 AND VAR141 AND VAR142 AND OPEN>REF(C,1) AND VAR125 AND (REF(VAR35>2 AND OPEN<VAR25 AND C*0.997>VAR25,1) OR REF(BARSLASTCOUNT(VAR35<1)>=2,1));
VAR144:=BARSLASTCOUNT(C>OPEN AND VAR36>VAR35 AND VAR37<VAR36/2)>=2 AND H=HHV(H,10) AND COUNT(C/OPEN>1.04 AND VAR9 AND REF(VAR9,1)=0 AND VAR137 AND REF(C>OPEN AND OPEN<VAR25,1) AND VAR62>=4 AND VAR36>VAR35/2.1,10) AND VAR58 AND VAR32;
VAR145:=VAR9 AND LLV(VAR25,4)=LLV(VAR25,81) AND VAR58 AND VAR47>VAR26 AND OPEN<VAR25 AND C>VAR25 AND CROSS(C,MA5) AND C<MA10;
VAR146:=VAR145 AND COUNT(VAR120,7)>=1 AND REF(VAR8 AND VAR35>4.7,1)=0 AND VAR51<17;
VAR147:=VAR121 AND COUNT(VAR145,10)>=1 AND VAR51<17 AND VAR52<5 AND VAR58 AND VAR47<VAR26;
VAR148:=VAR144 OR VAR146 OR VAR147;{ WWW.ZHIBIAO123.CN}
VAR149:=VAR143 OR VAR148;{ WWW.ZHIBIAO123.CN}
VAR150:=VAR35>3.6 AND OPEN<VAR25*1.007 AND C>VAR25 AND VAR36<VAR35/1.84 AND VAR37<VAR35/2.1;
VAR151:=REF(VAR71,1) AND VAR81<-45 AND VAR82<4 AND VAR150 AND INBLOCK(‘吉林板块’)=0 AND NAMELIKE(‘*ST’)=0;
VAR152:=VAR58 AND VAR9 AND VAR11 AND C*1.04>REF(VAR25,1) AND LLV(L,4)=LLV(L,63) AND VAR50<14.7 AND VAR51<10 AND VAR47=MA120 AND REF(OPEN>C AND VAR35>5.4,1)=0;
VAR153:=VAR58 AND VAR9 AND C>REF(VAR25,1) AND REF(L,1)=LLV(L,72) AND MA120<REF(MA120,1) AND VAR35>REF(VAR35,1) AND VAR46>-20 AND MA120<VAR26 AND VAR25=LLV(VAR25,81);
VAR154:=VAR9 AND VAR6 AND C>REF(VAR25,1) AND VAR47<VAR26 AND REF(VAR25,1)*1.04>REF(VAR25,45) AND (MA60>REF(MA60,7) OR MA120>=REF(MA120,1)) AND MA30<>VAR47 AND VAR57>7;
VAR155:=(VAR152 OR VAR153 OR VAR154) AND VAR151;{ WWW.ZHIBIAO123.CN}
VAR156:=VAR61 AND VAR50<27 AND VAR51<15 AND VAR36<1.84 AND COUNT(CROSS(MA60,MA30),9)=0 AND VAR35>REF(VAR35,1) AND COUNT(CROSS(VAR26,MA60),4)=0 AND C<HHV(VAR25,7) AND C*1.061>HHV(VAR25,7);
VAR157:=VAR58 AND COUNT(VAR69,4)>=1 AND LLV(L,4)=LLV(L,72) AND (HHV(VAR25,4)-C)/C*100<15;
VAR158:=VAR9 AND COUNT(一字跌板,4)=0 AND (VAR11 AND REF(VAR35<1,2) OR COUNT(VAR130,4)) AND VAR81<-45 AND VAR150 AND REF(VAR70,2) AND REF(VAR80,1) AND VAR157 AND NAMELIKE(‘ST’)=0 AND COUNT(DT OR C<OPEN AND VAR35>9,4)=0 AND COUNT(CROSS(MA60,MA30),14)=0 AND COUNT(CROSS(MA120,MA60),7)=0;
VAR159:=VAR155 OR VAR158;{ WWW.ZHIBIAO123.CN}
VAR160:=VAR9 AND VAR6 AND VAR81<-45 AND REF(VAR70,3) AND REF(VAR80,2) AND REF(VAR80,1) AND COUNT(DT,7)=0 AND COUNT(VAR70,4) AND VAR150 AND VAR157 AND VAR156;
VAR161:=VAR9 AND VAR6 AND REF(VAR35<1,3) AND COUNT(VAR37>4,4)=0 AND VAR81<-45 AND REF(VAR70,3) AND REF(VAR80,2) AND REF(VAR80,1) AND COUNT(DT,7)=0 AND COUNT(VAR70,4) AND VAR150 AND VAR157;
VAR162:=(COUNT(CROSS(MA60,MA30),15)=1 AND COUNT(CROSS(MA60,MA30),4)=0) OR COUNT(CROSS(VAR26,MA60),9);
VAR163:=COUNT(VAR122,4) OR VAR126;{ WWW.ZHIBIAO123.CN}
VAR164:=VAR35>3.6 AND VAR35<9 AND OPEN<VAR25*1.007 AND C>VAR25 AND VAR36<VAR35/2.1 AND VAR37<VAR35/2.1;
VAR165:=VAR164 AND REF(COUNT(C>LC,3)>=1,1) AND (VAR136 OR VAR123) AND VAR67<2 AND REF(BARSLASTCOUNT(VAR35<1.74)>=4,1)=0;
VAR166:=VAR58 AND REF(VAR80,3) AND REF(VAR80,4) AND VAR165 AND VAR139 AND VAR162 AND VAR163 AND VAR81>-60 AND VAR51<40 AND VAR90<27.4 AND VAR13=0 AND VAR141 AND REF(VAR130 AND VAR11,1)=0;
VAR167:=VAR159 OR VAR160 OR VAR161 OR VAR166;{ WWW.ZHIBIAO123.CN}
VAR168:=VAR25=LLV(VAR25,81) AND VAR58 AND VAR61 AND VAR51<4 AND VAR52>5.4 AND VAR52<10 AND COUNT(VAR68,7)>=1 AND CROSS(C,MA5) AND C<MA10 AND COUNT(VAR35>4.5 AND VAR8,7)=0 AND REF(VAR37<4,1);
VAR169:=VAR35>3.6 AND VAR36<VAR35/1.84 AND VAR37<VAR35/2.1 AND MIN(OPEN,C)>VAR25 AND REF(MAX(OPEN,C)<VAR25,1);
VAR170:=VAR9 AND VAR6 AND VAR169 AND VAR168 AND NAMELIKE(‘退’)=0 AND NAMELIKE(‘ST’)=0 AND NAMELIKE(‘*ST’)=0;
VAR171:=HHV(VAR25,9)=HHV(VAR25,36) AND MA60=VAR47 AND VAR47<VAR26 AND C<VAR48 AND COUNT(VAR71,7)>=1 AND REF(MA60,6)>=REF(MA60,7) AND MA30<REF(MA30,1) AND COUNT(CROSS(MA60,MA30),5)=0;
VAR172:=VAR9 AND VAR6 AND VAR169 AND VAR171 AND NAMELIKE(‘退’)=0 AND NAMELIKE(‘ST’)=0 AND NAMELIKE(‘*ST’)=0;
VAR173:=HHV(VAR25,9)=HHV(VAR25,36) AND VAR59 AND VAR47<VAR26 AND C<VAR48 AND VAR66 AND MA60>REF(MA60,1) AND MA120>REF(MA120,1) AND MA30<REF(MA30,1);
VAR174:=VAR9 AND VAR6 AND VAR169 AND VAR173 AND NAMELIKE(‘退’)=0 AND NAMELIKE(‘ST’)=0 AND NAMELIKE(‘*ST’)=0;
VAR175:=VAR172 OR VAR174;{ WWW.ZHIBIAO123.CN}
VAR176:=VAR9 AND VAR6 AND VAR169 AND VAR33 AND ((VAR83 AND REF(VAR11 AND VAR35>2.1,1)) OR COUNT(VAR69,4)>=1);
VAR177:=VAR34 AND VAR9 AND REF(VAR44,1) AND VAR55<15;
VAR178:=VAR176 OR VAR177;{ WWW.ZHIBIAO123.CN}
VAR179:=VAR170 OR VAR175 OR VAR178;
VAR180:=((REF(C<VAR25,1) AND OPEN>VAR25) OR (OPEN<VAR25 AND OPEN*1.027<VAR25 AND C>VAR25)) AND COUNT(VAR72,10)>=1 AND VAR55<24 AND VAR35<9 AND VAR83=0 AND REF(VAR83,1)=0 AND REF(VAR35>4.7 AND OPEN>C,1)=0 AND CROSS(C,MA5) AND C>MA5*1.01;
VAR181:=VAR9 AND VAR11=0 AND VAR36<2.1 AND ((VAR58 AND VAR47>VAR26) OR (MA120=VAR47 AND VAR47<VAR26 AND VAR52<1)) AND COUNT(VAR83,7)>=1 AND LLV(L,4)=LLV(L,72) AND VAR52*3<VAR51 AND VAR180;
VAR182:=REF(OPEN>C AND VAR35>1 AND VAR35<2,1) AND OPEN>C AND VAR35>1.5 AND VAR35<2.7 AND OPEN<REF(OPEN,1) AND OPEN*1.0021>REF(OPEN,1) AND C<LC AND C*1.0021>LC;
VAR183:=HHV(VAR25,3)=HHV(VAR25,81) AND COUNT(VAR71,5)>=1 AND REF(VAR92>80,5) AND MA60=VAR47 AND MA60>=REF(MA60,1) AND MA120>=REF(MA120,1) AND MA120<VAR25 AND VAR51<5 AND COUNT(CROSS(MA60,MA30),7)>=1;
VAR184:=VAR9 AND VAR6 AND ((REF(VAR83 AND VAR35<0.81 AND VAR11 AND C<VAR25,1) AND OPEN>VAR25) OR (REF(VAR182,1) AND VAR83 AND OPEN<VAR25 AND OPEN*1.014>VAR25)) AND VAR183;
VAR185:=REF(VAR67<7 AND VAR68,1) AND REF(VAR67,7)<REF(VAR67,1) AND VAR67<REF(VAR67,1);
VAR186:= MA30>REF(MA30,1) AND MA60>REF(MA60,1) AND MA120<REF(MA120,1) AND MA30>MA120 AND MA120>MA60 AND VAR47<VAR26 AND VAR50<10 AND VAR55<10 AND VAR62>14;
VAR187:=VAR9 AND VAR6 AND REF(VAR25,1)=HHV(VAR25,72) AND OPEN<MA60 AND C>MA120 AND VAR186 AND VAR83=0;
VAR188:=VAR181 OR VAR184 OR VAR187;{ WWW.ZHIBIAO123.CN}
VAR189:=VAR9 AND VAR6 AND VAR55<8.1 AND MA30>=REF(MA30,1) AND MA60>REF(MA60,1) AND MA120<REF(MA120,1) AND MA120=VAR47 AND VAR47<VAR26 AND VAR62>9 AND VAR67>18;
VAR190:=(VAR13 AND REF(VAR189,1) AND C=H AND OPEN>VAR47 AND C<VAR26 AND REF(VAR118,1)) OR (VAR13 AND REF(VAR189,2) AND C*1.005>VAR47 AND C<VAR26 AND C>LC AND LC>REF(C,2) AND REF(VAR164,2));
VAR191:=VAR9 AND VAR6 AND VAR119 AND CROSS(C,MA5) AND CROSS(C,MA10) AND VAR59 AND VAR60 AND OPEN>VAR47 AND VAR51<4 AND VAR50<10 AND C<VAR26 AND VAR55<10;
VAR192:=VAR190 OR VAR191;{ WWW.ZHIBIAO123.CN}
VAR193:=VAR9 AND VAR6 AND COUNT (VAR42>50 AND HHV(H,4)=HHV(H,9),14)>=1 AND REF(VAR11,1) AND LC>REF(C,2) AND VAR55<36;
VAR194:=VAR59 AND VAR60 AND CROSS(C,VAR47) AND CROSS(C,MA10) AND VAR51>10 AND CROSS(C,MA5) AND VAR193;
VAR195:=VAR58 AND CROSS(C*1.005, VAR48) AND VAR50<10 AND CROSS(C,MA5) AND VAR193;
VAR196:=((VAR59 AND VAR60 AND CROSS(C,VAR47) AND CROSS(C,MA10) AND VAR51>10) OR (VAR58 AND CROSS(C*1.005, VAR48) AND VAR50<10)) AND CROSS(C,MA5) AND VAR193;
VAR197:=VAR188 OR VAR192 OR VAR196;{ WWW.ZHIBIAO123.CN}
VAR198:=VAR149 OR VAR167 OR VAR179 OR VAR197;
VAR199:=VAR35>3.6 AND VAR81>-36 AND OPEN<VAR25*1.007 AND C>VAR25 AND VAR36<VAR35/1.84 AND VAR37<VAR35/2.1;
VAR200:=VAR62>=14 AND VAR55<17 AND VAR57<10 AND VAR50<14 AND VAR51*2<VAR52;
VAR201:=VAR9 AND VAR6 AND VAR199 AND VAR200 AND VAR45>-15 AND (MA30=VAR47 AND VAR30 AND VAR53)=0 AND COUNT(CROSS(MA60,MA30),7)=0;
VAR202:=VAR47<VAR26 AND VAR50<10 AND VAR51<4 AND C>VAR48 AND REF(VAR108,1)=0 AND VAR13=0 AND OPEN<VAR48 AND C<VAR49;
VAR203:=VAR201 AND VAR202;{ WWW.ZHIBIAO123.CN}
VAR204:=VAR79>27 AND VAR59 AND VAR60 AND OPEN>VAR47 AND C<VAR26 AND VAR55<14 AND VAR62>=9;
VAR205:=REF(BARSLASTCOUNT(L>VAR47)>21,1) AND MAX(C,O)<MA20;
VAR206:=(H-LLV(L,14))/LLV(L,14)*100;
VAR207:=(HHV(MAX(C,O),14)-MIN(C,O))/MIN(C,O)*100;
VAR208:=VAR206>40;{ WWW.ZHIBIAO123.CN}
VAR209:=VAR207<24 AND VAR207>17;
VAR210:=COUNT(VAR208,14)>=1 AND VAR209;
VAR211:=COUNT(VAR205,4) AND COUNT(VAR210,4)>=1 AND VAR133;
VAR212:=VAR9 AND VAR6 AND VAR204 AND VAR211 AND C>MAX(MA10,MA20) AND VAR35>VAR36;
VAR213:=VAR79>21 AND VAR59 AND VAR60 AND C>VAR47 AND C<VAR26 AND VAR55<7 AND VAR62>=9;
VAR214:=VAR9 AND VAR6 AND VAR213 AND COUNT(VAR205,4) AND VAR207<14 AND VAR35>VAR36 AND VAR67>=4 AND COUNT(VAR9,7)>=2;
VAR215:=VAR79>81 AND VAR59 AND VAR60 AND OPEN>VAR47 AND C>MA20 AND C<VAR26 AND VAR55<21 AND VAR62>=7;
VAR216:=VAR9 AND VAR6 AND VAR215 AND COUNT(VAR205,4) AND VAR207<27 AND VAR35>VAR36 AND VAR67>=3;
VAR217:=VAR212 OR VAR214 OR VAR216;{ WWW.ZHIBIAO123.CN}
VAR218:=(MAX(C,O)-LLV(MIN(C,O),9))/LLV(MIN(C,O),9)*100;
VAR219:=(HHV(MAX(C,O),9)-MIN(C,O))/MIN(C,O)*100;
VAR220:=VAR218>70;{ WWW.ZHIBIAO123.CN}
VAR221:=VAR219<36 AND VAR219>24;
VAR222:=COUNT(VAR220,9)>=1 AND VAR221;
VAR223:=VAR9 AND C*1.01>VAR54 AND VAR79>40 AND VAR59 AND VAR60 AND OPEN>VAR47 AND C<VAR26 AND VAR55<21 AND VAR62>=9 AND VAR67>=9 AND COUNT(VAR222,9) AND REF(COUNT(C>OPEN AND C>VAR54,9)=0,1);
VAR224:=((MAX(C,O)-LLV(MIN(C,O),2))/LLV(MIN(C,O),2)*100>14 AND COUNT(ZT,2)>=1) OR ((MAX(C,O)-LLV(MIN(C,O),3))/LLV(MIN(C,O),3)*100>19 AND COUNT(ZT,3)>=1);
VAR225:=VAR62>=18 AND VAR55<14 AND VAR25=HHV(VAR25,72) AND VAR50<10 AND VAR51>VAR52*2 AND VAR27 AND VAR28 AND VAR32;
VAR226:=REF(BARSLASTCOUNT(L>VAR48)>21,1) AND MIN(C,O)<VAR48;
VAR227:=C>LC AND LC>REF(C,2) AND C=HHV(MAX(C,O),4) AND CROSS(C,VAR49) AND OPEN>VAR48 AND C<VAR47 AND VAR57<2.4;
VAR228:=VAR9 AND VAR6 AND COUNT(VAR224,30)>=1 AND VAR227 AND VAR225 AND COUNT(VAR226,4)>=1;
VAR229:=VAR62>=4 AND VAR62<9 AND VAR59 AND VAR60 AND OPEN>VAR47 AND C<VAR26 AND VAR55<14 AND VAR51>VAR52*2;
VAR230:=VAR219>17 AND L=LLV(L,3);{ WWW.ZHIBIAO123.CN}
VAR231:=VAR229 AND COUNT(VAR208,24)=0 AND COUNT(VAR224,12)>=1;
VAR232:=VAR9 AND COUNT(VAR230,4)=0 AND VAR231 AND COUNT(CROSS(MA30,MA60),12)=0;
VAR233:=VAR62>=14 AND VAR62<18 AND VAR59 AND VAR60 AND OPEN>VAR47 AND C<VAR26 AND VAR55<10 AND VAR51>VAR52*2;
VAR234:=VAR233 AND COUNT(VAR224,21)>=1;
VAR235:=VAR9 AND VAR6 AND VAR234;{ WWW.ZHIBIAO123.CN}
VAR236:=BARSLASTCOUNT(VAR35>4.5 AND C>OPEN)>=3 AND BARSLASTCOUNT(OPEN*1.01>LC)>=2 AND (MAX(C,O)-LLV(MIN(C,O),3))/LLV(MIN(C,O),3)*100<19 AND COUNT(ZT,3)=0;
VAR237:=VAR62>=18 AND VAR62<27 AND VAR59 AND VAR60 AND VAR55<10 AND VAR51>VAR52*2;
VAR238:=VAR237 AND COUNT(VAR236,27)>=1;{ WWW.ZHIBIAO123.CN}
VAR239:=VAR9 AND VAR6 AND OPEN<VAR47 AND C>VAR47 AND VAR238;
VAR240:=(MAX(C,O)-LLV(MIN(C,O),3))/LLV(MIN(C,O),3)*100>21 AND COUNT(ZT,3)>=2;
VAR241:=REF(BARSLASTCOUNT(L>VAR47)>21,1) AND MAX(C,O)<VAR47;
VAR242:=REF(BARSLASTCOUNT(L>MA40)>36,1) AND MAX(C,O)<MA40 AND REF(VAR241,1)>=1;
VAR243:=VAR9 AND VAR62>=18 AND VAR62<27 AND COUNT(VAR240,36)>=1 AND VAR59 AND VAR28 AND VAR29;
VAR244:=VAR55<14 AND VAR243 AND COUNT(VAR242,7)>=1 AND C=HHV(MAX(C,O),7);
VAR245:=MAX(VAR47,VAR54);{ WWW.ZHIBIAO123.CN}
VAR246:=COUNT(BARSLASTCOUNT(L>VAR49)>45,4)>=1 AND MAX(C,O)<VAR49;
VAR247:=VAR9 AND COUNT(VAR246,4) AND VAR133 AND VAR36>5.7;
VAR248:=BARSLASTCOUNT(VAR35<0.7)>=3 AND LLV(MAX(C,O),3)>=REF(C,BARSLAST(VAR247)+1) AND HHV(MAX(C,O),3)<REF(H,BARSLAST(VAR247)) AND LLV(MAX(C,O),3)*1.01>=VAR245 AND COUNT(VAR247,7);
VAR249:=VAR24 AND REF(VAR9,1) AND (REF(VAR83 AND VAR35<0.4,2) OR (VAR83 AND VAR35*2>REF(VAR35,1))) AND COUNT(VAR246,4) AND HHV(VAR25,4)=HHV(VAR25,72) AND VAR62>=9 AND VAR62<14 AND VAR59;
VAR250:=REF(VAR83,3) AND HHV(VAR25,5)=HHV(VAR25,72);
VAR251:=VAR250 AND VAR243 AND COUNT(VAR246,4) AND COUNT(DT AND C=OPEN,5)=0 AND REF(MIN(C,O),3)>VAR49;
VAR252:=VAR248 OR VAR249 OR VAR251;{ WWW.ZHIBIAO123.CN}
VAR253:=VAR203 OR VAR217 OR VAR223 OR VAR228 OR VAR232 OR VAR235 OR VAR239 OR VAR244 OR VAR252;
VAR254:=REF(VAR6 AND VAR11=0 AND VAR35<2,1) AND VAR35<0.54 AND C>=LC AND VAR40<1.02 AND VAR35*3<REF(VAR35,1);
VAR255:=BARSLASTCOUNT(VAR35>0.7 AND VAR35<1.027 AND VAR11)>=2 AND VAR40<1 AND C>=LC;
VAR256:=((REF(VAR255,1) AND REF(MAX(C,O)<VAR25,2)) OR (REF(VAR254,1) AND REF(MAX(C,O)<=VAR25,3))) AND VAR9 AND VAR13=0 AND OPEN*1.01>=REF(MAX(C,OPEN),1) AND OPEN<VAR48 AND OPEN>VAR25 AND VAR59 AND VAR28 AND VAR29 AND VAR51*3<VAR52;
VAR257:=REF(VAR9 AND VAR35>4.37,1) AND C<OPEN AND VAR35<0.63 AND MAX(C,O)*1.01>LC;
VAR258:=VAR257 AND REF(VAR257,2) AND REF(OPEN<VAR48,1);{ WWW.ZHIBIAO123.CN}
VAR259:=VAR9 AND OPEN*0.99<VAR25 AND OPEN<VAR48 AND C>VAR48 AND C<VAR49 AND COUNT(CROSS(MA60,MA30),4) AND VAR57<7 AND VAR55<24 AND REF(VAR67>14,1) AND REF(VAR62>27,2) AND VAR51*3<VAR52;
VAR260:=VAR9 AND COUNT(CROSS(MA60,MA30),7) AND OPEN<VAR49 AND C>VAR47 AND OPEN>VAR48 AND VAR51*3<VAR52;
VAR261:=VAR6 AND REF(VAR130,1) AND COUNT(VAR260,4) AND VAR133 AND OPEN>VAR47;
VAR262:=VAR256 OR VAR258 OR VAR259 OR VAR261;{ WWW.ZHIBIAO123.CN}
VAR263:=VAR9 AND VAR62>=6 AND VAR67>=15 AND VAR55<15 AND VAR51*3<VAR52 AND VAR133 AND OPEN<VAR49 AND C>VAR47 AND VAR59 AND VAR28 AND VAR29 AND REF(BARSLASTCOUNT(MAX(C,O)<VAR49)>=3,1) AND C>VAR245;
VAR264:=VAR9 AND VAR6 AND COUNT(VAR131,4) AND VAR59 AND VAR62>=14 AND VAR67>=18 AND VAR51*2<VAR52;
VAR265:=VAR9 AND OPEN*0.99<VAR49 AND C>VAR47 AND VAR51<VAR52 AND VAR51*2>VAR52 AND VAR67<=4 AND VAR62<=1 AND REF(BARSLASTCOUNT(MAX(C,O)<REF(MAX(C,O),1) AND MIN(C,O)<REF(MIN(C,O),1))>=2 AND BARSLASTCOUNT(VAR37>3.6)>=3,1);
VAR266:=BARSLASTCOUNT(VAR35>0.3 AND VAR35<3 AND C>VAR26)>=3 AND VAR35=LLV(VAR35,3) AND COUNT(VAR265,14);
VAR267:=VAR9 AND VAR58 AND VAR28 AND VAR62>27 AND VAR67>14 AND VAR55<7 AND VAR50<4 AND OPEN<VAR48 AND C>VAR49 AND COUNT(CROSS(MA60,MA30),7) AND COUNT(VAR36>5.4,14)>=1;
VAR268:=VAR9 AND VAR83 AND VAR79>21 AND OPEN>REF(MIN(C,O),1) AND C>REF(MAX(C,O),1) AND REF(VAR67>=2,2);
VAR269:=REF(VAR11 AND OPEN=LLV(MIN(C,O),108),1) AND VAR11 AND OPEN<VAR25 AND C>VAR25 AND C>LC;
VAR270:=REF(VAR21 AND VAR35>1 AND VAR35<1.4,1) AND VAR35<0.7 AND VAR40<1 AND VAR35<REF(VAR35,1);
VAR271:=VAR270 AND REF(VAR269,2) AND REF(OPEN*1.01,1)>REF(C,2) AND HHV(MAX(C,O),4)<VAR48 AND VAR51*2.5<VAR52;
VAR272:=VAR263 OR VAR264 OR VAR266 OR VAR267 OR VAR268 OR VAR271;{ WWW.ZHIBIAO123.CN}
黄龙帝国副:VAR198 OR VAR253 OR VAR262 OR VAR272;

通达信《黄龙帝国4更》副图指标公式源码:

MA5:=MA(C,5);
MA10:=MA(C,10);MA20:=MA(C,20);
MA30:=MA(C,30);MA40:=MA(C,40);
MA60:=MA(C,60);
MA120:=MA(C,120);
LC:=REF(C,1);{ WWW.ZHIBIAO123.CN}
DT:=REF(C,1)/C>1.1;
ZT:=C>REF(C,1)*1.095 AND C=H;
ZF:=(C-LC)/LC*100;{ WWW.ZHIBIAO123.CN}
十字星:=H<>L AND C=OPEN;
连板:=BARSLASTCOUNT(ZT)>=2;
连停:=BARSLASTCOUNT(DT)>=2;
一字板:=C>REF(C,1)*1.095 AND C=H AND L=H;
一字停:=C/REF(C,1)<=1.09 AND O=C AND C=L;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
VAR1:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF (C,2);
VAR2:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));{ WWW.ZHIBIAO123.CN}
VAR3:=REF(VAR2,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR5:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);{ WWW.ZHIBIAO123.CN}
VAR6:=REF(VAR5,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR8:=REF(VAR5 OR VAR6 OR VAR7,1) AND VAR2;
VAR9:=VAR8 AND CLOSE>OPEN;{ WWW.ZHIBIAO123.CN}
VAR10:=REF(VAR2,1) AND VAR5 AND NOT(REF(C,3)=LLV(C,4));
VAR11:=(REF(VAR2 OR VAR3 OR VAR4,1)) AND VAR5;
VAR12:=IF(C>MA(C,4),1,0);{ WWW.ZHIBIAO123.CN}
VAR13:=IF(C<MA(C,4),-1,0);
VAR14:=IF(MA(C,5)>REF(MA(C,5),1),1,0);
VAR15:=IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR16:=VAR12+VAR13+VAR14+VAR15;
VAR17:=VAR16=2 AND C<O;{ WWW.ZHIBIAO123.CN}
VAR18:=C/OPEN>1.04 AND C<SMA(HIGH,19,3) AND C>REF(C,1);
VAR19:=IF(C>MA(C,4),1,0)+IF(C<MA(C,4),-1,0)+IF(MA(C,5)>REF(MA(C,5),1),1,0)+IF(MA(C,5)<REF(MA(C,5),1),-1,0);
VAR20:=VAR19=-2 AND C>O;{ WWW.ZHIBIAO123.CN}
VAR21:= EMA((CLOSE*2+HIGH+LOW)/4,13)-EMA((CLOSE*2+HIGH+LOW)/4,73);
VAR22:=(CROSS(VAR21,EMA(VAR21,2)) AND VAR21<=0.05 AND (C/REF(C,1)>0.035));
VAR23:=(VAR6 OR VAR7) AND C>OPEN AND VAR20=0 AND VAR1=0;
VAR24:=CLOSE>OPEN AND VAR9=0 AND VAR18=0 AND VAR20=0 AND VAR22=0 AND VAR23=0 AND VAR1=0;
VAR25:=REF(VAR7,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR26:=(VAR5 OR VAR6 OR VAR7 OR VAR25) AND VAR1=0 AND VAR20=0 AND VAR22=0 AND VAR10=0;
VAR27:=C<REF(C,1) AND C<OPEN AND C>REF(OPEN,1) AND VAR26=0 AND VAR17=0 AND VAR1=0;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
VAR28:=MAX(MA30,MAX(MA60,MA120));
VAR29:=MIN(MA30,MIN(MA60,MA120));
VAR30:=IF(MA30<>VAR28 AND MA30<>VAR29,MA30,IF(MA60<>VAR28 AND MA60<>VAR29,MA60,MA120));
VAR31:=(VAR28-VAR29)/VAR29*100;{ WWW.ZHIBIAO123.CN}
VAR32:=(VAR28-VAR30)/VAR30*100;
VAR33:=(VAR30-VAR29)/VAR29*100;
VAR34:=MAX(VAR32,VAR33)/MIN(VAR32,VAR33);
VAR35:=(VAR29-MAX(C,O))/MAX(C,O)*100;
VAR36:=(MAX(C,O)-MIN(C,O))/MIN(C,O)*100;
VAR37:=(H-MAX(C,O))/MAX(C,O)*100;
VAR38:=(MIN(C,O)-L)/L*100;{ WWW.ZHIBIAO123.CN}
VAR39:=(MIN(C,O)-REF(MAX(C,O),1))/REF(MAX(C,O),1)*100;
VAR40:=(REF(MIN(C,O),1)-MAX(C,O))/MAX(C,O)*100;
VAR41:=MA(REF(LLV(C,30),1),2);
VAR42:=MA(REF(HHV(C,30),1),2);
VAR43:=(VAR42-VAR41)/VAR41*100;
VAR44:=(VAR42-MAX(C,O))/MAX(C,O)*100;
VAR45:=(MIN(C,O)-VAR41)/VAR41*100;
VAR46:=(VAR28-C)/C*100;{ WWW.ZHIBIAO123.CN}
VAR47:=MA120>MA60 AND MA60>MA30;
VAR48:=MA30>MA60 AND MA60>MA120;
VAR49:=MA30>REF(MA30,1) AND MA60>REF(MA60,1) AND MA120>=REF(MA120,1);
VAR50:=MA30<REF(MA30,1) AND MA60<REF(MA60,1) AND MA120<=REF(MA120,1);
VAR51:=(MAX(VAR28,VAR42)-MIN(VAR28,VAR42))/MIN(VAR28,VAR42)*100;
VAR52:=BARSLASTCOUNT(VAR48 AND VAR49)>=7;
VAR53:=BARSLASTCOUNT(VAR42=REF(VAR42,1));
VAR54:=BARSLASTCOUNT(VAR41=REF(VAR41,1));
VAR55:=VAR54>=4;{ WWW.ZHIBIAO123.CN}
VAR56:=VAR54>=9;
VAR57:=VAR54>=27;
VAR58:=BARSLAST(VAR55);
VAR59:=REF(VAR41,VAR58);
VAR60:=REF(VAR59,VAR58-1);
VAR61:=IF(VAR55>0,VAR41,0);
VAR62:=IF(VAR55>0,VAR41,VAR60);
VAR63:=(VAR62-MAX(C,O))/MAX(C,O)*100;
VAR64:=(MIN(C,O)-VAR62)/VAR62*100;
VAR65:=VAR41<REF(VAR41,1);{ WWW.ZHIBIAO123.CN}
VAR66:=REF(VAR41,1)>REF(VAR41,2) AND VAR41<REF(VAR41,1);
VAR67:=REF(VAR41,3)<REF(VAR41,2) AND REF(VAR41,1)=REF(VAR41,2) AND VAR41<REF(VAR41,1);
VAR68:=ATAN((VAR42/REF(VAR42,1)-1)*100)*180/3.1416;
VAR69:=ATAN((VAR41/REF(VAR41,1)-1)*100)*180/3.1416;
VAR70:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;{ WWW.ZHIBIAO123.CN}
VAR71:=ATAN((MA120/REF(MA120,1)-1)*100)*180/3.1416;
VAR72:=MA30>=REF(MA30,1);VAR73:=MA60>=REF(MA60,1);VAR74:=MA120>=REF(MA120,1);
VAR75:=MA30<REF(MA30,1);VAR76:=MA60<REF(MA60,1);VAR77:=MA120<REF(MA120,1);
{—————————————————————————————————————};
VAR78:=(HHV(MAX(C,O),4)-LLV(MIN(C,O),4))/LLV(MIN(C,O),4)*100;{ WWW.ZHIBIAO123.CN}
VAR79:=(HHV(MAX(C,O),10)-LLV(MIN(C,O),10))/LLV(MIN(C,O),10)*100;
VAR80:=BARSLASTCOUNT(MIN(C,O)>REF(MIN(C,O),1) AND MAX(C,O)>REF(MAX(C,O),1))>=2 AND BARSLASTCOUNT(VAR36>1.4 AND VAR36<4.2)>=3;
VAR81:=(MAX(C,O)*2+MIN(O,C))/3;{ WWW.ZHIBIAO123.CN}
VAR82:=(MIN(C,O)*2+MAX(C,O))/3;
VAR83:=REF(BARSLASTCOUNT(O>C AND VAR36>4)>=3 AND BARSLASTCOUNT(MAX(C,O)<=REF(VAR82,1))>=2,1) AND MIN(C,O)*1.01>LC;
VAR84:=(MAX(REF(MAX(C,O),1),MAX(C,O))-MIN(REF(MAX(C,O),1),MAX(C,O)))/MIN(REF(MAX(C,O),1),MAX(C,O))*100;
VAR85:=(MAX(REF(MIN(C,O),1),MIN(C,O))-MIN(REF(MIN(C,O),1),MIN(C,O)))/MIN(REF(MIN(C,O),1),MIN(C,O))*100;
VAR86:=MAX(MAX(MA5,MA10),MAX(MA20,MA40));
VAR87:=MAX(VAR28,VAR86);{ WWW.ZHIBIAO123.CN}
VAR88:=C*1.01>HHV(MAX(O,C),4);
VAR89:=BARSLAST(VAR56);
VAR90:=REF(VAR41,VAR89);
VAR91:=REF(VAR90,VAR89-1);
VAR92:=VAR41 AND VAR56;
VAR93:=IF(VAR92>0,VAR41,0);
VAR94:=(MAX(VAR91,VAR93)-MIN(VAR91,VAR93))/MIN(VAR91,VAR93)*100;
VAR95:=CROSS(C,MA120*0.995) AND C<MA120*1.005 AND REF(BARSLASTCOUNT(C<MA120)>=2,1);
VAR96:=CROSS(C,MA60*0.995) AND C<MA60*1.005 AND REF(BARSLASTCOUNT(C<MA60)>3,1);
VAR97:=((C>MA30 AND CROSS(C,MA30)) OR (C<MA30 AND CROSS(C,MA30*0.995))) AND C<MA30*1.005 AND REF(BARSLASTCOUNT(C<MA30)>3,1);
VAR98:=CROSS(C,MA10*0.995) AND C<MA10*1.005 AND REF(BARSLASTCOUNT(C<MA10)>3,1);
VAR99:=CROSS(C,MA40*0.995) AND C<MA40*1.005;{ WWW.ZHIBIAO123.CN}
VAR100:=VAR95 OR VAR96 OR VAR97 OR VAR98 OR VAR99;
VAR101:=REF(VAR39>5.5,2) AND REF(MIN(C,O),1)>REF(MAX(C,O),3) AND VAR40>1.5 AND REF(VAR36>9 AND VAR17,1)=0 AND REF(BARSLASTCOUNT(VAR17)<2,1);
VAR102:=REF(VAR39>4.5,3) AND REF(MIN(C,O),2)>REF(MIN(C,O),3) AND REF(MIN(C,O),1)>REF(MIN(C,O),3) AND VAR40>3;
VAR103:=VAR101 OR VAR102;{ WWW.ZHIBIAO123.CN}
VAR104:=REF(VAR36<2.1 AND VAR37>4.7 AND VAR37>VAR36*3,1) AND VAR36<2.1 AND VAR38>3.6 AND VAR38>VAR36*3 AND MAX(C,O)<REF(MAX(C,O),1);
VAR105:=REF(VAR36>6 AND C<OPEN,1) AND VAR36>5 AND C>OPEN AND C>REF(MAX(C,O),1);
VAR106:=REF(VAR10 AND VAR36>3.6,1) AND VAR36>4 AND OPEN<REF(OPEN,1) AND C>REF(OPEN,1);
VAR107:=VAR94>10 AND VAR93<VAR91 AND COUNT(CROSS(MA60,MA30),9);{ WWW.ZHIBIAO123.CN}
VAR108:=C>OPEN AND VAR36>4 AND COUNT(((VAR10 AND VAR36>3.6) OR (OPEN>C AND VAR36>5)),4) AND COUNT(VAR107,4) AND C>VAR41 AND VAR64<10 AND VAR54>=9;
VAR109:=OPEN*0.99<VAR29 AND C>VAR28;{ WWW.ZHIBIAO123.CN}
VAR110:=REF(C<OPEN AND VAR36>5.4,1) AND VAR36>5.4 AND C>OPEN AND VAR84<0.5 AND VAR85<1;
VAR111:=BARSLASTCOUNT(VAR36<0.54 AND VAR17)>=2 AND VAR36<REF(VAR36,1);
VAR112:=VAR24 AND VAR36>2 AND VAR36<2.17 AND VAR37>1.2 AND VAR38<VAR36/2 AND BARSLASTCOUNT(MAX(C,O)>REF(MAX(C,O),1))>=3;
VAR113:=VAR112 AND REF(VAR112,1)=0 AND REF(VAR112,2) AND VAR36>REF(VAR36,1);
VAR114:=VAR24 AND VAR36>1 AND VAR36<2.4 AND VAR37>2.9 AND VAR38<VAR36 AND BARSLASTCOUNT(MAX(C,O)>REF(MAX(C,O),1))>=2;
VAR115:=VAR114 AND REF(VAR114,1)=0 AND REF(VAR114,2) AND VAR36>REF(VAR36,1);{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
VAR116:=COUNT(BARSLASTCOUNT(L>MA30)>21,4)>=1 AND MAX(C,O)<MA30;
VAR117:=COUNT(BARSLASTCOUNT(L>MA60)>45,7)>=1 AND MAX(C,O)<MA60;
VAR118:=(HHV(VAR41,10)-LLV(VAR41,10))/LLV(VAR41,10)*100;
VAR119:=VAR118>10 AND VAR118<40 AND HHV(VAR41,3)=HHV(VAR41,10);
VAR120:=VAR118>20 AND VAR118<40 AND LLV(VAR41,3)=LLV(VAR41,10);
VAR121:=(MAX(C,O)-LLV(MIN(C,O),9))/LLV(MIN(C,O),9)*100;
VAR122:=(HHV(MAX(C,O),9)-MIN(C,O))/MIN(C,O)*100;
VAR123:=VAR121>70;{ WWW.ZHIBIAO123.CN}
VAR124:=VAR122<36 AND VAR122>24;
VAR125:=COUNT(VAR123,9)>=1 AND VAR124;
VAR126:=REF(MAX(C,O)*0.995<VAR41,1) AND C>OPEN AND OPEN*0.995<VAR41 AND C>VAR41 AND VAR65 AND VAR36>2.1 AND VAR37<VAR36/1.84 AND VAR38<VAR36/2.1;
VAR127:=VAR36>3.6 AND VAR36<9 AND OPEN<VAR41*1.007 AND C>VAR41 AND VAR37<VAR36/2.1 AND VAR38<VAR36/2.1 AND VAR54>=4;
VAR128:=VAR36>3.6 AND OPEN<VAR41*1.007 AND C>VAR41 AND VAR37<VAR36/2.1 AND VAR38<VAR36/2.1 AND BARSLASTCOUNT(VAR69>-35 AND VAR69<=0)>=4 AND REF(MAX(C,O),1)>VAR41;
VAR129:=VAR9 AND VAR54>=1 AND VAR54<4 AND OPEN<VAR41 AND C>VAR41;{ WWW.ZHIBIAO123.CN}
VAR130:=VAR18 AND VAR54>=1 AND VAR54<4 AND OPEN*0.997<VAR41 AND C>VAR41;
VAR131:=VAR18 AND REF(VAR54>=4,1) AND VAR126 AND REF(VAR54>=18,1) AND REF(一字停=0 AND VAR36<7 AND VAR63>3.8,1) AND VAR36>REF(VAR36,1) AND VAR34<2 AND VAR47 AND VAR50 AND VAR31<20 AND (VAR32>VAR33 OR VAR34<1.27);
{—————————————————————————————————————};
VAR132:=C<VAR42 AND VAR44<10;{ WWW.ZHIBIAO123.CN}
VAR133:=VAR43<10 AND VAR54>=21 AND VAR53>=7 AND VAR34<2.1;
VAR134:=VAR43<14 AND VAR54>=14 AND VAR53>=14 AND VAR73 AND VAR34<2.7;
VAR135:=VAR31<9 AND VAR53>=9 AND VAR54>=21 AND VAR43<21 AND VAR34<1.57;
VAR136:=VAR31<9 AND VAR53>=4 AND COUNT(VAR54>=21,4) AND VAR43<21 AND VAR34<1.57;
VAR137:=VAR132 AND BARSLASTCOUNT(VAR51<4.17)>=4 AND (VAR134 OR VAR136);
VAR138:=((C>MA30 AND CROSS(C,MA30)) OR (C<MA30 AND CROSS(C,MA30*0.995))) AND C<MA30*1.005;
VAR139:=CROSS(C,MA40) AND C<MA40*1.007;{ WWW.ZHIBIAO123.CN}
VAR140:=VAR138 AND REF(VAR54>=14,4) AND VAR64<7 AND VAR36>REF(VAR36,1) AND REF(VAR40<4,1) AND VAR47;
VAR141:=VAR139 AND REF(VAR53>=9,1) AND VAR54>=14 AND VAR64<11 AND COUNT(CROSS(MA120,MA60),7)=0;
VAR142:=VAR18 AND VAR132 AND VAR47 AND VAR34<1.57 AND VAR37<4 AND BARSLASTCOUNT(VAR51<4.17)>=4 AND (VAR140 OR VAR141);
VAR143:=VAR18 AND VAR132 AND VAR47 AND VAR34<1.57 AND VAR73 AND VAR141 AND VAR22=0;
VAR144:=VAR142 OR VAR143;{ WWW.ZHIBIAO123.CN}
VAR145:=VAR18 AND VAR100 AND VAR64<7 AND VAR132 AND ((MA60=VAR28 AND (VAR67 OR REF(VAR104,1))) OR (BARSLASTCOUNT(VAR51<4.17)>=4 AND VAR133) OR (VAR109 AND VAR135));
VAR146:=VAR18 AND VAR137 AND VAR127;{ WWW.ZHIBIAO123.CN}
VAR147:=VAR18 AND VAR36<7 AND VAR48 AND VAR49 AND VAR132 AND VAR54<4 AND VAR53>=4 AND VAR64>10 AND VAR64<18 AND (VAR110 OR VAR109);
VAR148:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54<4 AND VAR53>=4 AND VAR64>10 AND VAR64<18 AND REF(C<OPEN AND VAR36>4.5,1)=0 AND ((OPEN<MA40 AND OPEN*1.005>MA40 AND VAR37<1) OR (OPEN>MA40 AND MA40*1.005>OPEN AND C>MA20 AND VAR38<1.54));
VAR149:=VAR147 OR VAR148;{ WWW.ZHIBIAO123.CN}
VAR150:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54<1 AND VAR53>=4 AND OPEN>MA30 AND VAR64>18 AND VAR64<30 AND VAR37>3 AND VAR34>2;
VAR151:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54<1 AND VAR53>=9 AND OPEN>MA30 AND VAR64>30 AND VAR64<40 AND REF(BARSLASTCOUNT(MAX(C,O)<MA20)>=2,1) AND COUNT(L<MA30,3)>=1 AND COUNT(C<OPEN AND VAR36>7,4)=0;
VAR152:=VAR149 OR VAR150 OR VAR151;{ WWW.ZHIBIAO123.CN}
VAR153:=VAR144 OR VAR145 OR VAR146 OR VAR152;
VAR154:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54>=7 AND VAR53>=7 AND VAR64>10 AND VAR64<18 AND VAR36>7 AND OPEN>MA40;
VAR155:=VAR18 AND VAR20=0 AND REF(一字停,1) AND VAR48 AND VAR49 AND VAR132 AND VAR36>7 AND VAR53>=1 AND VAR54=0 AND VAR64>20 AND OPEN<MA40 AND C>MA40;
VAR156:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR53>=18 AND VAR37>3 AND VAR34>2 AND VAR32>VAR33;
VAR157:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR53>=4 AND VAR53<9 AND VAR34>2 AND VAR34<2.5 AND COUNT(CROSS(MA30,MA40),14)=0 AND OPEN>MA30 AND VAR36>REF(VAR36,1)*2 AND VAR43<40 AND COUNT(VAR40>5.4,4)=0 AND COUNT(VAR10 AND VAR36>4.5,4)=0 AND COUNT(C<OPEN AND VAR36>10,7)=0;
VAR158:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54<4 AND VAR53>=9 AND VAR64>10 AND VAR64<18 AND REF(OPEN>C AND VAR36>6.3,1) AND VAR36>4 AND OPEN>LC*1.04;
VAR159:=VAR18 AND VAR132 AND C>VAR87 AND VAR53>=7 AND VAR54>=21 AND VAR64>18 AND VAR36>3.6 AND VAR44<7 AND VAR43<40 AND VAR31<1.4 AND OPEN*0.995<VAR29;
VAR160:=VAR18 AND VAR132 AND VAR44<7 AND C>VAR87 AND VAR36>3.6 AND VAR109 AND VAR73 AND VAR31<5 AND VAR53>=18 AND VAR64>8 AND ((REF(VAR10 AND VAR36>3,1)) OR (MA30=VAR28)) AND COUNT(VAR10 AND VAR36>3.6 AND VAR38>4.5,7)=0;
VAR161:=VAR18 AND VAR132 AND REF(VAR103,1) AND C<REF(MIN(C,O),2) AND MA120<VAR42;
VAR162:=VAR18 AND VAR132 AND VAR100 AND VAR105 AND VAR53>=14 AND VAR31<10;{ WWW.ZHIBIAO123.CN}
VAR163:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR53>=9 AND VAR36>5 AND VAR44<7 AND VAR34<2 AND REF(COUNT(VAR36>4.5 AND C>OPEN,5),1) AND OPEN>MA40 AND OPEN*0.98<MA40;
VAR164:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54>=14 AND VAR54<21 AND VAR34>2.8 AND VAR34<3.5 AND VAR32<VAR33 AND VAR43>30 AND COUNT(VAR36>4.5 AND OPEN>C AND (VAR10 OR VAR40>3),4);
VAR165:=VAR18 AND VAR48 AND VAR49 AND VAR132 AND VAR54>=3 AND VAR53>=3 AND VAR64>20 AND VAR43<40 AND VAR34<2.5 AND VAR80;
VAR166:=VAR154 OR VAR155 OR VAR156 OR VAR157 OR VAR158 OR VAR159 OR VAR160 OR VAR161 OR VAR162 OR VAR163 OR VAR164 OR VAR165;
VAR167:=VAR18 AND VAR132 AND VAR66 AND VAR83 AND VAR48 AND COUNT(VAR52,7) AND VAR53>=4 AND VAR54=0 AND VAR64>18;
CS1:=VAR153 OR VAR166 OR VAR167;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
VAR168:=VAR44>=10 AND VAR44<20;{ WWW.ZHIBIAO123.CN}
VAR169:=VAR18 AND VAR53>=18 AND VAR48 AND VAR168 AND COUNT(VAR116,7) AND VAR100 AND COUNT(VAR52,4) AND OPEN<MA30 AND VAR88 AND VAR36>3.6 AND VAR64>18 AND C*1.01>VAR87 AND COUNT(C<O AND VAR36>4.5,7)=0;
VAR170:=VAR18 AND VAR168 AND VAR117 AND VAR100 AND VAR48 AND COUNT(BARSLASTCOUNT(VAR49)>=7,9) AND BARSLASTCOUNT(C>LC)>=2 AND VAR36>3.6 AND COUNT(VAR36<0.5,3);
VAR171:=VAR169 OR VAR170;{ WWW.ZHIBIAO123.CN}
VAR172:=VAR18 AND VAR168 AND VAR106 AND COUNT(VAR125,9) AND VAR48 AND VAR49 AND VAR53>=9 AND VAR54>=9;
VAR173:=VAR18 AND VAR168 AND VAR108 AND VAR53>=1 AND VAR54>=9 AND VAR64<5 AND VAR31<10 AND VAR34<2 AND VAR32>VAR33 AND C*1.0214>HHV(MAX(O,C),4);
VAR174:=VAR18 AND VAR168 AND VAR47 AND VAR53>=27 AND VAR54>=9 AND CROSS(MA60,MA30) AND OPEN>VAR41 AND OPEN*0.99<VAR41 AND VAR43<25 AND VAR31<10;
VAR175:=VAR18 AND VAR168 AND VAR52 AND MA40>MA60 AND OPEN>MA40 AND VAR53>=14 AND VAR54=0 AND VAR64>25 AND VAR31<14 AND VAR34>1.4 AND VAR34<1.7;
VAR176:=VAR174 OR VAR175;{ WWW.ZHIBIAO123.CN}
VAR177:=VAR113 AND BARSLASTCOUNT(VAR72)>=7 AND BARSLASTCOUNT(C*1.01>VAR87)>=3 AND REF(VAR38<VAR36,1);
VAR178:=VAR24 AND REF(VAR24 AND COUNT(VAR111,4) AND COUNT(VAR79<10,4),1) AND BARSLASTCOUNT(VAR47 AND VAR50)>=7 AND BARSLASTCOUNT(MAX(C,O)<VAR29)>=7 AND VAR54>=9 AND VAR31<4;
CS2:=VAR171 OR VAR172 OR VAR176 OR VAR173 OR VAR177 OR VAR178;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
VAR179:=VAR44>=20;{ WWW.ZHIBIAO123.CN}
VAR180:=VAR47 AND VAR77 AND VAR28>VAR42*1.04 AND ((VAR68>-27 AND VAR32>VAR33*2) OR (VAR68<-27 AND VAR32<VAR33*2)) AND C<VAR29;
VAR181:=VAR18 AND VAR36<6.3 AND VAR128 AND (VAR47 OR BARSLASTCOUNT(VAR33<1.4)>=4) AND MA120>VAR42 AND VAR44>20 AND COUNT(VAR53>=4,4) AND C*1.03>HHV(MAX(C,O),7) AND REF(COUNT(VAR10,4)=0 AND BARSLASTCOUNT(VAR36<2.42)>=3 AND COUNT(C<OPEN,3)>=2,1);
VAR182:=VAR181 AND (C=LLV(MAX(C,O),4) OR C=HHV(MAX(C,O),7));
VAR183:=VAR18 AND VAR69<=0 AND VAR69>-10 AND REF(VAR54>=14,1) AND VAR36>3.6 AND OPEN<VAR41 AND C>VAR41 AND REF(COUNT(VAR18 AND VAR127,14)=1,1) AND REF(COUNT(VAR18 AND VAR127,9)=0,1) AND VAR47 AND VAR50 AND COUNT(VAR53>=7,9);
VAR184:=VAR182 OR VAR183;{ WWW.ZHIBIAO123.CN}
VAR185:=VAR18 AND VAR22=0 AND VAR179 AND REF(VAR129,1) AND VAR47 AND VAR50 AND COUNT(VAR53>=7,7) AND COUNT(VAR54>=9,9) AND CROSS(C,MA10) AND REF(VAR18,1)=0;
VAR186:=VAR130 AND REF(BARSLASTCOUNT(VAR69<-70),1)>=4 AND VAR120 AND VAR82>REF(MAX(C,O),1) AND REF(MAX(C,O),1)>=REF(MAX(C,O),2)*0.999 AND REF(BARSLASTCOUNT(VAR36<1.5)>=2,1);
VAR187:=VAR185 OR VAR186;{ WWW.ZHIBIAO123.CN}
VAR188:=VAR18 AND VAR179 AND VAR47 AND VAR34<1.57 AND BARSLASTCOUNT(VAR51<4)>=4 AND VAR50 AND REF(一字停,1) AND VAR65 AND VAR53>=14 AND REF(VAR54>=18,3) AND VAR36>3.6;
VAR189:=VAR18 AND VAR22 AND VAR36>7 AND VAR179 AND BARSLASTCOUNT(VAR47 AND VAR50)>=7 AND COUNT(VAR53>=21,7) AND BARSLASTCOUNT(MAX(C,O)<VAR29)>=7 AND BARSLASTCOUNT(OPEN>VAR41 AND VAR41*1.04>OPEN)>=3 AND BARSLASTCOUNT(VAR51<1)>=7;
VAR190:=VAR188 OR VAR189;{ WWW.ZHIBIAO123.CN}
VAR191:=VAR179 AND VAR83 AND COUNT(VAR52,4) AND VAR53>=4 AND VAR54>=4 AND REF(VAR64>18 AND VAR64<70,1);
VAR192:=VAR20 AND VAR66 AND REF(一字停,1) AND VAR36<6.3 AND REF(MA20>VAR28 AND VAR36>4.5 AND VAR10=0,2) AND COUNT(VAR119,3) AND REF(C<VAR41 AND C*1.04>VAR41,1) AND C>VAR41;
VAR193:=VAR18 AND VAR9 AND VAR53>=9 AND COUNT(VAR119,3) AND VAR48 AND VAR52 AND OPEN>MA120 AND C<MA30 AND CROSS(C,MA60) AND VAR31<17 AND VAR34<1.7 AND COUNT(VAR40>5.4,4)=0;
VAR194:=VAR191 OR VAR192 OR VAR193;{ WWW.ZHIBIAO123.CN}
VAR195:=VAR115 AND BARSLASTCOUNT(VAR43<10)>=14 AND BARSLASTCOUNT(VAR72)>=3 AND C>VAR87 AND COUNT(BARSLASTCOUNT(MIN(C,O)>VAR41 AND MAX(C,O)<VAR42)>=18,7);
VAR196:=VAR18 AND VAR179 AND REF(COUNT(VAR36<1,4)>=3 AND VAR78<4.1,1) AND BARSLASTCOUNT(VAR47 AND VAR50)>=7 AND BARSLASTCOUNT(MAX(C,O)<VAR29)>=7 AND VAR53>=21 AND VAR54>=7 AND BARSLASTCOUNT(MIN(C,O)>VAR41 AND MAX(C,O)<VAR42)>=7 AND VAR64<7 AND MA120>VAR42;
CS3:=VAR184 OR VAR187 OR VAR190 OR VAR194 OR VAR195 OR VAR196;{ WWW.ZHIBIAO123.CN}
{—————————————————————————————————————};
VAR197:=VAR20 AND VAR18=0 AND REF(一字停,1) AND REF(VAR10,2) AND C<LC AND MA30>MA120 AND MA120>MA60 AND VAR64<4 AND VAR36>4 AND VAR36<5.7 AND VAR44>20 AND VAR31<10 AND ((VAR34<2 AND VAR63<1) OR (VAR32>VAR33*2.7 AND VAR34<4));
VAR198:=VAR20 AND REF(一字停,1) AND REF(VAR10,2) AND VAR48 AND VAR36>3 AND VAR36<6.4 AND ((VAR54>=7 AND VAR53>=7 AND OPEN<VAR41 AND C>VAR41) OR (VAR53>=1 AND C>LC AND VAR31<4 AND VAR34>5));
VAR199:=VAR18 AND REF(一字停,1) AND REF(VAR10,2) AND VAR48 AND VAR36<12 AND VAR109 AND BARSLASTCOUNT(VAR72 AND VAR73)>=7;
VAR200:=VAR20 AND REF(一字停,1) AND REF(VAR36>0 AND VAR36<0.5,2) AND REF(VAR36<0.9,3) AND VAR31<10 AND VAR53>=7 AND VAR44>20 AND VAR44<30 AND VAR34>4.5 AND VAR33>1.18;
VAR201:=VAR20 AND REF(一字停,1) AND REF(VAR36<0.64 AND VAR36>0.1 AND VAR37>6,2) AND VAR48 AND VAR49 AND OPEN<MA40 AND C>MA40 AND OPEN>MA60*1.03;
VAR202:=VAR20 AND REF(一字停,1) AND REF(VAR36>1.5 AND VAR36<3,2) AND VAR48 AND VAR49 AND VAR32>VAR33 AND VAR34>2.1 AND VAR34<4.7 AND OPEN<VAR41 AND C>VAR41 AND VAR54>=1;
VAR203:=VAR20 AND REF(一字停,1) AND VAR48 AND VAR49 AND OPEN<MIN(MIN(MA120,MA60),MIN(VAR41,MA40)) AND C>MAX(MAX(MA120,MA60),MAX(VAR41,MA40)) AND VAR41>MA120 AND VAR64>0 AND VAR34<2;
VAR204:=VAR20 AND REF(一字停,1) AND REF(VAR36>1.5 AND VAR36<3.2,2) AND MA30>MA120 AND MA120>MA60 AND VAR54=0 AND VAR53>=5 AND VAR34>1 AND VAR34<1.2 AND ((VAR36<7 AND VAR44>30 AND VAR44<40 AND VAR35<20) OR (VAR36>10 AND OPEN<VAR41 AND C>VAR29));
VAR205:=VAR20 AND REF(一字停,1) AND REF(C<OPEN AND VAR36>3.4 AND MA20>VAR30,2) AND VAR32>VAR33 AND VAR65 AND VAR53>=5 AND VAR36>4.2 AND VAR36<7 AND VAR44>28 AND VAR44<37 AND VAR43>14 AND VAR43<30 AND VAR31<7 AND VAR34<2.5 AND VAR64<-11 AND VAR64>-21.72 AND VAR66=0;
VAR206:=VAR9 AND VAR36<3.7 AND VAR36*2.1>REF(VAR36,1) AND VAR37<1.3 AND BARSLASTCOUNT(VAR75)>=4 AND REF(VAR20 AND CROSS(C*1.005,VAR41),1) AND REF(VAR205,2);
VAR207:=VAR20 AND REF(一字停,1) AND REF(MA20>VAR28 AND (VAR36>4 OR VAR36<1),2) AND VAR65 AND VAR53>=7 AND VAR53<10 AND VAR36>4.5 AND VAR36<7.4 AND VAR44>25 AND VAR44<41 AND VAR43>18 AND VAR43<27 AND VAR31<7.2 AND VAR34<1.7 AND VAR64<-14 AND VAR64>-24;
VAR208:=VAR20 AND REF(VAR36<0.14,1) AND REF(MA20>VAR28 AND VAR36>0 AND VAR36<1,2) AND VAR36>3 AND VAR36<7 AND VAR34>1.4 AND VAR34<2 AND VAR48 AND COUNT(VAR52,4) AND VAR32>VAR33 AND C<VAR41;
VAR209:=VAR206 OR VAR207 OR VAR208;{ WWW.ZHIBIAO123.CN}
VAR210:=VAR20 AND REF(一字停,1) AND VAR49 AND VAR53>=1 AND VAR54>=3 AND VAR64>40 AND VAR64<47 AND VAR36>10 AND VAR43>45;
VAR211:=VAR197 OR VAR198 OR VAR199 OR VAR200 OR VAR201 OR VAR202 OR VAR203 OR VAR204 OR VAR209 OR VAR210;
{—————————————————————————————————————};
VAR212:=((REF(C<VAR41,1) AND OPEN>VAR41) OR (OPEN<VAR41 AND OPEN*1.027<VAR41 AND C>VAR41)) AND COUNT(VAR57,10)>=1 AND VAR44<24 AND VAR36<9 AND VAR66=0 AND REF(VAR66,1)=0 AND REF(VAR36>4.7 AND OPEN>C,1)=0 AND CROSS(C,MA5) AND C>MA5*1.01;
VAR213:=VAR18 AND VAR20=0 AND VAR37<2.1 AND ((VAR47 AND VAR28>VAR42) OR (MA120=VAR28 AND VAR28<VAR42 AND VAR33<1)) AND COUNT(VAR66,7)>=1 AND LLV(L,4)=LLV(L,72) AND VAR33*3<VAR32 AND VAR212;
{—————————————————————————————————————};
黄龙帝国副:VAR131 OR CS1 OR CS2 OR CS3 OR VAR211 OR VAR213;{ WWW.ZHIBIAO123.CN}

资源下载
下载价格VIP专享
仅限VIP下载升级VIP
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/3844.html,转载请注明出处。
通达信《龙头股道》全套37个无加密无未来函数指标公式源码
通达信《龙头股道》全套37个无加密无未来函数指标公式源码
刚刚 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录