通达信《沧海掘金》主图+副图+选股预警指标公式源码

通达信沧海掘金主图指标公式源码:

{ WWW.ZHIBIAO123.CN};指标123网:1 NODRAW;
X_1:=EMA(CLOSE,34);
X_2:=EMA(X_1,13);
X_3:=MACD.DIF#MONTH;
X_4:=MACD.DEA#MONTH;
X_5:=CROSS(X_3,X_4) OR X_3>X_4;
X_6:=CCI#MONTH;
X_7:=CROSS(X_6,100) OR X_6>100;
X_8:=MIKE.STOR#MONTH;
X_9:=CROSS(CLOSE,X_8) OR X_8>0;
X_10:=X_5 AND X_7 AND X_9;
X_11:=MACD.DIF#WEEK;
X_12:=MACD.DEA#WEEK;
X_13:=CROSS(X_11,X_12) OR X_11>X_12;
X_14:=CCI#WEEK;{ WWW.ZHIBIAO123.CN}
X_15:=CROSS(X_14,100) OR X_14>100;
X_16:=MIKE.STOR#WEEK;
X_17:=CROSS(CLOSE,X_16) OR X_16>0;
X_18:=X_13 AND X_15 AND X_17;
X_19:=CLOSE/REF(CLOSE,1)>1.035 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_20:=FILTER(X_19,28)*100 AND LOW>REF(CLOSE,1)*0.93 AND VOL>REF(VOL,1)*0.93;
X_21:=SUMBARS(VOL,CAPITAL);
X_22:=IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,X_21)*33/10);
X_23:=COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
X_24:=DYNAINFO(8)>0;
X_25:=VOL=LLV(VOL,100) AND X_24;
X_26:=VOL=HHV(VOL,100) AND X_24;
X_27:=X_24 AND X_25;
X_28:=VOL>REF(VOL,1)*1.9;
X_29:=VOL<REF(LLV(VOL,13),1);
X_30:=VOL<REF(LLV(VOL,55),1);
X_31:=X_28;{ WWW.ZHIBIAO123.CN}
X_32:=X_24 AND X_26;
X_33:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_34:=(8*X_33+7*REF(X_33,1)+6*REF(X_33,2)+5*REF(X_33,3)+4*REF(X_33,4)+3*REF(X_33,5)+2*REF(X_33,6)+REF(X_33,8))/36;
X_35:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>X_34 AND CLOSE>OPEN;
X_36:=FILTER(X_35,5);
X_37:=IF(VOL>REF(VOL,1) AND (REF(VOL,1)>REF(VOL,2) OR REF(X_27,1)),11,10);
X_38:=X_23;
X_39:=VOL>REF(VOL,1)*0.98 AND VOL<REF(VOL,1)*1.02;
X_40:=X_39;
X_41:=CLOSE/REF(CLOSE,1)<=0.96 AND VOL<HHV(VOL,30)/1.9;
DRAWTEXT(X_41,HIGH*1.04,8),COLORYELLOW;
X_42:=CLOSE=HHV(CLOSE,13);
X_43:=BARSLAST(FILTER(CROSS(0.8,X_42),2))+1;
X_44:=REF(CLOSE,X_43);
X_45:=CROSS(CLOSE,REF(X_44,1));
STICKLINE(X_43<=6,X_44,X_44,3,0),COLORMAGENTA;
DRAWTEXT(X_45,LOW*0.98,9),COLORYELLOW;
MA3:MA(CLOSE,3),COLORWHITE;
X_46:=MA(CLOSE,10);{ WWW.ZHIBIAO123.CN}
MA20:MA(CLOSE,20),COLORGRAY,LINETHICK2;
MA60:MA(CLOSE,60),COLORGREEN;
X_47:=CLOSE/REF(CLOSE,1)>1.045 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1);
X_48:=WINNER(CLOSE)*100>=90;
X_49:=EMA(EMA(CLOSE,X_48),80);
X_50:=EMA(EMA(CLOSE,X_48),55);
IF(X_50<X_49 AND X_49>=REF(X_49,1),X_49,DRAWNULL),COLORWHITE,LINETHICK3;
STICKLINE(CLOSE/REF(CLOSE,1)>1.05,CLOSE,OPEN,1.5,0),COLORLIRED;
STICKLINE(CLOSE/REF(CLOSE,1)>1.095,CLOSE,OPEN,1,0),COLORYELLOW;
X_51:=X_50<X_49 AND X_49>=REF(X_49,1);
IF(X_51 AND X_49,X_49,DRAWNULL),COLORWHITE,LINETHICK3;
X_52:=MA(CLOSE,20);
X_53:=MA(CLOSE,5);
X_54:=MA(CLOSE,20);
X_55:=IF(X_53>X_54,X_54,X_53);
X_56:=X_54!=X_55;


X_60:=X_59;
X_61:=IF(CLOSE<REF(OPEN,2) AND X_58<0,1,0);
X_62:=X_61;
X_63:=CLOSE-EMA(CLOSE,13);
X_64:=EMA(X_63,13);
X_65:=(X_63-X_64)*2;
X_66:=X_60=0 AND REF(X_60,1)=1 AND X_62=0 AND REF(X_62,1)=1 AND (X_65<0 OR (REF(X_65<=0,1) AND X_65>0));
STICKLINE(X_66,OPEN,(CLOSE+OPEN)/2,4,0),COLORLIRED;
X_67:=OPEN*1.008>BBI AND HIGH*1.008>MA(CLOSE,10) AND (CLOSE<REF(CLOSE,1)*0.98 OR CLOSE<REF(CLOSE,1)*0.97 OR CLOSE<REF(OPEN,1)*0.98 OR CLOSE<REF(OPEN,1)*0.97);
X_68:=CLOSE/REF(CLOSE,1)<1-5/100 AND CLOSE/REF(HIGH,1)>0.98;
X_69:=CLOSE<REF(CLOSE,1)*0.97 OR CLOSE/REF(CLOSE,1)<1-5/100 AND REF(CLOSE>BBI,1) AND (OPEN<BBI OR CLOSE<BBI);
X_70:=CLOSE/REF(CLOSE,1)>1.025 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1);
X_71:=EMA(CLOSE,30)-EMA(CLOSE,17);
X_72:=EMA(X_71,13);{ WWW.ZHIBIAO123.CN}
X_73:=X_71<X_72;
X_74:=REF(X_67 OR X_68 OR X_69 AND (BARSLAST(KDJ.J>60)<20 OR BARSLAST(KDJ.J<0)<20),1) AND X_73 AND X_70;
X_75:=REF(BARSLAST(KDJ.J<0)<20,1) AND REF(CLOSE,1)<REF(CLOSE,2)*0.97 AND CLOSE/OPEN>1.03 AND X_20;
STICKLINE(X_74 OR X_75,OPEN+0.382*(CLOSE-OPEN),OPEN+0.01*(CLOSE-OPEN),0.1,0),COLORRED;
X_76:=COUNT(CLOSE/REF(CLOSE,1)>=1.097,12)>=1 AND REF(X_67 OR X_68 OR X_69,1) AND X_70;
DRAWICON(X_76,REF(LOW*0.96,1),11);
上轨:MA(REF(HHV((CLOSE+LOW+OPEN+HIGH)/4,30),1),3),COLORMAGENTA;
X_77:=(HIGH+LOW)/2;
X_78:=SMA(X_77,8,1);
X_79:=REF(X_78,5);
X_80:=IF(LOW=LLV(LOW,3),1,0);
X_81:=IF(REF(X_80,2)=1 AND REF(X_80,1)=0 AND X_80=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(X_80,2)=1 AND REF(X_80,1)=0 AND X_80=0)));{ WWW.ZHIBIAO123.CN}
X_82:=IF(LOW<=X_79,X_81,REF(X_81,BARSLAST(LOW<=X_79)));{ WWW.ZHIBIAO123.CN}
X_83:=CLOSE/REF(CLOSE,3)>=1.1;
X_84:=FILTER(X_83,3);
X_85:=EVERY(CLOSE>OPEN,3);
X_86:=BARSLAST(CROSS(X_83,1.1));
X_87:=BARSLAST(CROSS(1.1,X_83));
X_88:=IF(X_86<X_87,X_86+1,0);
X_89:=X_85=1 AND X_88=1 AND CLOSE/OPEN>1.05;
X_90:=X_84 OR X_89 AND NOT(REF(CLOSE/REF(CLOSE,1)>=1.095,1));
X_91:=OPEN/REF(CLOSE,3)>=1.1;
X_92:=FILTER(X_91,3);
X_93:=EVERY(CLOSE>OPEN,3);
X_94:=BARSLAST(CROSS(X_91,1.1));
X_95:=BARSLAST(CROSS(1.1,X_91));
X_96:=IF(X_94<X_95,X_94+1,0);
X_97:=X_93=1 AND X_96=1 AND CLOSE/OPEN>1.05;
X_98:=X_92 OR X_97 AND NOT(REF(CLOSE/REF(CLOSE,1)>=1.095,1));
X_99:=X_98 OR REF(X_90,1);
DRAWICON(X_99>0,LOW*0.99,2);
X_100:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
X_101:=DMA((2*CLOSE+LOW+HIGH)/4,X_100);
X_102:=CLOSE/X_101;
X_103:=MA(X_102*(2*CLOSE+HIGH+LOW)/4,3);
X_104:=(X_103-X_101)/X_101/3;
X_105:=X_103-X_104*X_103;{ WWW.ZHIBIAO123.CN}
FJ:IF(X_105>=X_101 AND MA20>MA60,MA20,DRAWNULL),COLOR670FF0,LINETHICK3;
DRAWTEXT(X_45,LOW*0.98,9),COLORYELLOW;

通达信沧海掘金副图指标公式源码:

{ WWW.ZHIBIAO123.CN};指标123网:1 NODRAW;
X_1:=1211230;
X_2:=DATETODAY(DATE);
X_3:=DATETODAY(X_1);
X_4:=X_3-X_2;
DRAWTEXT(1>X_4,HIGH,1),COLORRED;
X_5:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
X_6:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_7:=EMA(X_6,9);
X_8:=(X_6-X_7)*2;
X_9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_10:=SMA(X_9,3,1);
X_11:=SMA(X_10,3,1);
X_12:=3*X_10-2*X_11;
X_13:=MACD.MACD#WEEK;
周J:KDJ.J#WEEK,COLORFF0099,LINETHICK2;
周D:KDJ.D#WEEK,COLOR3388AA,LINETHICK2;
X_14:=X_13-REF(X_13,5)>0.05;
X_15:=X_13-REF(X_13,5)>0.12;
X_16:=X_15 AND (X_14 AND X_13>0);


X_20:=X_5>=OPEN AND X_5<CLOSE OR (OPEN>=X_5 AND OPEN>REF(CLOSE,1) AND REF(LOW<X_5,1)) AND CLOSE>OPEN;{ WWW.ZHIBIAO123.CN}
X_21:=FILTER(X_19 OR X_20 AND CLOSE>MA(CLOSE,5) AND (X_18 OR X_6>REF(X_6,1)) AND (VOL>REF(VOL,1) AND VOL>REF(VOL,2) AND CLOSE/REF(CLOSE,1)>=1.055 OR (VOL>REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND CLOSE/REF(CLOSE,1)>=1.055) OR (REF(VOL,1)>REF(VOL,2) AND CLOSE/REF(CLOSE,1)>=1.055)),3);
X_22:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
X_23:=CROSS(CLOSE,X_22) AND X_22>REF(X_22,1);
X_24:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
X_25:=CROSS(CLOSE,X_24) AND X_24>REF(X_24,1);
X_26:=EMA(LOW,9);
X_27:=EMA(EMA(HIGH,X_13),9);
X_28:=EMA(EMA(LOW,X_13),9);
X_29:=OPEN>=REF(CLOSE,1) AND REF(CLOSE>OPEN,1) AND OPEN/REF(CLOSE,1)<1.045 OR (REF(CLOSE>OPEN,1) AND OPEN/REF(OPEN,1)>1.001 AND CLOSE>REF(CLOSE,1)) OR (OPEN>REF(OPEN,1) AND REF(CLOSE<OPEN,1) AND OPEN/REF(OPEN,1)<1.03);
X_30:=CLOSE=HHV(CLOSE,13);
X_31:=BARSLAST(FILTER(CROSS(0.8,X_30),2))+1;
X_32:=REF(CLOSE,X_31);
X_33:=CROSS(CLOSE,REF(X_32,1));
X_34:=(CLOSE*3+HIGH+LOW+OPEN)/6;
X_35:=(EMA(CR,3)+EMA(X_34,6)+EMA(X_34,12)*3+EMA(X_34,24))/6;
X_36:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
X_37:=IF(BARSCOUNT(CLOSE)<24,X_35,X_36);
X_38:=MA(REF(HHV((CLOSE+LOW+OPEN+HIGH)/4,30),1),3);
X_39:=CLOSE/REF(CLOSE,1)>1.033 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1);
X_40:=CLOSE>MA(CLOSE,10) AND REF(CLOSE,1)<REF(CLOSE,2)*0.97 AND CLOSE/OPEN>1.03 AND VOL/CAPITAL>0.03 AND CLOSE/REF(CLOSE,1)>1.035 AND HIGH/CLOSE<1.01;
X_41:=CLOSE/REF(CLOSE,1)>1.038 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_42:=FILTER(X_41,28)*100 AND LOW>REF(CLOSE,1)*0.93;
X_43:=CROSS(0.9,1/VOL*1000>0 AND KDJ.J<0) OR CROSS(0.9,1/VOL*1000>0.01 AND KDJ.J<0);
X_44:=OPEN=HIGH AND CLOSE=HIGH AND CLOSE>REF(CLOSE,1) AND LOW>REF(CLOSE,1);
X_45:=OPEN=HIGH AND CLOSE=HIGH AND LOW=HIGH AND CLOSE>REF(CLOSE,1) AND LOW>REF(CLOSE,1);
X_46:=SUMBARS(VOL,CAPITAL);
X_47:=IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,X_46)*33/10);
X_48:=COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
X_49:=DYNAINFO(8)>0;
X_50:=VOL=LLV(VOL,100) AND X_49;
X_51:=VOL=HHV(VOL,100) AND X_49;
X_52:=X_49 AND X_50;
X_53:=VOL>REF(VOL,1)*1.9;
X_54:=VOL<REF(LLV(VOL,13),1);
X_55:=VOL<REF(LLV(VOL,55),1);
X_56:=X_53;
X_57:=X_49 AND X_51;
X_58:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_59:=(8*X_58+7*REF(X_58,1)+6*REF(X_58,2)+5*REF(X_58,3)+4*REF(X_58,4)+3*REF(X_58,5)+2*REF(X_58,6)+REF(X_58,8))/36;
X_60:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>X_59 AND CLOSE>OPEN;
X_61:=FILTER(X_60,5);
X_62:=IF(VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND (REF(VOL,2)>REF(VOL,3) OR REF(X_52,1)) AND NDAY(CLOSE,OPEN,3) AND NDAY(VOL,REF(VOL,1),3),11,10);
X_63:=IF(NDAY(LOW,REF(LOW,1),3) AND NDAY(CLOSE,OPEN,3) AND NDAY(VOL,REF(VOL,1),2),11,10);
X_64:=IF(NDAY(LOW,REF(LOW,1),3) AND NDAY(CLOSE,OPEN,3) AND NDAY(REF(VOL,1),VOL,2),11,10);
X_65:=X_48;
X_66:=VOL>REF(VOL,1)*0.98 AND VOL<REF(VOL,1)*1.02;
X_67:=X_66;
X_68:=VOL/CAPITAL*100;
X_69:=X_68>=25;
X_70:=CLOSE/REF(CLOSE,1)<=0.96 AND VOL<HHV(VOL,30)/1.9;
X_71:=VOL=LLV(VOL,100) AND VOL>0;
X_72:=VOL>=REF(VOL,1)*1.9 AND CLOSE>REF(CLOSE,1);
X_73:=COUNT(X_71,5)>=1 AND COUNT(X_72,1)>=1;
X_74:=20;
X_75:=REF(HHV(CLOSE,X_74),1);
X_76:=REF(COUNT(CLOSE<X_75,2)=2,1) AND CLOSE>X_75 AND CLOSE>OPEN AND VOL/REF(VOL,1)>=1.9;
X_77:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_78:=DMA(X_77,0.2);
X_79:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>X_78 AND CLOSE>REF(CLOSE,1);
X_80:=FILTER(X_79,3);
X_81:=REF(LOW,BARSLAST(X_80));
X_82:=FILTER(X_79,3);
X_83:=REF(VOL,6)/REF(VOL,7)>=2;
X_84:=REF(VOL,5)/REF(VOL,6)>=2;
X_85:=REF(VOL,5)/REF(VOL,4)>=1.5;
X_86:=REF(VOL,4)/REF(VOL,3)>=1.5;
X_87:=REF(VOL,2)/REF(VOL,3)>=1.5;
X_88:=VOL/REF(VOL,1)>2;
X_89:=CLOSE>OPEN AND CLOSE>REF(CLOSE,1);
X_90:=X_83 AND X_88 AND X_89 OR X_84 AND X_88 AND X_89 OR X_85 AND X_88 AND X_89 OR X_86 AND X_88 AND X_89 OR X_87 AND X_88 AND X_89;
X_91:=X_82 AND X_90;
X_92:=3;
X_93:=0;
X_94:=X_93/100;
X_95:=ABS(LOW-REF(LOW,1))<=X_94;
X_96:=ABS(LOW-REF(LOW,2))<=X_94;
X_97:=ABS(LOW-REF(LOW,3))<=X_94;
X_98:=ABS(LOW-REF(LOW,4))<=X_94;
X_99:=ABS(LOW-REF(LOW,5))<=X_94;
X_100:=X_95 OR X_96 OR X_97 OR X_98 OR X_99;
X_101:=FILTER(X_100,X_92);{ WWW.ZHIBIAO123.CN}
X_102:=X_70 OR X_76 OR X_101 OR X_91 OR X_73;
X_103:=CLOSE/REF(CLOSE,1)>=1.095;
X_104:=COUNT(REF(X_103 AND REF(X_103,1) AND REF(X_103,2),1),20)<1 AND REF(LOW*0.98<X_5,2) AND CLOSE>X_5 AND COUNT(X_102 AND VOL>REF(VOL,1),15)>=1 AND CLOSE>OPEN AND X_15;
X_105:=LOW>REF(LOW,1) AND REF(LOW,1)>=REF(LOW,2) OR (LOW>REF(LOW,1) AND REF(LOW,1)<REF(LOW,2)) OR (LOW<REF(LOW,1) AND REF(LOW,1)<REF(LOW,2)) OR (LOW<REF(LOW,1) AND REF(LOW,1)>REF(LOW,2));
X_106:=COUNT(FILTER(COUNT(X_43>0,22)>=1 AND X_14>0 AND X_15 AND 周J>0 AND X_17 AND COUNT(周J>REF(周J,1),5)>=1,20),5)>=1;
X_107:=X_104 OR X_16 AND (REF(LOW*0.99<X_28 OR (LOW*0.99<X_5 AND REF(LOW>X_28,1)),1) OR (REF(LOW*0.99<X_5 AND LOW>=X_28,1) AND LOW*0.99<X_28));
X_108:=X_104 OR X_16 AND (REF(LOW<X_5 AND (LOW>=X_28 OR (LOW<X_28 AND CLOSE>OPEN)),1) AND LOW<X_5) OR (X_16 AND COUNT(X_106,6)>=1 AND X_19 AND X_42);
X_109:=X_106 AND (X_42 OR X_21) AND OPEN/REF(CLOSE,1)<=1.04 AND (X_23 OR REF(X_23,1)) AND COUNT(REF(周J<周D,1),14)>=1 AND 周J>周D AND CLOSE/REF(CLOSE,1)>=1.033 AND X_68>1 AND 1<X_4 AND NOT(X_44 OR X_45);
精简底追:30*FILTER(X_23 OR (REF(X_23,1) AND X_42) AND LOW*0.99<X_37 AND X_68>1 AND NOT(X_44 OR X_45) AND CLOSE/REF(CLOSE,1)>=1.033 AND COUNT(REF(CLOSE/REF(CLOSE,1)>=1.095,1),6)<1 AND (X_29 OR (REF(X_56>0,2) AND 1<X_4 AND REF(VOL*1.5<REF(VOL,1),1) AND VOL>REF(VOL,1))) AND X_107 OR (X_19 AND X_42 AND COUNT(REF(CLOSE/REF(CLOSE,1)>=1.095,1),6)<1 AND X_108 OR (X_16 AND COUNT(X_106,6)>=1 AND CLOSE/REF(CLOSE,1)>=1.033 AND NOT(X_44 OR X_45) AND (X_23 OR X_25 OR REF(X_23,1) AND X_25 OR X_42))) AND COUNT(REF(VOL<MA(VOL,60),1),4)>=3 AND OPEN/REF(CLOSE,1)<=1.033 AND X_105 AND X_68>1 AND X_16 AND X_17 AND 周J>周D AND 1<X_4 OR (X_109 AND 1<X_4),2),COLORWHITE,LINETHICK2;{ WWW.ZHIBIAO123.CN};

通达信沧海掘金选股预警公式源码:

X_1:=1211230;
X_2:=DATETODAY(DATE);
X_3:=DATETODAY(X_1);
X_4:=X_3-X_2;
X_5:=CAPITAL>=2000 AND CAPITAL<=49999998976 AND CLOSE<50;
X_6:=IF(CODELIKE(2),0,1);
X_7:=IF(NAMELIKE(3),0,1);
X_8:=IF(NAMELIKE(4),0,1);
X_9:=DYNAINFO(17)>=0;
X_10:=NOT(NAMELIKE(5) OR INBLOCK(6));
X_11:=IF(CODELIKE(7),0,1);
X_12:=X_7 AND X_8 AND X_9 AND X_5 AND X_10 AND X_11;
X_13:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
X_14:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_15:=EMA(X_14,9);
X_16:=(X_14-X_15)*2;
X_17:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_18:=SMA(X_17,3,1);
X_19:=SMA(X_18,3,1);
X_20:=3*X_18-2*X_19;
X_21:=MACD.MACD#WEEK;
X_22:=KDJ.J#WEEK;
X_23:=KDJ.D#WEEK;
X_24:=X_21-REF(X_21,5)>0.05;
X_25:=X_21-REF(X_21,5)>0.12;
X_26:=X_25 AND (X_24 AND X_21>0);
X_27:=X_22>0 AND X_22-REF(X_22,5)>8;
X_28:=X_15<0 AND X_15>REF(X_15,1) AND (X_16>0 OR X_16>REF(X_16,1));
X_29:=REF(X_13,1)>=OPEN AND REF(X_13,1)<CLOSE OR (OPEN>=REF(X_13,1) AND OPEN>REF(CLOSE,1) AND REF(LOW<REF(X_13,1),1)) AND CLOSE>OPEN;
X_30:=X_13>=OPEN AND X_13<CLOSE OR (OPEN>=X_13 AND OPEN>REF(CLOSE,1) AND REF(LOW<X_13,1)) AND CLOSE>OPEN;


X_33:=CROSS(CLOSE,X_32) AND X_32>REF(X_32,1);
X_34:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
X_35:=CROSS(CLOSE,X_34) AND X_34>REF(X_34,1);
X_36:=EMA(LOW,9);
X_37:=EMA(EMA(HIGH,X_21),9);
X_38:=EMA(EMA(LOW,X_21),9);
X_39:=CLOSE=HHV(CLOSE,13);
X_40:=BARSLAST(FILTER(CROSS(0.8,X_39),2))+1;
X_41:=REF(CLOSE,X_40);
X_42:=CROSS(CLOSE,REF(X_41,1));
X_43:=OPEN>=REF(CLOSE,1) AND REF(CLOSE>OPEN,1) AND OPEN/REF(CLOSE,1)<1.045 OR (REF(CLOSE>OPEN,1) AND OPEN/REF(OPEN,1)>1.001 AND CLOSE>REF(CLOSE,1)) OR (OPEN>REF(OPEN,1) AND REF(CLOSE<OPEN,1) AND OPEN/REF(OPEN,1)<1.03);
X_44:=(CLOSE*3+HIGH+LOW+OPEN)/6;
X_45:=(EMA(CR,3)+EMA(X_44,6)+EMA(X_44,12)*3+EMA(X_44,24))/6;
X_46:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
X_47:=IF(BARSCOUNT(CLOSE)<24,X_45,X_46);
X_48:=MA(REF(HHV((CLOSE+LOW+OPEN+HIGH)/4,30),1),3);
X_49:=CLOSE/REF(CLOSE,1)>1.033 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1);
X_50:=CLOSE>MA(CLOSE,10) AND REF(CLOSE,1)<REF(CLOSE,2)*0.97 AND CLOSE/OPEN>1.03 AND VOL/CAPITAL>0.03 AND CLOSE/REF(CLOSE,1)>1.035 AND HIGH/CLOSE<1.01;
X_51:=CLOSE/REF(CLOSE,1)>1.038 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
X_52:=FILTER(X_51,28)*100 AND LOW>REF(CLOSE,1)*0.93;
X_53:=CROSS(0.9,1/VOL*1000>0 AND KDJ.J<0) OR CROSS(0.9,1/VOL*1000>0.01 AND KDJ.J<0);
X_54:=CLOSE/REF(CLOSE,1)>1.038 AND HIGH/CLOSE<1.01 AND CLOSE>REF(CLOSE,1);
X_55:=OPEN=HIGH AND CLOSE=HIGH AND CLOSE>REF(CLOSE,1) AND LOW>REF(CLOSE,1);
X_56:=OPEN=HIGH AND CLOSE=HIGH AND LOW=HIGH AND CLOSE>REF(CLOSE,1) AND LOW>REF(CLOSE,1);
X_57:=SUMBARS(VOL,CAPITAL);
X_58:=IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,X_57)*33/10);
X_59:=COUNT(CLOSE>REF(CLOSE,1),2)=2 AND COUNT(VOL<REF(VOL,1),2)=2;
X_60:=DYNAINFO(8)>0;
X_61:=VOL=LLV(VOL,100) AND X_60;
X_62:=VOL=HHV(VOL,100) AND X_60;
X_63:=X_60 AND X_61;
X_64:=VOL>REF(VOL,1)*1.9;
X_65:=VOL<REF(LLV(VOL,13),1);
X_66:=VOL<REF(LLV(VOL,55),1);
X_67:=X_64;
X_68:=X_60 AND X_62;
X_69:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_70:=(8*X_69+7*REF(X_69,1)+6*REF(X_69,2)+5*REF(X_69,3)+4*REF(X_69,4)+3*REF(X_69,5)+2*REF(X_69,6)+REF(X_69,8))/36;
X_71:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>X_70 AND CLOSE>OPEN;
X_72:=FILTER(X_71,5);
X_73:=IF(VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND (REF(VOL,2)>REF(VOL,3) OR REF(X_63,1)) AND NDAY(CLOSE,OPEN,3) AND NDAY(VOL,REF(VOL,1),3),11,10);
X_74:=IF(NDAY(LOW,REF(LOW,1),3) AND NDAY(CLOSE,OPEN,3) AND NDAY(VOL,REF(VOL,1),2),11,10);
X_75:=IF(NDAY(LOW,REF(LOW,1),3) AND NDAY(CLOSE,OPEN,3) AND NDAY(REF(VOL,1),VOL,2),11,10);
X_76:=X_59;
X_77:=VOL>REF(VOL,1)*0.98 AND VOL<REF(VOL,1)*1.02;
X_78:=X_77;
X_79:=VOL/CAPITAL*100;
X_80:=X_79>=25;
X_81:=CLOSE/REF(CLOSE,1)<=0.96 AND VOL<HHV(VOL,30)/1.9;
X_82:=VOL=LLV(VOL,100) AND VOL>0;
X_83:=VOL>=REF(VOL,1)*1.9 AND CLOSE>REF(CLOSE,1);
X_84:=COUNT(X_82,5)>=1 AND COUNT(X_83,1)>=1;
X_85:=20;
X_86:=REF(HHV(CLOSE,X_85),1);
X_87:=REF(COUNT(CLOSE<X_86,2)=2,1) AND CLOSE>X_86 AND CLOSE>OPEN AND VOL/REF(VOL,1)>=1.9;
X_88:=(3*CLOSE+HIGH+LOW+OPEN)/6;
X_89:=DMA(X_88,0.2);
X_90:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>X_89 AND CLOSE>REF(CLOSE,1);
X_91:=FILTER(X_90,3);
X_92:=REF(LOW,BARSLAST(X_91));
X_93:=FILTER(X_90,3);
X_94:=REF(VOL,6)/REF(VOL,7)>=2;
X_95:=REF(VOL,5)/REF(VOL,6)>=2;
X_96:=REF(VOL,5)/REF(VOL,4)>=1.5;
X_97:=REF(VOL,4)/REF(VOL,3)>=1.5;
X_98:=REF(VOL,2)/REF(VOL,3)>=1.5;
X_99:=VOL/REF(VOL,1)>2;
X_100:=CLOSE>OPEN AND CLOSE>REF(CLOSE,1);
X_101:=X_94 AND X_99 AND X_100 OR X_95 AND X_99 AND X_100 OR X_96 AND X_99 AND X_100 OR X_97 AND X_99 AND X_100 OR X_98 AND X_99 AND X_100;
X_102:=X_93 AND X_101;
X_103:=3;
X_104:=0;
X_105:=X_104/100;
X_106:=ABS(LOW-REF(LOW,1))<=X_105;
X_107:=ABS(LOW-REF(LOW,2))<=X_105;
X_108:=ABS(LOW-REF(LOW,3))<=X_105;
X_109:=ABS(LOW-REF(LOW,4))<=X_105;
X_110:=ABS(LOW-REF(LOW,5))<=X_105;
X_111:=X_106 OR X_107 OR X_108 OR X_109 OR X_110;
X_112:=FILTER(X_111,X_103);
X_113:=X_81 OR X_87 OR X_112 OR X_102 OR X_84;
X_114:=CLOSE/REF(CLOSE,1)>=1.095;
X_115:=COUNT(REF(X_114 AND REF(X_114,1) AND REF(X_114,2),1),20)<1 AND REF(LOW*0.98<X_13,2) AND CLOSE>X_13 AND COUNT(X_113 AND VOL>REF(VOL,1),15)>=1 AND CLOSE>OPEN AND X_25;
X_116:=LOW>REF(LOW,1) AND REF(LOW,1)>=REF(LOW,2) OR (LOW>REF(LOW,1) AND REF(LOW,1)<REF(LOW,2)) OR (LOW<REF(LOW,1) AND REF(LOW,1)<REF(LOW,2)) OR (LOW<REF(LOW,1) AND REF(LOW,1)>REF(LOW,2));
X_117:=COUNT(FILTER(COUNT(X_53>0,22)>=1 AND X_24>0 AND X_25 AND X_22>0 AND X_27 AND COUNT(X_22>REF(X_22,1),5)>=1,20),5)>=1;
X_118:=X_115 OR X_26 AND (REF(LOW*0.99<X_38 OR (LOW*0.99<X_13 AND REF(LOW>X_38,1)),1) OR (REF(LOW*0.99<X_13 AND LOW>=X_38,1) AND LOW*0.99<X_38));
X_119:=X_115 OR X_26 AND (REF(LOW<X_13 AND (LOW>=X_38 OR (LOW<X_38 AND CLOSE>OPEN)),1) AND LOW<X_13) OR (X_26 AND COUNT(X_117,6)>=1 AND X_29 AND X_52);
X_120:=X_117 AND (X_52 OR X_31) AND OPEN/REF(CLOSE,1)<=1.04 AND (X_33 OR REF(X_33,1)) AND COUNT(REF(X_22<X_23,1),14)>=1 AND X_22>X_23 AND X_49 AND X_79>1;
X_121:=X_33 OR (REF(X_33,1) AND X_52) AND X_79>1 AND LOW*0.99<X_47 AND X_49 AND COUNT(REF(CLOSE/REF(CLOSE,1)>=1.095,1),6)<1 AND (X_43 OR (REF(X_67>0,2) AND REF(VOL*1.5<REF(VOL,1),1) AND VOL>REF(VOL,1))) AND X_118 OR (X_29 AND X_52 AND COUNT(REF(CLOSE/REF(CLOSE,1)>=1.095,1),6)<1 AND X_119 OR (X_26 AND COUNT(X_117,6)>=1 AND X_49 AND (X_33 OR X_35 OR REF(X_33,1) AND X_35 OR X_52))) AND COUNT(REF(VOL<MA(VOL,60),1),4)>=3 AND OPEN/REF(CLOSE,1)<=1.033 AND X_116 AND X_79>1 AND X_26 AND X_27 AND X_22>X_23 OR X_120;
FILTER(X_121 AND NOT(X_55 OR X_56) AND 1<X_4 AND X_12,2);

通达信沧海掘金指标公式截图:

通达信沧海掘金指标公式截图1 通达信沧海掘金指标公式截图2

通达信沧海掘金主图指标公式

资源下载
下载价格免费
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/2376.html,转载请注明出处。
通达信博弈资金战法全套主图副图选股指标公式源码
通达信博弈资金战法全套主图副图选股指标公式源码
1分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录