通达信《开天之剑》副图指标公式源码

在风起云涌的股市中,每一个决策都关乎成败。《开天之剑》副图指标,作为通达信软件的得力助手,凭借其独特的技术分析算法,助力投资者精准把握市场脉搏。该指标融合了均线、动量、成交量等多维度数据,通过智能计算,为投资者提供清晰明了的建仓、清仓信号。无需繁琐操作,一眼便可洞悉市场趋势,为股市投资决策提供有力支持。

开天之剑指标源码:

TR1:=EXPMEMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),12);
HD1:=H-REF(H,1); LD1:=REF(L,1)-L;
VAR1:=EXPMEMA(IF(HD1>0&&HD1>LD1,HD1,0),12)*100/TR1;
VAR2:=EXPMEMA(IF(LD1>0&&LD1>HD1,LD1,0),12)*100/TR1;
VAR3:=VAR1>65 AND VAR1>REF(VAR1,1);
VAR4:=LLV(VAR1,0);{WWW.ZHIBIAO123.CN}
VAR5:=BARSLAST(VAR4=VAR1);
VAR6:=(0-REF(VAR2,4))/(VAR4-REF(VAR2,VAR5))>2;
VAR7:=VAR1>REF(VAR1,1);
VAR8:=VOL>2*MA(VOL,30);
VAR9:=EXPMEMA(ABS(VAR2-VAR1)/(VAR2+VAR1)*100,6);
VARA:=EXPMEMA(VAR3,6);
VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
VARE:=0-(EMA(CLOSE,7)-EMA(CLOSE,21));
VARF:=TROUGHBARS(3,15,1)<4;
VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
VAR11:=IF(VARF=1,50,0);
VAR12:=CROSS(VAR2,VAR1) AND CROSS(VARA,VAR9);
VAR13:=CROSS(VAR2,VAR1) AND CROSS(VAR9,VARA);
VAR14:=VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50;
VAR15:=BARSLAST(CROSS(VAR2,VAR1)=1);
VAR16:=BARSLAST(CROSS(VAR1,VAR2)=1);
VAR17:=HHV(VAR1,VAR16);{WWW.ZHIBIAO123.CN}
VAR18:=BARSLAST(VAR1=VAR17);
多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
STICKLINE(0=0,0,0,1500,1),COLORRED;
STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,10,0),COLORF00FF0;
STICKLINE(FILTER(VARF=1,5),50,0,5,0),COLORYELLOW;
VAR19:=VAR3 OR VAR12 OR VAR13*100;
VAR1A:=VAR13*100;{WWW.ZHIBIAO123.CN}
DRAWTEXT(FILTER(VARF=1,3),25,'←开天之剑'),COLORRED;
STICKLINE(多空<-10,0,多空,0.85,0),COLORYELLOW;
STICKLINE(多空>10,0,多空,0.95,0),COLORRED;

开天之剑指标截图:

负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/154994.html,转载请注明出处。
最新通达信波段密码潜伏追涨停版全套金钻指标公式源码
最新通达信波段密码潜伏追涨停版全套金钻指标公式源码
9分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录