通达信《三枪锁喉买入》主图+副图+选股指标公式源码

以下是通达信《三枪锁喉买入》主图+副图+选股指标公式源码截图和用法说明:

通达信三枪锁喉买入全套指标包含一个三枪锁喉买入主图、一个三枪锁喉买入副图和一个选股预警公式,实测全套指标无加密,无未来函数,可永久使用。

指标用法说明:

1.通达信三枪锁喉买入主图指标由红、蓝、黄、绿四种颜色的K线和一条白色的三枪买入线、一条生命线组成;

2.三枪买入指标实战用法:

  • 股价战上生命线同时生命线与三枪锁喉买入线形成金叉为第一买点;
  • 主图出现三枪买入信号与副图形成共振为第二买点;
  • 股价跌跛生命线同时生命线由红转绿为第一卖点;
  • 三枪锁喉买入主图K线出现上绿下蓝的K线为第二卖点;

三枪锁喉买入源码:

B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
三枪买入:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4;
三枪卖出:HHV(MA(B2,1),13),COLORYELLOW;
BG1:=(2*CLOSE+HIGH+LOW)/4;
BG2:=MA(BG1,7);
BG3:=BG2-MA(BG1,7/2)<0;
BG4:=BG2-MA(BG1,7/2)>0;
BG5:=BARSLAST(BG3);
BG6:=0-BARSLAST(BG4);
BG7:=IF(BG3<=0,BG5,BG6);
STICKLINE(三枪卖出>B2 AND B2>SMA2,三枪卖出,B2,0,1),COLORLIBLUE;
STICKLINE(三枪卖出>SMA2 AND B2<SMA2,三枪卖出,SMA2,0,1),COLORBLUE;
BG11:=(CLOSE*2+HIGH+LOW)/4;
BG21:=EMA(BG11,13)-EMA(BG11,34);
BG31:=EMA(BG21,5);{ZHIBIAO123.CN}
STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;
STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;
STICKLINE((C<O),CLOSE,LOW,0,0),COLORDE9100;
STICKLINE((C<O),OPEN,HIGH,0,0),COLORDE9100;
STICKLINE((C<O),CLOSE,OPEN,4,0),COLORFF5B00;
STICKLINE((C<O),CLOSE,OPEN,3.4,0),COLORFF6C00;
STICKLINE((C<O),CLOSE,OPEN,2.8,0),COLORFF7B00;
STICKLINE((C<O),CLOSE,OPEN,2.2,0),COLORFF9C00;
STICKLINE((C<O),CLOSE,OPEN,1.6,0),COLORFFBE00;
STICKLINE((C<O),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((C<O),CLOSE,OPEN,0.3,0),COLORFFFF00;
STICKLINE((C>O),CLOSE,OPEN,4,0),COLOR070084;
STICKLINE((C>O),CLOSE,OPEN,3.4,0),COLOR0000A3;
STICKLINE((C>O),CLOSE,OPEN,2.8,0),COLOR0000B7;
STICKLINE((C>O),CLOSE,OPEN,2.2,0),COLOR0000CD;
STICKLINE((C>O),CLOSE,OPEN,1.6,0),COLOR0000E9;
STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR0754E9;
STICKLINE((C>O),CLOSE,OPEN,0.5,0),COLOR076EF3;
STICKLINE((C>O),CLOSE,OPEN,0.2,0),COLOR077BF3;

{DRAWTEXT_FIX(C>O,0,0.07,0,’指标123网’),COLORMAGENTA;}
BG2A:=((CLOSE>REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
BG3A:=((REF(BG2A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG4A:=((REF(BG3A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG5A:=((REF(BG4A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG6A:=((REF(BG5A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG7A:=((REF(BG6A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG8A:=((REF(BG7A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG9A:=((REF(BG8A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BGAA:=((REF(BG9A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BGBA:=((REF(BGAA,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BGCA:=((REF(BGBA,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BGDA:=((REF(BGCA,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BGEAA:=((CLOSE<REF(CLOSE,1)) AND (CLOSE<REF(CLOSE,2)));{ZHIBIAO123.CN}
BGFA:=((REF(BGEAA,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG10A:=((REF(BGFA,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG11A:=((REF(BG10A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG12A:=((REF(BG11A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG13A:=((REF(BG12A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG14A:=((REF(BG13A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG15A:=((REF(BG14A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG16A:=((REF(BG15A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG17A:=((REF(BG16A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG18A:=((REF(BG17A,1) AND (CLOSE<=REF(CLOSE,1))) AND (CLOSE>=REF(CLOSE,2)));
BG19A:=((REF(BG18A,1) AND (CLOSE>=REF(CLOSE,1))) AND (CLOSE<=REF(CLOSE,2)));
BG1A:=(REF((((((((((((BGEAA OR BGFA) OR BG10A) OR BG11A) OR BG12A) OR BG13A) OR BG14A) OR BG15A) OR BG16A) OR BG17A) OR BG18A) OR BG19A),1) ANDBG2A);
STICKLINE(BG1A,O,O+(C-O)/3,4,0),COLOR1029FF;
STICKLINE(BG1A,O,O+(C-O)/3,3.4,0),COLOR1040FF;
STICKLINE(BG1A,O,O+(C-O)/3,2.8,0),COLOR1083FF;
STICKLINE(BG1A,O,O+(C-O)/3,2.2,0),COLOR10ABFF;
STICKLINE(BG1A,O,O+(C-O)/3,1.6,0),COLOR10D0FF;
STICKLINE(BG1A,O,O+(C-O)/3,1,0),COLOR10FFFF;
STICKLINE(BG1A,O,O+(C-O)/3,0.3,0),COLOR00FFFF;
AA:=(REF((((((((((((BG2A OR BG3A) OR BG4A) OR BG5A) OR BG6A) OR BG7A) OR BG8A) OR BG9A)OR BGAA) OR BGBA) OR BGCA) OR BGDA),1) AND BGEAA);
STICKLINE(AA,O,O+(C-O)/3,4.3,0),COLOR009900;
STICKLINE(AA,O,O+(C-O)/3,3.2,0),COLOR00AA00;
STICKLINE(AA,O,O+(C-O)/3,2.4,0),COLOR00BB00;
STICKLINE(AA,O,O+(C-O)/3,1.7,0),COLOR00CC00;
STICKLINE(AA,O,O+(C-O)/3,1.1,0),COLOR00DD00;
STICKLINE(AA,O,O+(C-O)/3,0.5,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,0.2,0),COLOR00FF00;
A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH+LOW)/5;
A18:=(MA(A17,4))-(MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25<A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1))<=(REF(A27,1))) AND (CLOSE>A27)) AND (A21<A22);
A29:=(((REF(CLOSE,1))>=(REF(A27,1))) AND (CLOSE<A27)) AND (A22<A21);
A30:=A28 AND ((COUNT(A28,A21))=1);
A31:=A29 AND ((COUNT(A29,A22))=1);
A32:=A30 AND ((REF(BARSLAST(A31),1))<(REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1))>(REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,’←三枪买入’),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);

指标案例截图:

三枪锁喉买入指标截图

三枪锁喉买入指标公式源码

资源下载
下载价格VIP专享
仅限VIP下载升级VIP
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/4912.html,转载请注明出处。
通达信【一线战天下】主图+副图+选股预警指标公式源码捕捉短线涨停暴利战法
通达信【一线战天下】主图+副图+选股预警指标公式源码捕捉短线涨停暴利战法
1分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录