通达信《儿墨轩分时》主图指标公式源码

通达信《儿墨轩分时》主图指标公式源码:

{仿净流入}
超单买:=SUM(IF(C>=REF(C,1) AND VOL>=26000,VOL,0),FROMOPEN);
超单卖:=SUM(IF(C<REF(C,1) AND VOL>=26000,-VOL,0),FROMOPEN);
超单:(超单买+超单卖)*1000/CAPITAL*100,NODRAW;
大单买:=SUM(IF(C>=REF(C,1) AND VOL>=600 AND VOL<26000,VOL,0),FROMOPEN);
大单卖:=SUM(IF(C<REF(C,1) AND VOL>=600 AND VOL<26000,-VOL,0),FROMOPEN);
大单:(大单买+大单卖)*1000/CAPITAL*100,NODRAW;
FZ:大单-REF(大单,1),NODRAW;
PK1:VAR2STR(FZ,0),NODRAW;
DRAWTEXT(FZ>250,C*0.995,PK1),COLORYELLOW;
DRAWTEXT(FZ>250,C*0.995,’ 万’),COLORYELLOW;
DZ3:=大单-REF(大单,3);
CZ3:=超单-REF(超单,3);
DZ1:=大单-REF(大单,1);
CZ1:=超单-REF(超单,1);
ZS3:DZ3+CZ3,NODRAW;
ZS1:DZ1+CZ1,NODRAW;
ZS33:ZS3/10>N1,NODRAW;
ZS11:ZS1/10>1,NODRAW;
异动:ZS33 AND ZS11 AND FZ>200,NODRAW;
DRAWICON(异动,C,41);
{指标123:WWW.ZHIBIAO123.CN};
N:=0.01;N1:=5;
现流通:=ROUND(FINANCE(46)*C/1000000)/100;
当前成交额:=ROUND(DYNAINFO(10)/10000);
已成额:=STRCAT(CON2STR(当前成交额/10000,2),’亿 / ‘);
流通亿:=STRCAT(CON2STR(现流通,2),’亿_换手Z: ‘);

此隐藏内容仅限VIP查看升级VIP

ZX5:=MA(预警线,5);
DRAWNUMBER(ISLASTBAR,预警线*1.003,预警线),COLORGREEN;
{DRAWTEXT(BARSTATUS=1,预警线*1.002,STRCAT(STRCAT(‘预警’,VAR2STR(预警线,2)),’元’)),COLORYELLOW;}
{指标123:WWW.ZHIBIAO123.CN};
{AAA:=C/DYNAINFO(3);
单笔换手:=V/CAPITAL*100;
XX:=BARSSINCE(V>0)+1;
均价线:=SUM(C*V,XX)/SUM(V,XX),NODRAW;
限制:=AAA>1.01 AND AAA<1.04;
X1:=单笔换手>0.08 AND CROSS(C,均价线) AND 限制;
LT:=(CAPITAL/100)/10000<=10;
JD:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
VV:=V>1999;
PX:=JD>30;
ZZ:=EMA(CLOSE,5)+EMA(CLOSE,60);
ZQ:=EMA(ZZ,30);
Z2:=REF(AAA,1)<1.025 AND AAA>1.025 AND AAA<1.04;
TJ:=ZZ/ZQ>0.99 AND ZZ/ZQ<1.015;
X3:=LT AND (Z2 AND VV AND PX AND TJ);
预警:=X1 OR X3;
DRAWICON(预警,L*1.008,25);
DRAWTEXT(预警,L*0.988,’预警’),COLORWHITE;
STICKLINE(X1 OR X3,C*0.96,C,3,0),COLORFF00FF;}
{突破信号}
XG1:HHV(H,480),DOTLINE,COLORRED;
{STICKLINE(FILTER(CROSS(C,REF(XG1,1)),10) AND C>REF(XG1,1),C*0.99,C,8,0),COLORGREEN;
DRAWTEXT(FILTER(CROSS(C,REF(XG1,1)),10) AND C>REF(XG1,1),C*0.99,’突’),COLOR0080FF;}
{分时突破}{指标123:WWW.ZHIBIAO123.CN};
{MACD}
现价:=C,COLORWHITE;
均价11:=SUM(C*V,240)/SUM(V,240),COLORRED,LINETHICK2;
TT:=BARSCOUNT(C);
前高:=REF(HHV(H,TT),1);
突破:=CROSS(C,REF(HHV(H,TT),1)){ AND HHVBARS(VOL,TT)=0} AND C/均价11<1.09 AND TT>1 AND TT<240;
{主力扫盘:=COUNT(突破,13)>=3 AND CROSS(C,REF(HHV(H,TT),1)){ AND HHVBARS(VOL,TT)=0};
{DRAWTEXT(主力扫盘,前高, ‘←’),COLORYELLOW;
已主力扫盘:=BARSLAST(主力扫盘)<13;
全仓买进:=CROSS(C,REF(HHV(H,TT),1)) AND HHVBARS(VOL,TT)=0 AND C/均价11<1.09 AND TT>1 AND TT<240 AND BARSLAST(主力扫盘)>=20;
DRAWTEXT(全仓买进 ,前高, ‘全仓’),COLORCYAN;
HJ_2:=DYNAINFO(4)>0 AND HHV(HIGH,2)/LLV(LOW,2)<1.25 AND REF(CLOSE,1)<LLV(LOW,3)+(HHV(HIGH,3)-LLV(LOW,3))*0.85;
HJ_9:=EMA(CLOSE,2);
HJ_10:=EMA(CLOSE,3);
HJ_11:=MAX(HJ_9,HJ_10);
X2:=CLOSE>HJ_11 AND HJ_2 AND (CLOSE>REF(HHV(HIGH,2),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.015) AND (V/CAPITAL<=0.2) AND C/REF(C,1)<1.07;}
{牛熊线}{指标123:WWW.ZHIBIAO123.CN};
NX:=MA(((SLOPE(C,20)*5)+C),10);

{MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD10:=(DIF-DEA)*2;
AA0:=MACD10>00 AND DIF>0 AND DEA>0;
{捉牛信号}{指标123:WWW.ZHIBIAO123.CN};
A100:=HOUR=10 AND MINUTE=0;
A20:=HHV(H,30);
A30:=BARSLAST(A100);
A40:=REF(A20,A30);
A50:=CONST(A40);
A80:=CLOSE>A50 AND REF(C<=A50,1) AND CLOSE>NX;
AB:=FILTER(A80,100);
A90:=DYNAINFO(3);
AC:=CLOSE<=A90*1.04 AND CLOSE>A90;
量比:=V/REF(MA(V,5),1);
XG:=AA0 AND AB AND AC AND A40>A90 AND 量比>=1;
DRAWICON(XG,A50,23);
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.995,’突’),COLORYELLOW;
HJ_4:=CLOSE;{指标123:WWW.ZHIBIAO123.CN};
HJ_5:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5);
BAB1:=STICKLINE(HJ_5>0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
BAB2:=STICKLINE(HJ_5<0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);

此隐藏内容仅限VIP查看升级VIP

{指标123:WWW.ZHIBIAO123.CN};
X_1:=HIGH-REF(HIGH,1);
X_2:=REF(LOW,1)-LOW;
X_3:=EMA(IF(X_1>0 AND X_1>X_2,X_1,0),28);
X_4:=EMA(IF(X_2>0 AND X_2>X_1,X_2,0),28);
X_5:=EMA(X_3/TR,28);
X_6:=EMA(X_4/TR,28);
X_7:=EMA((CLOSE+HIGH+LOW)/3,2);
X_8:=MAX(DYNAINFO(3),EMA(DYNAINFO(5),5));
X_9:=MIN(DYNAINFO(3),EMA(DYNAINFO(6),5));
X_10:=(COST(95)+DYNAINFO(11))/2;
X_11:=(COST(5)+DYNAINFO(11))/2;
X_12:=CONST((X_8+X_10)/2);
X_13:=CONST((X_9+X_11)/2);
X_14:=(X_12+X_13)/2;
X_15:=X_13+X_14-X_12;
X_16:=(X_13+X_15)/2;
X_17:=(X_15+X_16)/2;
X_18:=(EMA(CLOSE,24)-EMA(CLOSE,52))*4+X_14;
X_19:=EMA(X_18,18);
MCD:=(X_18-X_19)*2+X_14,NODRAW,COLORYELLOW;
X_20:=3*SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54)),3,1)-2*SMA(SMA((CLOSE-LLV(LOW,54))/(HHV(HIGH,54)-LLV(LOW,54)),3,1),3,1);
X_21:=MEMA(X_20,10);
X_22:=EMA(X_21,10);
X_23:=IF(EXIST(CROSS(X_12,X_7),5) AND EXIST(CLOSE>X_12,10) AND X_21<HHV(X_21,10) AND X_22<REF(X_22,1),1,0);
X_24:=IF(EXIST(CROSS(X_7,X_13),5) AND EXIST(CLOSE<X_13,10) AND X_21>LLV(X_21,10) AND X_22>REF(X_22,1),1,0);
卖出:=X_23=1 AND REF(X_23,1)=0;
{DRAWICON(X_23=1 AND REF(X_23,1)=0,X_12,8);
DRAWICON(X_24=1 AND REF(X_24,1)=0,X_13,7);
STICKLINE(X_23=1 AND REF(X_23,1)=0,X_12,X_13,0,0),COLORGREEN;
STICKLINE(X_24=1 AND REF(X_24,1)=0,X_12,X_13,0,0),COLORRED;}
{指标123:WWW.ZHIBIAO123.CN};
YD:=DYNAINFO(3);
MM:=IF(C=DYNAINFO(4)*1.1 AND L=DYNAINFO(4)*1.1,H-YD,H-REF(C,1));
M:=IF(MM>0,MM,0.0);
SS:=IF(C=DYNAINFO(4)*0.9 AND H=DYNAINFO(4)*0.9,YD-H,REF(C,1)-L);
S:=IF(SS>0,SS,0.0);
HJ:=M+S;
买入力度:=M/HJ*AMOUNT/CAPITAL;
卖出力度:=S/HJ*AMOUNT/CAPITAL;
{分时买卖追涨}
N2:=7.5;
MMA30:=EMA(CLOSE,30);
强弱界定:=IF(PERIOD=0,EMA(CLOSE,900),DRAWNULL),COLORWHITE,LINETHICK2;
分时价量线:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
实时涨幅限制:=(C/DYNAINFO(3)-1)*100;{买卖力度}
买卖力度:=SUM((买入力度-卖出力度),0),COLORAAAA00,NODRAW;
买卖力度比:=买卖力度/SUM((买入力度+卖出力度),0)*50,NODRAW,COLORFFFFFF,LINETHICK2;
买卖力度比设置:=买卖力度比+50;
买卖力度比限制:=IF(买卖力度比设置>80,80,IF(买卖力度比设置<20,20,买卖力度比设置));
分时力度线:=SUM(C*买卖力度比限制,240)/SUM(买卖力度比限制,240);
买卖力度参考线0:=MA(买卖力度比限制,8)*1.062;
买卖力度参考线:=MA(买卖力度比限制,8)*1.091;
买卖力度参考线2:=MA(买卖力度比限制,5)*1.191;
平安分时关注:=买卖力度参考线<50 AND CROSS(买卖力度比限制,50);
平安分时追涨:=(CROSS(买卖力度比限制,买卖力度参考线) OR (CROSS(买卖力度比限制,买卖力度参考线0) AND 买卖力度比限制>70))
AND (买卖力度比限制>50) AND (MMA30>强弱界定 OR 分时价量线>强弱界定 OR C>MAX(MMA30,强弱界定)) AND C>分时价量线
AND V>MA(V,20) AND DYNAINFO(17)>=1.2 AND 实时涨幅限制<N2;
{DRAWTEXT(FILTER(平安分时关注,20),现价,’←关注’),COLOR00FFFF;
STICKLINE(FILTER(平安分时关注,20),X_12,X_13,0,0),COLOR00FFFF;}
{DRAWTEXT(FILTER(平安分时追涨,20),现价,’←追涨’),COLORMAGENTA;
STICKLINE(FILTER(平安分时追涨,20),X_12,X_13,0,0),COLORMAGENTA;}
{PA4:=BARSSINCE(平安分时追涨)+1;
首次追涨价:=REF(C,PA4-1),NODRAW;
追涨收益:(DYNAINFO(7)-首次追涨价)/首次追涨价*100,NODRAW;
PA5:=BARSSINCE(平安分时关注)+1;
首次关注价:=REF(C,PA5-1),NODRAW;
关注收益:(DYNAINFO(7)-首次关注价)/首次关注价*100,NODRAW,COLORRED;}
{指标123:WWW.ZHIBIAO123.CN};
A024:IF(CODELIKE(‘300’) OR CODELIKE(‘688’),DYNAINFO(3)*0.9205,DYNAINFO(3)*0.9586),COLORCYAN ,DOTLINE;
DRAWNUMBER(ISLASTBAR,A024,A024),COLORCYAN;
A026:IF(CODELIKE(‘300’) OR CODELIKE(‘688’),DYNAINFO(3)*0.945,DYNAINFO(3)*0.971),COLORCYAN ;
DRAWNUMBER(ISLASTBAR,A026,A026),COLORCYAN;
A027:IF(CODELIKE(‘300’) OR CODELIKE(‘688’),DYNAINFO(3)*1.0586,DYNAINFO(3)*1.0298),COLORMAGENTA ;
DRAWNUMBER(ISLASTBAR,A027,A027),COLORCYAN;
A023:IF(CODELIKE(‘300’) OR CODELIKE(‘688’),DYNAINFO(3)*1.0864,DYNAINFO(3)*1.0432),COLORMAGENTA,DOTLINE;
DRAWNUMBER(ISLASTBAR,A023,A023),COLORCYAN;

DRAWTEXT_FIX(ISLASTBAR,0.005.005,0.95,0,GNBLOCK),COLORWHITE;

{分时压力}
MM1:”重心.前收#DAY”*1.0618,COLORYELLOW,DOTLINE;
DRAWTEXT(BARSTATUS=1,MM1*1.005,STRCAT(STRCAT(‘阻力:’,VAR2STR(MM1,2)),’元’)),COLORYELLOW;
{分时支撑}{指标123:WWW.ZHIBIAO123.CN};
ZC2:”重心.前收#DAY”*0.941,COLORYELLOW,DOTLINE;
DRAWTEXT(BARSTATUS=1,ZC2*1.005,STRCAT(STRCAT(‘支撑:’,VAR2STR(ZC2,1)),’元’)),COLORYELLOW;

LTPY:=CAPITAL/1000000;
P:=IF(LTPY>10,3,IF(RANGE(LTPY,5,8),4,IF(RANGE(LTPY,3,5),5,IF(RANGE(LTPY,2,3),8,10))));
竞开标量:=LTPY/10*P;
DRAWTEXT_FIX(1,0.86,0.90,0,STRCAT(STRCAT(‘【竞开标量】’,CON2STR(竞开标量,2)),’万手’)),COLORRED;
竞价额万:=DYNAINFO(15)/10000;
DRAWTEXT_FIX(1,0.86,0.85,0,STRCAT(STRCAT(‘【竞价额万】’,CON2STR(竞价额万,0)),’万’)),COLORRED;
竞价量:=DYNAINFO(15)/O/100;
{竞量比:竞价量/”重心.前量#DAY”*100,NODRAW;}
竞量比:”重心.竞量比#DAY”,NODRAW;
DRAWTEXT_FIX(1,0.86,0.95,0,STRCAT(STRCAT(‘【竞量比】’,CON2STR(竞量比,2)),’%’)),COLORRED;

JJCJL:=DYNAINFO(15)/DYNAINFO(4)/100;{集竞成交量}
AA:=STRCAT(‘集竞成交量:’,CON2STR(JJCJL,0));
DRAWTEXT_FIX(1,0.4,0.05,0,STRCAT(AA,’手’)),COLORRED;
{昨日高量:”FSYY.昨日最高量”,NODRAW;}{指标123:WWW.ZHIBIAO123.CN};
开额:DYNAINFO(15),NODRAW;
开盘量比:DYNAINFO(15)/DYNAINFO(4)/100/DYNAINFO(16),NODRAW;
A:=BARSLAST(DAY<>REF(DAY,1))+1;
分时高量:HHV(V,A),DOTLINE,NODRAW;
昨日最高量:REF(HHV(V,A),A){一分钟周期},NODRAW;
昨竞量:REF(V,BARSLAST(TIME<92700)),NODRAW;
竞价量1:SUM(IF(TIME<92610 ,VOL,0),0),NODRAW;
{竞价量:”FSYY.竞价量”,NODRAW;}
{爆量:分时高量/昨日高量,NODRAW;
爆量比:JJCJL/昨日最高量,NODRAW;
DRAWTEXT_FIX(1,0.51,0.05,0,STRCAT(STRCAT(‘爆量比:’,CON2STR(爆量比,2)),’%’)),COLORRED;
DRAWTEXT_FIX(1,0.51,0.15,0,STRCAT(STRCAT(‘爆量:’,CON2STR(爆量,2)),’%’)),COLORRED;}
{DRAWTEXT_FIX(1,0.4,0.05,0,STRCAT(STRCAT(‘竞价量:’,CON2STR(AA,0)),’手’)),COLORRED;}
{DRAWTEXT_FIX(1,0.4,0.15,0,STRCAT(STRCAT(‘昨日高量:’,CON2STR(昨日高量,0)),’手’)),COLORRED;
DRAWTEXT_FIX(1,0.4,0.25,0,STRCAT(STRCAT(‘今日高量:’,CON2STR(分时高量,0)),’手’)),COLORRED;};
{指标123:WWW.ZHIBIAO123.CN};

通达信《儿墨轩分时》主图指标案例截图:

儿墨轩分时图2

儿墨轩分时图1

儿墨轩分时图3

资源下载
下载价格20 金币
VIP免费
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/2759.html,转载请注明出处。
通达信《筹码低位单峰密集》副图+选股预警指标公式源码
通达信《筹码低位单峰密集》副图+选股预警指标公式源码
10分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录