通达信《捉大妖》主图指标:捕捉市场大行情的利器

在变幻莫测的股市中,如何抓住大行情,实现财富的快速增值?通达信《捉大妖》主图指标为您揭秘股市大妖股的奥秘。通过独特的算法和数据分析,该指标能够精准捕捉市场大行情的启动点,助您在投资中抢占先机。无论您是短线交易者还是中长线投资者,《捉大妖》主图指标都是您不可或缺的决策利器。让我们一起捉住大妖,驾驭财富的巨轮,驶向投资的彼岸。

指标源码:

DRAWGBK(CLOSE>0,RGB(1,1,1),RGB(1,1,1),0,1,0);
DRAWNULL,COLORCCCCCC;
{板块市值业绩}
所属板块:=STRCAT(‘【所属板块】:’,STRCAT(STRCAT(‘ [行业]—’,HYBLOCK),STRCAT(‘ [概念]—’,GNBLOCK)));
风格板块:=STRCAT(‘【风格板块】:’,STRCAT(STRCAT(‘ [地域]—’,DYBLOCK),STRCAT(‘ [风格]—’,FGBLOCK)));
总股本:=STRCAT(STRCAT(‘ 总股本:’,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);
流通盘:=STRCAT(STRCAT(‘ 流通盘:’,CON2STR(CAPITAL/1000000,2)),’亿’);
全流通:=STRCAT(STRCAT(‘ 流通比:’,CON2STR(CAPITAL/TOTALCAPITAL*100,2)),’%’);
市值:=STRCAT(STRCAT(‘ 流通市值:’,CON2STR((CAPITAL/1000000)*C,2)),’亿’);
股本市值:=STRCAT(‘【股本市值】:’,STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值));
市盈率:=STRCAT(‘ 市盈率:’,CON2STR(C/FINANCE(33),2));
净资收益率:=STRCAT(‘ 净资收益率:’,CON2STR(FINANCE(33)/FINANCE(34)*100,2));
主营利润率:=STRCAT(‘ 主营利润率:’,CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT(‘【当前业绩】:’,STRCAT(STRCAT(市盈率,净资收益率),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.005,0.07,0,风格板块),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,股本市值),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.17,0,当前业绩),COLORMAGENTA;
获利盘%:=100*WINNER(C);
短期压力:=HHV(H,15);
短期支撑:=LLV(L,20);
X11:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X12:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X13:=FINANCE(23)/FINANCE(10)*3.3;
X14:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X15:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X11+X12+X13+X14+X15;
DRAWTEXT_FIX(Z值<1.2,0.312,0.22,0,’ 【●财务重警●】’),COLORLIRED;
DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.312,0.22,0,’ 【○财务轻警○】’),COLOR0099FF;
DRAWTEXT_FIX(Z值>2.6,0.312,0.22,0,’ 【◎财务无警◎】’),COLORLIGREEN;
DRAWTEXT_FIX(C>0,0.005 ,0.22,0,’【获利盘%】:’),COLORRED;

此隐藏内容仅限VIP查看升级VIP

{涨停统计}
STG:=NAMELIKE(‘S’) OR NAMELIKE(‘*’);
涨停:=((C/REF(C,1)>=1.095 AND C=H) OR (C/REF(C,1)>=1.09 AND C=O AND O=L AND H=L) OR (C/REF(C,1)>=1.048 AND STG=1 AND C=H) OR (C/REF(C,1)>=1.045 AND C=O AND O=L AND H=L AND STG=1)) AND CURRBARSCOUNT<=120;
ZTCS:=COUNT(涨停,BARSSINCE(涨停)+1);
GZT1:=STRCAT(‘ 半年內涨停次数:’,CON2STR(ZTCS,0));
GZT2:=STRCAT(GZT1,’次’);
SSTS1:=STRCAT(‘ 上市天数:’,CON2STR(FINANCE(42),0));
SSTS2:=STRCAT(SSTS1,’天’);
NTZZT1:=STRCAT(‘ 距今:’,CON2STR(CONST(BARSLAST(涨停)),0));
NTZZT2:=STRCAT(NTZZT1,’天有涨停’);
ZTTJ1:=STRCAT(SSTS2,GZT2);
ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);
ZTTJ:=STRCAT(‘【涨停统计】:’,ZTTJ2);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.005,0.265,0,ZTTJ),COLORYELLOW;
DRAWKLINE(H,O,L,C);
N:=2;M:=30;
MA(H,M) * (1 + 13 / 100) * 1.0382,LINETHICK1,COLORYELLOW ;
MA(H,M) * (1 + 13 / 100),LINETHICK1,COLORYELLOW ;
EMA(L,30) * (1 – 15 / 100),COLORGREEN , NODRAW ;
EMA(L,30) * (1 – 15 / 100) * 0.82,NODRAW, COLORYELLOW;
AA:(EMA(C,5) * 7 + EMA(C,10) * 3) / 10,LINETHICK2,COLORWHITE;
A1:=(H + L + O + C) / 4;A2:=EMA(A1,13) – EMA(A1,34);A3:=EMA(A2,5);
A4:=(A2 – A3) * 5;A5:=IF(A4 >= 1000,1000,IF(A4 <= A1,A1,A4));
A6:=FORCAST(FORCAST(A5,32),10);A7:=(C – EMA(C,13)) / EMA(C,13) * (0 – 100);
A8:=EMA(A7 / 10 + EMA(C,13),8);A9:=EMA(C,3);A10:=EMA(SLOPE(C,22) * 20 + C,45);
A11:=IF(PERIOD >8 AND PERIOD < 11,MA(A10,1),IF(PERIOD = 8,MA(A10,4),IF(PERIOD = 7,MA(A10,8),IF(PERIOD = 6,MA(A10,16),IF(PERIOD = 5,MA(A10,32),0)))));A12:=A11 * 0.865;A13:=IF(A9 > A11,A9,A12);
A14:=C * V;A15:=EMA((EMA(A14,3) / EMA(V,3) + EMA(A14,6) / EMA(V,6) + EMA(A14,12) / EMA(V,12) + EMA(A14,24) / EMA(V,24)) / 4,13);
A16:=1.06 * A15;A17:=(C – REF(C,1)) / REF(C,1) * 100 > 8.5;
A18:=EMA(H,10) * (1 + 5 / 100);
捉妖:CROSS(AA,MA(H,30) * (1 + 13 / 100)) * 10,NODRAW;
A19:=(C – O) / REF(C,1) * 100;A20:=REF(H,N) = HHV(H,2 * N + 1);
A21:=FILTER(A20,N);A22:=BACKSET(A21,N + 1);A23:=FILTER(A22,N);
A24:=REF(L,N) = LLV(L,2 * N + 1);A25:=FILTER(A24,N);
A26:=BACKSET(A25,N + 1);A27:=FILTER(A26,N);
A28:=(REF(LLV(L,2 * N),1) + REF(HHV(H,2 * N),1)) / 2;
A29:=(H + L) / 2;A30:=(A23 AND NOT(A27 AND A28 >= A29)) OR ISLASTBAR OR BARSCOUNT(C) = 1;
A31:=A27 AND NOT(A23 AND A28 < A29);A32:=REF(BARSLAST(A30),1) + 1;
A33:=BACKSET(A30 AND COUNT(A31,A32) > 0,LLVBARS(IF(A31,L,10000),A32));
A34:=A33 > REF(A33,1);A35:=BACKSET(A34,2);A36:=A35 > REF(A35,1);
A37:=A36 OR ISLASTBAR OR BARSCOUNT(C) = 1;A38:=REF(BARSLAST(A37),1) + 1;
A39:=BACKSET(A37 AND COUNT(A23 AND NOT(A27 AND A28 >= A29),A38) > 0,HHVBARS(IF(A23 AND NOT(A27 AND A28 >= A29),H,0),A38));
A40:=A39 > REF(A39,1);A41:=BACKSET(A40,2);A42:=A41 > REF(A41,1);
A43:=BACKSET(ISLASTBAR,BARSLAST(A42) + 1);A44:=A43 > REF(A43,1);
A45:=BACKSET(A44,REF(BARSLAST(A42),1) + 2);A46:=A45 > REF(A45,1);
短齐压力:DRAWLINE(A46,H,A44,H,1),COLORGREEN,NODRAW;
{真妖显身}A0:=((L+H+C*2)/4);上F:=EMA(A0,14)*1.1382;
A1KX:=(上F-REF(上F,1)) / REF(上F,1) * 100;GD1:=BARSLAST(CROSS(A1KX,0));
真妖显身:IF(H>=REF(A0,BARSLAST(CROSS(A1KX,0)))*1.3,REF(A0,BARSLAST(CROSS(A1KX,0)))*1.3,DRAWNULL),COLORFFB5FF,LINETHICK9;
DRAWTEXT(ISLASTBAR,真妖显身,’ 妖股显身’),COLORFFB5FF;
DRAWTEXT(FILTER(CROSS(AA,MA(H,30) * (1 + 13 / 100)),5),MA(H,30) * (1 + 13 / 100) * 0.88,’ 捉大妖’),COLORGREEN;{=====================================}
VAR22:=IF(((YEAR) >= (2039)) AND ((MONTH) > 3),0,1);
VAR33:=(MA(C,3) + MA(C,6) + MA(C,12) + MA(C,24)) / 4 + ((1.88) * (STD((MA(C,3) + MA(C,6) + MA(C,12) + MA(C,24)) / 4,9))) * (VAR22);
急拉涨停线:((MA(VAR33,12)) * (1.06)) * (VAR22),LINETHICK2,COLORCYAN ;
VAR55:=(EMA(H,10)) * (1 + 5 / (100));
VAR6:=C * V;
VAR7:=EMA(((EMA(VAR6,3)) / (EMA(V,3)) + (EMA(VAR6,6)) / (EMA(V,6)) + (EMA(VAR6,12)) / (EMA(V,12)) + (EMA(VAR6,24)) / (EMA(V,24))) / 4,13);
VAR8:=(1.06) * (VAR7);VAR9:=(L / ((H + REF(C,1) + O) / 3)) * C;
DRAWTEXT(((CROSS(VAR9,VAR8)) AND (C > (VAR55))) AND (C > (急拉涨停线)),L,’▲’),LINETHICK1,COLORYELLOW;{==========开口捉妖多彩K线========}
NN:=5;MM:=3;VAR0:=((EMA(C,5)) * 7 + (EMA(C,10)) * 3) / 10;
VAR1:=IF((YEAR) >= (2025),0,1);VAR2:=EMA(EMA(L,21) + (6.8) * (STD(L,2)),55);VAR3:=EMA(((C / (VAR2)) * ((1.88) * C + L + O)) / (2.75),3);
VAR4:=(((VAR3) – (VAR2)) / (VAR2)) / 2;VAR5:=(EMA((VAR3) – ((VAR4) * (VAR3)),5)) * (VAR1);黄金轨道:(IF((VAR0) > (VAR5),VAR0,VAR5)) * (VAR1),NODRAW ,COLORRED ;{红线}上轨:IF(((VAR5) < (VAR0)) AND ((VAR5) < (C * (0.15))),(EMA(C,300)) – (3 * (STD(C,300))),VAR5),NODRAW ,COLORYELLOW;{黄线}IF((VAR5) > (VAR0),上轨,DRAWNULL),COLORCYAN ,NODRAW ;{中轴}
VAR10:=(((SMA(MAX(C – (REF(C,1)),0),24,1)) / (SMA(ABS(C – (REF(C,1))),24,1))) * (100)) * (VAR1);VAR13:=((SMA(MAX(C – (REF(C,1)),0),14,1)) / (SMA(ABS(C – (REF(C,1))),14,1))) * (100);
VAR14:=(EMA(C,60) + EMA(C,120) + EMA(C,240) + EMA(C,480)) / 4;
VAR15:=VAR14 + (1.91) * (STD(VAR14,3));VAR16:=(EMA(VAR15,12)) * (1.23);{红色中线}
STICKLINE((((VAR10) > 65) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16)),H,L,0,0),COLORRED;{红色}
STICKLINE((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16)),C,O,3,0),COLORRED;VAR37:=((L + H) / 2);
VAR39:=(EMA((C + L + H) / 3,1));{黄色}STICKLINE(((((VAR10) >= (64.5)) AND ((VAR13) >= 65)) AND ((MA(C,1)) > (VAR16))) AND ((MA(C,1)) > ((MA(H,30)) * (1 + 15 / (100)))),O,(VAR37 + L) / 2,3,0),COLORYELLOW;{白色}
STICKLINE(((C > ((MA(H,30)) * (1 + 18 / (100)))) AND (C > (VAR5))) AND ((VAR10) > (64.5)),VAR39,VAR37,3,0),COLORWHITE;{================超牛=================}
转强:=100*(C-REF(C,12))/REF(C,12);{WWW.ZHIBIAO123.CN}
超强:=((H+L+C)/3-MA((H+L+C)/3,88))/(0.015*AVEDEV((H+L+C)/3,88));
通道:=1.07*DMA(C,ABS((2*C+H+L)/4-MA(C,26))/MA(C,26));
趋势:=MA(ATAN(通道-REF(通道,1)),3);
QS1:=IF((C>O OR C<O) AND H>=REF(C,1),ATAN(MA(H,5)*1.02-REF(MA(C,5)*1.02,1)),0);
QS2:=IF((C>O OR C<O) AND H<REF(C,1),-ATAN(REF(MA(C,5)*1.02,1)-MA(H,5)*1.02),0);
分界:=MA(REF((QS1+QS2),1),26);
强势:=趋势>分界 AND 趋势>REF(趋势,1);
超级牛股:=强势 AND 超强>200 AND 转强>20 AND C>REF(C,1);
{================走强线 ================};
DRAWTEXT(超级牛股,L*0.95,’ 龙’),COLORRED;

指标截图:

资源下载
下载价格VIP专享
仅限VIP下载升级VIP
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/16375.html,转载请注明出处。
通达信《庄家出击》全套指标:揭秘股市庄家的操盘密码
通达信《庄家出击》全套指标:揭秘股市庄家的操盘密码
3分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录