通达信《炸炸》主图指标公式源码

在股票投资的广阔领域中,通达信《炸炸》主图指标宛如一颗璀璨的明珠,为投资者照亮前行的道路。

这一主图指标并非普通的工具,它融合了先进的技术分析和独特的算法,通过清晰直观的图表呈现,帮助投资者精准捕捉市场的动态变化。从趋势的判断到买卖点的把握,《炸炸》都能提供准确而及时的信号。

无论是短线交易者追求快速盈利,还是长线投资者谋求稳定布局,《炸炸》主图指标都能凭借其强大的功能性和稳健的表现成为您投资决策过程中的得力助手。让我们借助这一神奇的指标,在风云变幻的股市中炸出属于自己的财富之路。

《炸炸》指标源码:

VAR1:=IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1));
VAR2:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,VAR1)));
VAR3:=IF(MOD(FROMOPEN,VAR2)<0.5,VAR2,MOD(FROMOPEN,VAR2));
VAR4:=IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),V*(VAR2+3)/(VAR3+3),V);
VAR5:=IF(FINANCE(3)=2,0.3,IF((FINANCE(3)=3 OR FINANCE(3)=4 OR FINANCE(3)=6),0.2,0.1));
VAR6:=ZTPRICE(REF(C,1),IF(NAMEINCLUDE('ST'),0.05,VAR5));
VAR7:=DTPRICE(REF(C,1),IF(NAMEINCLUDE('ST'),0.05,VAR5));
VAR8:=C>=ZTPRICE(REF(C,1),IF(NAMEINCLUDE('ST'),0.05,VAR5)) AND H!=L AND H>0;
VAR9:=C>=ZTPRICE(REF(C,1),IF(NAMEINCLUDE('ST'),0.05,VAR5)) AND H=L AND H>0;
VAR10:=C<=DTPRICE(REF(C,1),IF(NAMEINCLUDE('ST'),0.05,VAR5)) AND H!=L AND L>0;
VAR11:=C<=DTPRICE(REF(C,1),IF(NAMEINCLUDE('ST'),0.05,VAR5)) AND H=L AND L>0;
VAR12:=EMA(COST(85),10)>=REF(EMA(COST(85),10),1);
VAR13:=VAR12 AND EMA(COST(99),10)>=REF(EMA(COST(99),10),1);
VAR14:=BARSLAST(H>=VAR6 AND C<H);
VAR15:=REF(VAR14,VAR14+1)+VAR14+1;
VAR16:=REF(VAR14,VAR15+2)+VAR15+2;
VAR17:=CROSS(C,REF(AMOUNT/V/100,VAR14));
VAR18:=VAR17 OR (REF(C<=REF(AMOUNT/V/100,VAR14),1) AND C>REF(AMOUNT/V/100,VAR14));
VAR19:=BETWEEN(VAR14,1,8) AND (VAR18) AND REF(COUNT(C>REF(REF(H,VAR14),1),VAR14),1)=0 AND C>O;
VAR20:=C>REF(REF(AMOUNT/V/100,VAR14),1) AND C>O;
VAR21:=VAR14>8 AND REF(C,1)<=REF(REF(AMOUNT/V/100,VAR14),1) AND VAR20;
VAR22:=VAR14>8 AND REF(C,1)<=REF(REF(H,VAR14),1) AND C>REF(REF(H,VAR14),1) AND C>O;
VAR23:=REF(VAR8 OR VAR9,1) AND C<O;
VAR24:=VAR23 AND (V>=REF(V,1)*1.9 OR AMOUNT>=REF(AMOUNT,1)*1.9);
VAR25:=BARSLAST(VAR24);{WWW.ZHIBIAO123.CN}
VAR26:=H=C OR (O>=REF(H,1) AND C>O);
VAR27:=H-MAX(O,C)<MAX(O,C)-MIN(O,C);
VAR28:=MAX(O,C)-MIN(O,C)>(H-MAX(O,C))*1.38;
VAR29:=MAX(O,C)-MIN(O,C)>MIN(O,C)-L AND MAX(O,C)-MIN(O,C)>H-MAX(O,C);
VAR30:=IF(VAR26,1,IF(L=O,VAR27,IF(H-MAX(O,C)>MIN(O,C)-L,VAR28,IF(L<O AND H>C,VAR29,DRAWNULL))));
VAR31:=DYNAINFO(4)>0 AND BARSLASTCOUNT(C/REF(C,1)>1.09)=1;
VAR32:=BARSLAST(BARSLASTCOUNT(C>REF(C,4))=9>0);
VAR33:=VAR32>4 AND C/REF(C,1)>1.09 AND C>REF(H,VAR32) AND VAR31;
VAR34:=MAX(MAX((H-L),ABS((REF(C,1)-H))),ABS((REF(C,1)-L)));
VAR35:=(REF(CLOSE,1)-REF(MA(VAR34,13),1));
VAR36:=(C-REF(C,1))/REF(C,1)*100<-5.5 OR C/O<=0.955;
VAR37:=REF(BARSLAST(VAR36),BARSLAST(VAR36)+1)+BARSLAST(VAR36)+1;
VAR38:=(REF(O,BARSLAST(VAR36))+REF(C,BARSLAST(VAR36)))/2;
VAR39:=IF(PERIOD=4,60,IF(PERIOD=5, TOTALFZNUM,1));
VAR40:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,VAR39)));
VAR41:=IF(MOD(FROMOPEN,VAR40)<0.5,VAR40,MOD(FROMOPEN,VAR40));
VAR42:=IF(CURRBARSCOUNT=1 AND DYNAINFO(8)>1,AMOUNT*(VAR40+3)/(VAR41+3),AMOUNT);
VAR43:=VAR42>=REF(AMOUNT,1)*1.9 AND (IF(C<=O,C>REF(C,1),1));
VAR44:=AMOUNT=HHV(AMOUNT,120) AND VAR43 AND VAR4/REF(MA(V,5),1)>2 AND (BARSCOUNT(C)+1)>120;
VAR45:=REF(BARSLAST(VAR44),BARSLAST(VAR44)+1)+BARSLAST(VAR44)+1;
VAR46:=REF(DOWNNDAY(C,3),1) AND C>REF(C,1) AND C>=O;
VAR47:=IF(C>O,V/((H-L)*2-ABS(C-O))*(H-L),IF(C<O,V/((H-L)*2-ABS(C-O))*((H-O)+(C-L)),V/2));
VAR48:=0-V/((H-L)*2-ABS(C-O))*((H-C)+(O-L));
VAR49:=IF(C>O,VAR48,IF(C<O,0-V/((H-L)*2-ABS(C-O))*(H-L),0-V/2));
VAR50:=(VAR47+VAR49)/99/AMOUNT/10000*100;
VAR51:=STRCAT(STRCAT('总上涨:',CON2STR(DYNAINFO(60),0)),' 只');
VAR52:=STRCAT(STRCAT('总下跌:',CON2STR(DYNAINFO(61),0)),' 只');
VAR53:=(DYNAINFO(60)+DYNAINFO(61));
VAR54:=STRCAT(STRCAT('涨跌比:',CON2STR(DYNAINFO(60)/VAR53*100,2)),' %');
VAR55:=REF(AMOUNT/V/100,VAR14);{WWW.ZHIBIAO123.CN}
VAR56:=BETWEEN(VAR14,0,8) AND IF(VAR14=0 AND BETWEEN(C,AMOUNT/V/100,REF(H,VAR14)),1,IF(VAR14>0,COUNT(C<REF(AMOUNT/V/100,VAR14),VAR14)=0 AND COUNT(C>REF(REF(H,VAR14),1),VAR14)=0,0));
VAR57:=VAR56 AND IF(CODELIKE('43') OR CODELIKE('83') OR CODELIKE('87') OR CODELIKE('88') OR BETWEEN(FINANCE(3),4,8) OR FINANCE(3)=2 OR NAMEINCLUDE('ST') OR NAMELIKE('*'),0,1);
VAR89:=BETWEEN(C,AMOUNT/V/100,REF(H,VAR14));
VAR88:=COUNT(C<REF(AMOUNT/V/100,VAR14),VAR14)=0;
DRAWTEXT_FIX(1,0.00,0.00,0,'板块:'),COLORCYAN;
DRAWTEXT_FIX(1,0.05,0.00,0,STRCAT(STRCAT(STRCAT(STRCAT(HYBLOCK,'__'),GNBLOCK),'__'),DYBLOCK)),COLORCYAN;
今夕比:VAR4/REF(V,1),COLORWHITE,NODRAW;
弱分界:EMA(COST(85),10),COLORRED,DOTLINE;
强分界:EMA(COST(99),10),COLORGREEN,DOTLINE;
八日内不破均突:BETWEEN(VAR14,1,8) AND REF(IF(VAR14=0 AND VAR89,1,IF(VAR14>0,VAR88 AND COUNT(C>REF(REF(H,VAR14),1),VAR14)=0,0)),1)=1 AND C>REF(REF(H,VAR14),1),COLORMAGENTA,NODRAW;{WWW.ZHIBIAO123.CN}
八日内突:VAR19 AND REF(COUNT(VAR19,VAR14),1)=0,COLORYELLOW,NODRAW;
超八突:VAR21 AND REF(COUNT(VAR21,VAR14),1)<=2,COLORRED,NODRAW;
超八加:VAR22 AND REF(COUNT(VAR22,VAR14),1)<=2,COLORWHITE,NODRAW;
破倍阴均:REF(C,1)<=REF(REF(AMOUNT/V/100,VAR25),1) AND C>REF(REF(AMOUNT/V/100,VAR25),1) AND VAR30,COLORYELLOW,NODRAW;
破倍阴高:REF(C,1)<=REF(REF(H,VAR25),1) AND C>REF(REF(H,VAR25),1) AND VAR30,COLORMAGENTA,NODRAW;
DRAWBAND(弱分界,RGB(20,20,20),强分界,RGB(60,60,8));
DRAWBAND(IF(VAR13,强分界,弱分界),RGB(139,35,35),弱分界,RGB(00,00,00));
DRAWKLINE(H,O,L,C);
STICKLINE(VAR8,O,C,3,0),COLORMAGENTA;
STICKLINE(VAR8,H,L,0,0),COLORMAGENTA;
STICKLINE(VAR10,O,C,3,0),COLORFF8000;
STICKLINE(VAR10,H,L,0,0),COLORFF8000;
STICKLINE(VAR9,O,C,3,0),COLORMAGENTA;
STICKLINE(VAR11,O,C,3,0),COLORBLUE;
STICKLINE(H>=VAR6 AND C<H,H,MIN(O,C),0,0),COLOR5900B3;
STICKLINE(H>=VAR6 AND C<H,O,C,0.18,0),COLOR5900B3;
STICKLINE(L<=VAR7 AND C=VAR6,MIN(O,C),L,0,0),COLORFF8000;
STICKLINE(L<=VAR7 AND C=VAR6,O,C,0.18,0),COLORFF8000;
DRAWTEXT(H>=VAR6 AND C<H,H,'炸'),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=CONST(VAR16)+1 AND VAR14>=0,REF(H,VAR14),REF(H,VAR14),4.2,-1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=CONST(VAR15)+1 AND VAR14>=0,REF(H,VAR14),REF(H,VAR14),4.2,-1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT<=CONST(VAR14)+1 AND VAR14>=0,REF(H,VAR14),REF(H,VAR14),4.2,0),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,REF(H,VAR14),VARCAT(VAR2STR(REF(H,VAR14),2),'←炸分高')),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,VAR55,VARCAT(VAR2STR(REF(AMOUNT/V/100,VAR14),2),'↙炸分均')),COLORLIGRAY,DRAWABOVE;
DRAWICON(八日内不破均突,L,34);
DRAWICON(八日内突,L,1);
DRAWICON(超八突,L,38);
DRAWICON(超八加,L,23);
DRAWTEXT(VAR24,H*1.012,'倍阴'),COLORLIGREEN;
STICKLINE(VAR24,O,C,3,0),COLORLIGREEN;
STICKLINE(VAR24,L,H,0,0),COLORLIGREEN;
DRAWICON(破倍阴均 AND EMA(C,5)>=REF(EMA(C,5),1) AND C>EMA(C,5) AND REF(COUNT(破倍阴均,VAR25),1)<=2,L*0.98,11);
DRAWICON(破倍阴高 AND EMA(C,5)>=REF(EMA(C,5),1) AND C>EMA(C,5) AND REF(COUNT(破倍阴高,VAR25),1)<=2,O,25);
DRAWICON(VAR57,L,9);
DRAWTEXT((BARSLASTCOUNT(C>REF(C,4)))=9 AND C>=O,(O+C)/2,'9'),COLORGREEN;
DRAWTEXT((BARSLASTCOUNT(C>REF(C,4)))=9 AND C<O,(O+C)/2,'9'),COLORFF0000;
DRAWTEXT((BARSLASTCOUNT(C<REF(C,4)))=9,(O+C)/2,'9'),COLORRED;
DRAWTEXT(FILTER(VAR33>0,3),L*0.998,'9'),COLORGREEN;
黄金支撑:(HHV(VAR35,12)),COLORYELLOW;
DRAWTEXT(ISLASTBAR,黄金支撑,VARCAT(VAR2STR(黄金支撑,2),'←金支撑')),COLORYELLOW;
STICKLINE(CURRBARSCOUNT<=CONST(VAR37)+1 AND (C<REF(VAR38,BARSLAST(VAR36)) OR BARSLASTCOUNT(C>REF(VAR38,BARSLAST(VAR36)))<=3),VAR38,VAR38,2,0),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT<=CONST(VAR37)+1 AND BARSLAST(VAR36)=1,VAR38,VARCAT(VAR2STR(VAR38,2),'←上线3日买')),COLORGREEN,DRAWABOVE;
STICKLINE(VAR46,MIN(O,C),MIN(O,C)+(MAX(O,C)-MIN(O,C))/4,2.5,0),COLORBROWN;
DRAWTEXT(VAR46,LOW,'↑止'),COLORRED;
STICKLINE(CURRBARSCOUNT<=CONST(BARSLAST(VAR46))+1 AND BARSLAST(VAR46)>=0,REF(O,BARSLAST(VAR46)),REF(O,BARSLAST(VAR46)),4,0),COLOR0000BB;
DRAWTEXT(ISLASTBAR,REF(O,BARSLAST(VAR46)),VARCAT(VAR2STR(REF(O,BARSLAST(VAR46)),2),'←止损')),COLOR0000BB;
反转线:REF(H,BARSLAST(CONST(BARSLAST(VAR46))+4=CURRBARSCOUNT)),COLOR65EBD0,DOTLINE;
DRAWTEXT(ISLASTBAR,反转线,VARCAT(VAR2STR(反转线,2),'←反转')),COLOR65EBD0;
STICKLINE(VAR44,MIN(O,C),(O+C)/2,2.5,0),COLORLIGREEN;
DRAWTEXT(CURRBARSCOUNT=CONST(BARSLAST(VAR44))+1,MIN(O,C)+(MAX(O,C)-MIN(O,C))/4,'←王3'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=CONST(VAR45)+1,MIN(O,C)+(MAX(O,C)-MIN(O,C))/4,'←王2'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=CONST(REF(BARSLAST(VAR44),VAR45+2)+VAR45+2)+1,MIN(O,C)+(MAX(O,C)-MIN(O,C))/4,'←王1'),COLORGREEN;{公式平台,公式源码 HTTP://WWW.GSPT.COM}
DRAWTEXT_FIX(ISLASTBAR AND (VAR47+VAR49)/99>=200 AND (C/REF(C,1)-1)*100>=3,0.92,0.0,0,VARCAT(VARCAT('净买:',VAR2STR((VAR47+VAR49)/99,0)),'万')),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND (VAR47+VAR49)/99<-200 AND (C/REF(C,1)-1)*100<=-2,0.92,0.0,0,VARCAT(VARCAT('流出:',VAR2STR((VAR47+VAR49)/99,0)),'万')),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR AND VAR50<15,0.92,0.05,0,STRCAT('净流占比:',STRCAT(CON2STR(VAR50,0),'%'))),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND VAR50>=15,0.92,0.05,0,STRCAT('净流占比:',STRCAT(CON2STR(VAR50,0),'%'))),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0,1,0,VAR51),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.12,1,0,VAR52),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.23,1,0,VAR54),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR AND (C/LLV(C,10)-1)*100>=15,0.88,1,0,STRCAT('十日最大涨幅:',STRCAT(CON2STR((C/LLV(C,10)-1)*100,2),' %'))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR AND (C/LLV(C,10)-1)*100<15,0.88,1,0,STRCAT('十日最大涨幅:',STRCAT(CON2STR((C/LLV(C,10)-1)*100,2),' %'))),COLORWHITE;

《炸炸》指标截图:

资源下载
下载价格免费
指标公式下载安装问题请参阅网站顶部新手必读具体使用靠您自己学习完成,无培训服务
下载前请仔细阅读说明及配图介绍适合自己再下载指标公式是特殊商品一经下载概不退换
负责声明:
1、 本站所有指标公式源码资源均是从网络采集和会员提供所得,仅供用来学习研究,请于下载后的24h内自行删除,正式商用请购买正版。如若本站内容侵犯了原著者的合法权益,请携带相关版权文件联系我们进行下架或删除。
2、文章内文字内容均为本站原创发布,任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。原文链接:https://www.zhibiao123.cn/158319.html,转载请注明出处。
通达信《鱼窝打分+鱼游打分+鱼仙股池》2023升级版全套指标源码,手机通用!
通达信《鱼窝打分+鱼游打分+鱼仙股池》2023升级版全套指标源码,手机通用!
6分钟前 有人购买 去瞅瞅看
温馨提示:本站暂不支持手机端在线支付,请您在电脑端扫码完成支付!
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录